CEL flashed last night, dealer no help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > CEL flashed last night, dealer no help

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueRough Country Lift Kits and Parts!

Reply
Unread 02-13-2014, 10:15 AM   #1
jdl1325
Registered User
2010 WK 
 
Join Date: Nov 2011
Location: Tampa, FL
Posts: 6
CEL flashed last night, dealer no help

I have a 2010 Jeep Grand Cherokee with 80k miles on it.

So, my check engine light came on a few days ago and I assumed it was the common gascap/emission leak error. I went to Autozone yesterday during lunch and they read the code and confirmed as much.

Then last night driving home in dense, stop-and-go traffic for about an hour, the CEL started flashing, of course freaking me out. My jeep idled rough and accelerated sluggishly for my last mile home.

So, this morning I wake up and the CEL isn't on at all, but I still take it to the dealership. They pull their own code, but again the only thing thing they get is a gascap/emission error.

They really didn't have any recommendation besides replacing the ESIM switch, but they conceded that they didn't believe that is what caused the problem.

I replaced my spark plugs 1 year ago and again their was not a code indicating a misfire.

Any suggestions on what to do from here?

Also, still no CEL light driving to the dealership or from the dealership to work.


Last edited by jdl1325; 02-13-2014 at 10:27 AM..
jdl1325 is offline   Reply With Quote
Unread 02-13-2014, 11:50 AM   #2
xSoFx
Registered User
2006 WK 
 
Join Date: Jun 2013
Location: , Iowa
Posts: 79
Not sure if it's of much help, but I once changed out the plugs in my JK and somehow managed to not connect one of the plug wires. Started it up, rough idle. Figured it was just the PCM relearn, started driving and a CEL started flashing. Pulled over and saw the plug boot just laying there.
xSoFx is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.