post #1 of Old 02-13-2014, 10:15 AM Thread Starter
jdl1325
Registered User
2010 WK 
 
Join Date: Nov 2011
Location: Tampa
Posts: 6
CEL flashed last night, dealer no help

I have a 2010 Jeep Grand Cherokee with 80k miles on it.

So, my check engine light came on a few days ago and I assumed it was the common gascap/emission leak error. I went to Autozone yesterday during lunch and they read the code and confirmed as much.

Then last night driving home in dense, stop-and-go traffic for about an hour, the CEL started flashing, of course freaking me out. My jeep idled rough and accelerated sluggishly for my last mile home.

So, this morning I wake up and the CEL isn't on at all, but I still take it to the dealership. They pull their own code, but again the only thing thing they get is a gascap/emission error.

They really didn't have any recommendation besides replacing the ESIM switch, but they conceded that they didn't believe that is what caused the problem.

I replaced my spark plugs 1 year ago and again their was not a code indicating a misfire.

Any suggestions on what to do from here?

Also, still no CEL light driving to the dealership or from the dealership to work.


Last edited by jdl1325; 02-13-2014 at 10:27 AM.
jdl1325 is offline  
post #2 of Old 02-13-2014, 11:50 AM
xSoFx
Registered User
1987 XJ Cherokee 
 
Join Date: Jun 2013
Posts: 82
Not sure if it's of much help, but I once changed out the plugs in my JK and somehow managed to not connect one of the plug wires. Started it up, rough idle. Figured it was just the PCM relearn, started driving and a CEL started flashing. Pulled over and saw the plug boot just laying there.
xSoFx is offline  
Reply

Tags
cel , flashing cel , gas cap , rough idle


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome