Car won't start, Service Electric Brake System light comes on - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Car won't start, Service Electric Brake System light comes on

2014 Spartan Locker Special - While Supplies Last! Dana 3The Original 3/8" Ruffstuff Diff Cover!The RuffStuff "I can't go to EJS" Sale!

Reply
Unread 02-07-2012, 11:44 PM   #1
aquintana06
Registered User
2005 WK 
 
Join Date: Feb 2012
Location: Tallahassee, Florida
Posts: 1
Car won't start, Service Electric Brake System light comes on

I have a 05 Grand Cherokee Laredo that won't start without a jump, all the electrical stuff works (lights, radio, etc) and the battery is relatively new. Also an error message pops up about the electric brake system. Any ideas?

aquintana06 is offline   Reply With Quote
Unread 02-08-2012, 01:18 PM   #2
BlueSteelJP
Registered User
2005 WK 
 
Join Date: Apr 2009
Location: Maine
Posts: 253
Probably two different issues, still sounds like a battery or a battery connection, can you do a load test on the new battery?
__________________
Blue WK Club Member #10


2005 Jeep Grand Cherokee Limited, 5.7 Liter Hemi no Mods So Far.
BlueSteelJP is offline   Reply With Quote
Unread 02-08-2012, 05:13 PM   #3
JKM
Registered User
2005 WK 
 
Join Date: Dec 2008
Location: Toronto, Ontario
Posts: 394
when you're jumping the Jeep are you connecting the ground jumper cable to the engine block? If so, then maybe you have a bad ground to the engine. To verify, connect the ground jumper cable from the Jeep battery (neg) to the engine block, this will basically act as a temporary second ground cable. If it starts your ground cable is bad, likely a dirty connection at the battery or the engine block. Engine block ground connection just above the starter
JKM is offline   Reply With Quote
Unread 06-18-2013, 07:51 PM   #4
justinmay1982
Registered User
2005 WK 
 
Join Date: Jul 2012
Location: Northville, NY
Posts: 1
I too have the same exact problem.

All of the sudden my 2005 Jeep Grand Cherokee started having this message service electric brake system. Now every time I leave my vehicle for any amount of time it drains my battery down and it wont start until I put jumper cables on it. So whatever has to do with the electric brake system is shorting out the battery. I did hit a few pot holes pretty hard and this happened soon after. I have been having to drive on rough road daily because they tore my road up to repave. I have examined the wires that come down to the wheel speed sensor without taking the tire off and they seem fine from what I can see. Could a bad sensor drain my battery? Any help would greatly be appreciated thanks in advance.
justinmay1982 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.