a/c problems 2006 wh grand cherokee - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > a/c problems 2006 wh grand cherokee

Spartan Locker's at all time LOW exclusive from ROCKRIDGE FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Bds fox ipf 2.0 racing series shocks now available at rock

Reply
Unread 03-27-2015, 10:32 PM   #1
troy123
Registered User
 
Join Date: Feb 2014
Location: banora point, nsw
Posts: 13
a/c problems 2006 wh grand cherokee

one day i was driving with the a/c on and it just stopped then the next day it started working again on all settings i turned the car off but I left it on no 3 blower setting when I started the car and it turned on for a moment then stopped and would not come on again. i decided i would buy a ac/heater control module as it was only $200 i waited 3 weeks for that to come with no a/c i installed it and i still had no aircon then the next day i started the car as the blower setting was on 2 and it worked, it worked fine for 3 weeks and now it has stopped again. I checked the blower motor and it works fine (hooked it up to 12v) i do not have AC on hi setting, my next move is to replace the blower motor resistor just to eliminate it. has anyone else had this problem and if so how do you fix it.

troy123 is offline   Reply With Quote Quick reply to this message
Unread 03-28-2015, 05:45 AM   #2
JKM
Registered User
2005 WK 
 
Join Date: Dec 2008
Location: Toronto, Ontario
Posts: 457
My first guess would have been the resistor
JKM is online now   Reply With Quote Quick reply to this message
Unread 04-01-2015, 02:49 AM   #3
troy123
Registered User
 
Join Date: Feb 2014
Location: banora point, nsw
Posts: 13
Just changed the blower resister still does now work. So now I have eliminated front control panel, HVAC blower, all fuses and relays, blower resister I'm now thinking it could be a bad ground does anyone know if there is a computer that the a/c runs off? Or has any idea what I could try next?
troy123 is offline   Reply With Quote Quick reply to this message
Unread 04-24-2015, 06:49 PM   #4
troy123
Registered User
 
Join Date: Feb 2014
Location: banora point, nsw
Posts: 13
Just changed the ignition switch still nothing. I have ran out of ideas will have to take it to the stealer please help
troy123 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.