brake issue - pads not completely releasing? -

LinkBack Thread Tools
post #1 of 2 Old 12-28-2013, 09:00 AM Thread Starter
Registered User
2005 WK 
Join Date: Dec 2013
Location: gray
Posts: 35
brake issue - pads not completely releasing?

For lack of a better term. It's causing squealing.

Is there a "common" issue with this?

2005 Laredo, HD factory suspension & class IV tow group, qt2 with 67xxx miles. Brakes were just serviced a few weeks ago. We do use our parking brake when we park. The calipers are a bit rusty though. (Was a rust belt/Florida vehicle)

1964 Jeep Wagoneer Panel Delivery - work in slow progress
2005 Grand Cherokee Laredo QTII 4x4 - stock for now

Last edited by suzq044; 12-28-2013 at 09:16 AM.
suzq044 is offline  
Sponsored Links
post #2 of 2 Old 12-28-2013, 11:27 AM
Registered User
2000 XJ Cherokee 
Join Date: May 2008
Location: Victoria
Posts: 3,588
Calipers are probably shot... the pistons get rusty/cruddy and will not retract all the way in. That is my guess.

2000 Jeep Cherokee Classic XJ - 2005 Jeep Grand Cherokee LTD 5.7L WK - CDN M101 1/4 Ton Trailer

l l ,[_____],
l---- L -[]lllllll[]-

()_) ()_)--o-)_)
GregB_00XJ is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome