Black Betty Build Thread - Page 3 - JeepForum.com

 6Likes
Reply
 
LinkBack Thread Tools
post #31 of 159 Old 11-18-2015, 06:55 PM Thread Starter
05BlackWK
Registered User
2005 WK 
 
Join Date: Jun 2014
Location: Charlotte
Posts: 156
Garage
Heading up to my brothers house in raleigh for the install tomorrow! My wheels and tires are on the way as we speak! I should have the whole thing together with the tires around this time next week! I'll try and take plenty of pics during the install. I'm packed to the brim with car parts

Attached Thumbnails
IMG_20151118_144633243.jpg   IMG_20151118_144639499.jpg   IMG_20151118_144659885.jpg  
05BlackWK is offline  
Sponsored Links
Advertisement
 
post #32 of 159 Old 11-18-2015, 07:21 PM
sheepdog918
Registered User
2007 WK 
 
Join Date: May 2014
Location: Russell Springs
Posts: 823
Quote:
Originally Posted by 05BlackWK View Post
Heading up to my brothers house in raleigh for the install tomorrow! My wheels and tires are on the way as we speak! I should have the whole thing together with the tires around this time next week! I'll try and take plenty of pics during the install. I'm packed to the brim with car parts
Packed to the brim with car parts -AND- a Christmas tree lol

There are the wolves, there are the sheep, but then, there are the Sheepdog's
sheepdog918 is offline  
post #33 of 159 Old 11-19-2015, 08:49 AM Thread Starter
05BlackWK
Registered User
2005 WK 
 
Join Date: Jun 2014
Location: Charlotte
Posts: 156
Garage
Quote:
Originally Posted by sheepdog918 View Post
Packed to the brim with car parts -AND- a Christmas tree lol
05BlackWK is offline  
 
post #34 of 159 Old 11-19-2015, 09:11 AM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,688
looks like youre going to have a nice build. I love the matrix bumper with the stinger.


aren't you worried about your rack and your hub to fender measurement being over 23"?


looking forward to seeing the end results and how you like those 5100s in the rear.

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #35 of 159 Old 11-21-2015, 12:33 AM Thread Starter
05BlackWK
Registered User
2005 WK 
 
Join Date: Jun 2014
Location: Charlotte
Posts: 156
Garage
What a long day...

Started at around 9 and finished up at around 1:30 in the morning, an all day project. Ran into so many tedious and annoying things that took a lot of backtracking and were a pain to fix. But I managed to get everything installed; I am kind of nervous however, as I do not completely trust me and my brothers "DIY" work.

The back was fairly simple, the biggest pain was the front. It took forever having to work around the engine compartment to reach the UCA and strut bolts. I set the front strut to 2" for the max lift.

It did seem to give me a rather significant lift I will post the before and after pics tomorrow since I could not do it today since I was up past midnight

There was one problem though; it was pretty strange. When I reconnected the battery my brights automatically turned on without the car turning on.... I then went to turn the car on..... I had no control over the lights; couldn't set to parking lights or turn off the brights.... I drove around for a little bit then the brights cut off but I could not turn them back on or use my turn signals. At least now I don't worry about the battery dying overnight, but it is still something that I have no clue that it could be and needs to be fixed. Any ideas? Any info would be appreciated.
05BlackWK is offline  
post #36 of 159 Old 11-21-2015, 08:11 AM
JakeWK
Registered User
2005 WK 
 
Join Date: Mar 2015
Location: Fresno
Posts: 1,172
need to do more digging... i definitely recall seeing this happen on another thread. Guy lifted and then had light issues.

05 WK HEMI


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

USN Jeep Club
CentralCaL 4X4
Colorado 4X4
JakeWK is offline  
post #37 of 159 Old 11-21-2015, 09:04 AM Thread Starter
05BlackWK
Registered User
2005 WK 
 
Join Date: Jun 2014
Location: Charlotte
Posts: 156
Garage
All lights work now no problem.

On my way home now. 3 hour. Wish me luck.

There is kind of a knocking sound on front passenger side. I'll keep and eye/ear out. Any ideas
05BlackWK is offline  
post #38 of 159 Old 11-21-2015, 10:23 AM
paroxysym
Registered User
2007 WK 
 
Join Date: Jan 2005
Location: Baltimore
Posts: 4,688
So you set the 5100s to 2" and added a OME HD to them? Hope you budgeted a new rack in your future.

2007.5 WK Laredo 4.7
OEM+
paroxysym is offline  
post #39 of 159 Old 11-21-2015, 02:03 PM
youngPreacher
Registered User
2006 XK Commander 
 
Join Date: Feb 2015
Location: st augustine
Posts: 245
Garage
Yeah, I'm interested in the hub/flare measurement

~XKs LEAD THE WAY.~ '06 XK.Hemi.SCT 3872.Modified Rusty's lift
youngPreacher is offline  
post #40 of 159 Old 11-21-2015, 04:49 PM
youngPreacher
Registered User
2006 XK Commander 
 
Join Date: Feb 2015
Location: st augustine
Posts: 245
Garage
Down travel difference

Quote:
Originally Posted by KillaJeep4569 View Post
Just to let you know the OME Struts and Shocks have a Longer Down travel than the Bilstiens and also have a beefier Piston. That is why I went OME. I will be Putting on 33"s next week once The Rims come in.

What is the down travel difference between the OME and 5100

~XKs LEAD THE WAY.~ '06 XK.Hemi.SCT 3872.Modified Rusty's lift
youngPreacher is offline  
post #41 of 159 Old 11-21-2015, 05:30 PM
eMc9002
Registered User
2007 WK 
 
Join Date: Dec 2013
Location: Raleigh
Posts: 241
Your pretty much doing the same setup as me, I'm starting on mine in 2 weeks when I get some time off. In Raleigh aswell with a blacked out WK. Look forward to seeing pics!

07 WK 4.7L V8 Limited l Flowmaster 44 l Spidertrax 1.5" l JK Moab's l Black WK #137.
eMc9002 is offline  
post #42 of 159 Old 11-21-2015, 06:12 PM Thread Starter
05BlackWK
Registered User
2005 WK 
 
Join Date: Jun 2014
Location: Charlotte
Posts: 156
Garage
My rack fits fine in my garage right now.... Shouldn't be too bad once I get the tires
05BlackWK is offline  
post #43 of 159 Old 11-21-2015, 06:24 PM
Sneaky2Toes
Registered User
2005 WK 
 
Join Date: Dec 2011
Location: Logan
Posts: 243
I am curious too on what the height difference is between the 5100's on the lowest setting and the OME HD. I would like to add about 1/2" to my front (I have OME struts) and am interested to see if the 5100's will do it.
Sneaky2Toes is offline  
post #44 of 159 Old 11-21-2015, 07:18 PM
JordanD07
Registered User
2007 WK 
 
Join Date: Jan 2011
Location: Atlanta
Posts: 333
Quote:
Originally Posted by 05BlackWK View Post
My rack fits fine in my garage right now.... Shouldn't be too bad once I get the tires
By rack, parox meant steering rack

'07 3.7 4x4 QT1 ll Red WK Club #27 ll OME ll Monroe LL ll Rusty's ll ProComp ll BFG ll 4xGuard ll S4XC ll VLEDS ll Infinity ll Thrush ll Riddler ll 6K HID
JordanD07 is offline  
post #45 of 159 Old 11-21-2015, 08:20 PM Thread Starter
05BlackWK
Registered User
2005 WK 
 
Join Date: Jun 2014
Location: Charlotte
Posts: 156
Garage
Quote:
Originally Posted by JordanD07 View Post
By rack, parox meant steering rack
ah... I can feel the turning the gears a lot more. Nothing too major though. Hopefully it doesn't get to bad. Have any other people had problems?
05BlackWK is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome