bilstein 5100's - JeepForum.com
 2Likes
  • 1 Post By Kman09JGC
  • 1 Post By nutjobrob
 
LinkBack Thread Tools
post #1 of 14 Old 03-18-2016, 01:22 PM Thread Starter
cotman1
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2007
Location: providence forge, virginia
Posts: 23
bilstein 5100's

I've searched lifts, level, front only and the pic thread. What I'm interested in seeing is those struts @ the 1.5" setting and that's it. No spacers front OR rear just them set @ 1.5" . And what I call level is NOT wheel well to center of the hub, but more like bottom edge of rocker panel,(front and rear) no rake .....just level. Pics would best, especially with srt8 wheels.....but level is my primary concern. thanks in advance

cotman1 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 03-18-2016, 02:25 PM
Kman09JGC
Registered User
 
Join Date: Sep 2010
Location: Twinsburg, OH
Posts: 382
Garage
At the 1.5 inches in the front and nothing in the back just the 5100 shocks your front maybe a little higher than the back. I have mine set at .75 inches with just the 5100's in the back and its level.
Attached Images
 

09 laredo 28x 4.7 w/QD2 Superchip w/91 perf tune w/ trans app, jet 180 tstat,K&N CAI, bistein 5100 struts and shocks, srt8 front and rear swaybars, 255/65/17 General Grabber at2's.
Black WK Club #107
Kman09JGC is offline  
post #3 of 14 Old 03-18-2016, 02:33 PM Thread Starter
cotman1
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2007
Location: providence forge, virginia
Posts: 23
Ok cool .....what size tires are you running?
cotman1 is offline  
 
post #4 of 14 Old 03-18-2016, 02:52 PM
Kman09JGC
Registered User
 
Join Date: Sep 2010
Location: Twinsburg, OH
Posts: 382
Garage
255/65/17 general grabber at2's
cotman1 likes this.

09 laredo 28x 4.7 w/QD2 Superchip w/91 perf tune w/ trans app, jet 180 tstat,K&N CAI, bistein 5100 struts and shocks, srt8 front and rear swaybars, 255/65/17 General Grabber at2's.
Black WK Club #107
Kman09JGC is offline  
post #5 of 14 Old 03-18-2016, 03:01 PM
nutjobrob
Registered User
 
Join Date: Mar 2016
Posts: 1
Good thread. I've been searching for the same. Thanks you, Kman, for the info and photo.
cotman1 likes this.
nutjobrob is offline  
post #6 of 14 Old 03-18-2016, 03:43 PM
Kman09JGC
Registered User
 
Join Date: Sep 2010
Location: Twinsburg, OH
Posts: 382
Garage
No problem good luck

09 laredo 28x 4.7 w/QD2 Superchip w/91 perf tune w/ trans app, jet 180 tstat,K&N CAI, bistein 5100 struts and shocks, srt8 front and rear swaybars, 255/65/17 General Grabber at2's.
Black WK Club #107
Kman09JGC is offline  
post #7 of 14 Old 03-18-2016, 04:28 PM Thread Starter
cotman1
Registered User
1997 TJ Wrangler 
 
Join Date: Oct 2007
Location: providence forge, virginia
Posts: 23
Quote:
Originally Posted by Kman09JGC View Post
255/65/17 general grabber at2's
sorry I was on my phone earlier and didn't see the info in the signature.
cotman1 is offline  
post #8 of 14 Old 06-11-2016, 11:29 AM
bromarc
Registered User
2007 WK 
 
Join Date: Jul 2015
Location: Ferndale
Posts: 165
Noob question for install: Am I going to need a spring compressor for removing the OEM springs from old fronts and putting them on the 5100s?

07 CRD Ltd QDII: GDE ECO, 255/70/18, 3/4" BORA, 5100s
bromarc is offline  
post #9 of 14 Old 06-11-2016, 02:32 PM
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville
Posts: 2,664
Uhh..yeah. Good ones.

If there's a garage near your house, take your stuff there and ask them to do it for you...worth the small fee. If you're not familiar with the process it's dangerous and even if you are it's a pain.
caulk04 is offline  
post #10 of 14 Old 06-11-2016, 03:52 PM
luckyse7ens
Registered User
2010 XK Commander 
 
Join Date: Jun 2014
Location: concord
Posts: 1,950
I ran my xk @ 1.5" front and tossed in two extra spring isolators In the rear for about .5" rear lift. Looked level. Ran that with 255/70r18s and pinchweld mod. Only slight rubb when turning while flexing it out and that was likely due to reduced back spacing on the custom wheels.
luckyse7ens is offline  
post #11 of 14 Old 06-24-2016, 07:56 PM
jhtopilko
Registered User
2008 WK 
 
Join Date: Jun 2011
Location: Edmonton
Posts: 36
Commanders only have two settings 1.2" and 2" , they aren't supposed to use the highest setting available for grand Cherokee. With the grand Cherokees lighter springs they need the top setting for 2".

5100s at .75". Tire 265/6018

on fuelly jhtmpg
jhtopilko is offline  
post #12 of 14 Old 06-27-2016, 02:04 PM
bromarc
Registered User
2007 WK 
 
Join Date: Jul 2015
Location: Ferndale
Posts: 165
Quote:
Originally Posted by caulk04 View Post
Uhh..yeah. Good ones.

If there's a garage near your house, take your stuff there and ask them to do it for you...worth the small fee. If you're not familiar with the process it's dangerous and even if you are it's a pain.
Did the install this weekend. You were not wrong about the pain in the *** part.

07 CRD Ltd QDII: GDE ECO, 255/70/18, 3/4" BORA, 5100s
bromarc is offline  
post #13 of 14 Old 06-27-2016, 06:53 PM
luckyse7ens
Registered User
2010 XK Commander 
 
Join Date: Jun 2014
Location: concord
Posts: 1,950
Quote:
Originally Posted by jhtopilko View Post
Commanders only have two settings 1.2" and 2" , they aren't supposed to use the highest setting available for grand Cherokee. With the grand Cherokees lighter springs they need the top setting for 2".
Yeah this is the second time that I have heard that.

I have been running mine on the max setting for awhile (a year? 15k miles maybe), and I am running a rustys strut spacer as well.

When I ordered my bilsteins there was no paperwork that indicated that.

No issues.

That warning makes no sense to me. Its the same suspension as the WK.

Black WK Club #152
luckyse7ens is offline  
post #14 of 14 Old 06-27-2016, 06:54 PM
luckyse7ens
Registered User
2010 XK Commander 
 
Join Date: Jun 2014
Location: concord
Posts: 1,950
Quote:
Originally Posted by caulk04 View Post
Uhh..yeah. Good ones.

If there's a garage near your house, take your stuff there and ask them to do it for you...worth the small fee. If you're not familiar with the process it's dangerous and even if you are it's a pain.
I used the crappy ones from the local autoparts store free rental.

I'm still alive.

I wouldn't recommend it though.

Black WK Club #152
luckyse7ens is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome