Battery died & check 4wd system came on - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 10-19-2009, 08:23 AM Thread Starter
Jblondie813
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2009
Location: jackonville NC
Posts: 48
Battery died & check 4wd system came on

I have an 05 GC. I went out to leave for work 2day and the battery was completely DEAD. The keyless entry wouldn't even unlock the doors. Absolutely NO juice. When I turned the key..nothing. So I got a jump and then after I got to my destination, I turned it off and back on and it works fine now. But ever since I got it running again, it now says "service 4wd system" in the message center. I have also experienced some jerking when accelerating at about 35-40mph. I have heard alot about them needing updated.. the computer system needs reflashed or something. My cherokee is no longer under warranty.
What do you think is wrong with it? & what can I do to fix it? Is it something I can do myself?
PLEASE Help!!


1994 YJ 4.7L Stroker, 32" Coopers on 15"s, 7500 lb winch, 2" BL, Rugged Ridge Heavy Duty Tie rod & Drag link, Rancho steering stabilizer, RE steel braided brake hoses, on board air, heavy duty bumper & tire carrier...
2005 WK- Grand Cherokee Ltd w/4.7L V8
Jblondie813 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 10-19-2009, 10:27 AM
brutusjeep
Member
2014 WK 
 
Join Date: May 2009
Location: Colorado
Posts: 406
Same thing on my '06. Is the battery original? If so, I would say replace it first. I'm sure you could use a flash update at this point. Not sure with the accelerating issue, that could be anything. This happened to my wife three or four times. It took me going to the dealer and having it happen to them.

2014 - Summit
Sold - 2006 GC Limited, 5.7L HEMI, Quad II. 4XGUARD Belly & Front (black powder coat) skid plates. Matrix front guard, PIAA Matrix mounted lights, 265/70 Nitto Trail Graplers MT, 1.5" Spider Trax spacers, Super Chips Tuner, OME MD Lift, 4XGUARD differential guard, JBA UCA'S.
brutusjeep is offline  
post #3 of 8 Old 10-19-2009, 12:38 PM
scottydog
Registered User
2017 WK 
 
Join Date: Jan 2005
Posts: 340
Agree, try a new battery. And let the car sit for 30 minutes with the battery disconnected, to reset the computers.
scottydog is offline  
 
post #4 of 8 Old 10-19-2009, 02:30 PM Thread Starter
Jblondie813
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2009
Location: jackonville NC
Posts: 48
Thanks for responding guys! Sooo now the msg is gone & hasn't come up in the last 3 times it was started. I ran errands 2day and the battery was fine and no more "service 4wd" msg! WEIRD! I am still going to look into getting the computer update.
So now I just wait and see if the battery goes again! I can't believe it just died out of the blue and its only 40 degrees out, the cold shouldn't have made it die...

1994 YJ 4.7L Stroker, 32" Coopers on 15"s, 7500 lb winch, 2" BL, Rugged Ridge Heavy Duty Tie rod & Drag link, Rancho steering stabilizer, RE steel braided brake hoses, on board air, heavy duty bumper & tire carrier...
2005 WK- Grand Cherokee Ltd w/4.7L V8
Jblondie813 is offline  
post #5 of 8 Old 10-19-2009, 03:01 PM
scottydog
Registered User
2017 WK 
 
Join Date: Jan 2005
Posts: 340
So the computer reset itself.

If your battery is the 4 year old original just replace it.
scottydog is offline  
post #6 of 8 Old 10-19-2009, 03:58 PM
dwp1975
Registered User
2006 XK Commander 
 
Join Date: Jun 2009
Location: Rockville, MD
Posts: 114
My battery on my 06 XK died right in my drive way. I needed a new battery because of a bad cell. As for the jerking, there is a TSB for it. It has to do with reflashing the computer. There is a gearing locking in 3rd I believe (atleast for the XK). I contacted my dealership about it and have yet to hear about it. When they usually are prompt with getting back to me.

2006 Jeep Commander v8
dwp1975 is offline  
post #7 of 8 Old 10-22-2009, 12:28 PM Thread Starter
Jblondie813
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2009
Location: jackonville NC
Posts: 48
Quote:
Originally Posted by dwp1975 View Post
My battery on my 06 XK died right in my drive way. I needed a new battery because of a bad cell. As for the jerking, there is a TSB for it. It has to do with reflashing the computer. There is a gearing locking in 3rd I believe (atleast for the XK). I contacted my dealership about it and have yet to hear about it. When they usually are prompt with getting back to me.
hmm thats very interesting.. I did read about the jerking at 35-40mph and that a reflash would most likely fix it. But I didnt know what the jerking was exactly.

1994 YJ 4.7L Stroker, 32" Coopers on 15"s, 7500 lb winch, 2" BL, Rugged Ridge Heavy Duty Tie rod & Drag link, Rancho steering stabilizer, RE steel braided brake hoses, on board air, heavy duty bumper & tire carrier...
2005 WK- Grand Cherokee Ltd w/4.7L V8
Jblondie813 is offline  
post #8 of 8 Old 10-22-2009, 12:35 PM Thread Starter
Jblondie813
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2009
Location: jackonville NC
Posts: 48
So my battery is fine now! It hasn't died since Monday morning... The service 4wd system light hasn't come on since monday.. BUT when my husband took it to work yesterday the "check oil" light came on!! GEEZ.. so I took it around the block yesterday and the light didn't turn on and I was trying to do all kinds of things to possibly trigger the light to come on again.. I checked the oil..the oils fine! Its not due for an oil change yet. But the light still hasnt come on again!

Does this stuff sound like problems that could be fixed with the reflash??

1994 YJ 4.7L Stroker, 32" Coopers on 15"s, 7500 lb winch, 2" BL, Rugged Ridge Heavy Duty Tie rod & Drag link, Rancho steering stabilizer, RE steel braided brake hoses, on board air, heavy duty bumper & tire carrier...
2005 WK- Grand Cherokee Ltd w/4.7L V8
Jblondie813 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Check Gauges/ Check Battery sunflash2012 ZJ Grand Cherokee Forum 7 11-06-2009 08:47 AM
02 GC Battery died last night, no warning that it was going. Valkyrie0002 ZJ Grand Cherokee Forum 5 08-15-2008 07:26 PM
Nav system died? m Crazypilotgal WK Grand Cherokee & XK Commander Forum 5 02-02-2008 10:00 AM
94zj - 5.2 Battery died, replaced, won't idle? PdMV ZJ Grand Cherokee Forum 7 01-10-2006 05:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome