Audio Issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > Audio Issue

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueSPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!Jeep Grand Cherokee Mirror - Side View

Reply
Unread 11-12-2013, 01:45 PM   #1
thewarshrew
Registered User
2008 WK 
 
Join Date: Nov 2013
Location: Sudbury, Ontario
Posts: 11
Audio Issue

I have a 2008 3.0L Grand Cherokee with the premium sound option with the RER CD/GPS Navigation Unit. I was driving to work today and every speaker in the truck (except the passenger side "tweet") stopped working. Not only that but to even get sound out of it I have to go to max volume. Has any one ever had issues with the amps on these things?

thewarshrew is offline   Reply With Quote
Unread 11-12-2013, 02:16 PM   #2
JRLT
Registered User
2010 WK 
 
Join Date: Aug 2011
Location: Lower Brule, South Dakota
Posts: 1,356
Sounds like you blew the voice coils.
__________________
2010 3.7L, 4XGuard Matrix, Fastman TB, TB Ground Mod, Injen CAI, 255/60/18 Nitto Terra Grapplers, Bilstein Shocks & Struts, Cruiser Alloy Wheels - Switchblade, Stillen Brakes, Cargo Light Strip Mod, Electric Ashtray Mod, Jet-powered, Monkey Navigated...
JRLT is offline   Reply With Quote
Unread 11-12-2013, 02:27 PM   #3
thewarshrew
Registered User
2008 WK 
 
Join Date: Nov 2013
Location: Sudbury, Ontario
Posts: 11
So I replaced the driver side tweet with a new speaker and it still doesn't work. I would just like to add that the passenger side speaker that is working only works when the volume is maxed out. I don't really feel like replacing all the speakers if I still won't have any audio coming out of all speakers.
thewarshrew is offline   Reply With Quote
Unread 11-12-2013, 05:45 PM   #4
RUGLAYR
Registered User
 
Join Date: Sep 2013
Posts: 36
Sounds like a amp issue
RUGLAYR is offline   Reply With Quote
Unread 11-13-2013, 06:28 AM   #5
thewarshrew
Registered User
2008 WK 
 
Join Date: Nov 2013
Location: Sudbury, Ontario
Posts: 11
Any way to test the amp(Other then power & ground that is)? That is above the driver side rear tire behind the plastic molding right?
thewarshrew is offline   Reply With Quote
Unread 11-13-2013, 10:56 AM   #6
Blue_Sassley
Registered User
2008 WK 
 
Join Date: Oct 2012
Location: Minneapolis, MN
Posts: 71
Yeah the amp is behind that rear panel:

http://wkjeeps.com/interior_trim.htm#QUARTER

Blue
__________________
2008 Grand Cherokee Laredo CRD - QDII - GDE Tune Oct 2013 - DPF delete by tnadanzig
2002 Grand Cherokee Laredo 4.7L - ST - Stock (Wreaked)
1999 Grand Cherokee Laredo 4.0L - QTII - Stock
1997 Grand Cherokee Laredo 4.0L - ST - Stock (Wreaked)
Blue_Sassley is offline   Reply With Quote
Unread 11-14-2013, 09:40 AM   #7
thewarshrew
Registered User
2008 WK 
 
Join Date: Nov 2013
Location: Sudbury, Ontario
Posts: 11
I ordered an amplifier and it comes in tonight. We shall see if that fixes it.
thewarshrew is offline   Reply With Quote
Unread 11-14-2013, 10:00 AM   #8
Blue_Sassley
Registered User
2008 WK 
 
Join Date: Oct 2012
Location: Minneapolis, MN
Posts: 71
Quote:
Originally Posted by thewarshrew View Post
I ordered an amplifier and it comes in tonight. We shall see if that fixes it.
Where did you get it? Just in case this would happened in the future for me?

Blue
__________________
2008 Grand Cherokee Laredo CRD - QDII - GDE Tune Oct 2013 - DPF delete by tnadanzig
2002 Grand Cherokee Laredo 4.7L - ST - Stock (Wreaked)
1999 Grand Cherokee Laredo 4.0L - QTII - Stock
1997 Grand Cherokee Laredo 4.0L - ST - Stock (Wreaked)
Blue_Sassley is offline   Reply With Quote
Unread 11-14-2013, 02:12 PM   #9
thewarshrew
Registered User
2008 WK 
 
Join Date: Nov 2013
Location: Sudbury, Ontario
Posts: 11
From the Dodge Jeep dealer... Almost 500 retail
thewarshrew is offline   Reply With Quote
Unread 11-14-2013, 02:58 PM   #10
ttusqrl
WK Supporter
2005 WK 
 
Join Date: Oct 2007
Location: Dallas, TX
Posts: 406
Quote:
Originally Posted by thewarshrew View Post
From the Dodge Jeep dealer... Almost 500 retail
Wish I would have seen this earlier -- I have my old one laying around.
__________________
2005 WK Limited 5.7 ORT | OME HD | Saguaro Front Winch Bumper| Warn Zeon 10s | 17" Moabs w custom powder coat | 265/70/17 BFG TA KO | 1.5" Spidertrax | AIRAID CAI | Gibson 3" Exhaust | DiabloSport Intune | XD 5000K HIDs | JL Stealthbox w A1300 Amp | Valentine 1

WANTED (PM if Selling): Gobi Roof Rack, 4XG Armor, MyGig RHR & Lockpick, Catch Can, Rear Diff Cover, Weathertechs / Quadratec Mats
ttusqrl is offline   Reply With Quote
Unread 11-15-2013, 07:32 AM   #11
thewarshrew
Registered User
2008 WK 
 
Join Date: Nov 2013
Location: Sudbury, Ontario
Posts: 11
After replacing the amp, all my Audio issues have been resolved! Thank you everyone, I appreciate it
thewarshrew is offline   Reply With Quote
Unread 11-15-2013, 11:52 AM   #12
RUGLAYR
Registered User
 
Join Date: Sep 2013
Posts: 36
Good to hear that you resolved the issue
RUGLAYR is offline   Reply With Quote
Unread 11-18-2013, 07:06 AM   #13
thewarshrew
Registered User
2008 WK 
 
Join Date: Nov 2013
Location: Sudbury, Ontario
Posts: 11
So everything was working good until yesterday, now I have the same issue again. I am thinking my head unit is causing my amps to burn out or stop working. Any ideas?

Last edited by thewarshrew; 11-18-2013 at 07:12 AM.. Reason: missed a few key words
thewarshrew is offline   Reply With Quote
Unread 11-18-2013, 07:10 AM   #14
RUGLAYR
Registered User
 
Join Date: Sep 2013
Posts: 36
Yes something is causing them to burn out. Check your power to see what kind of reading your getting at the amp
RUGLAYR is offline   Reply With Quote
Unread 11-18-2013, 12:21 PM   #15
thewarshrew
Registered User
2008 WK 
 
Join Date: Nov 2013
Location: Sudbury, Ontario
Posts: 11
I am picking up some extra hours this week so I might not get to it until the weekend... Just asking, but am I checking for power or am I checking for anything else? Haha just trying to gather a half decent plan of attack
thewarshrew is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.