Another Coolant issue.. -

LinkBack Thread Tools
post #1 of 4 Old 11-16-2013, 07:13 AM Thread Starter
Registered User
2005 WK 
Join Date: Nov 2013
Location: Burgbernheim
Posts: 5
Another Coolant issue..

Hello all, I am new to this forum and also to the jeep world. I'm currently stationed in germany and I purchased a 2005 jeep grand cherokee for my wife and now having coolant issues. I did a hefty amount of searching but could not find a right answer or a help to the issue. I noticed a few weeks back that it was leaking coolant from the lower radiator hose. I had the jeep dealership just put a new clamp around it and filled it up with coolant. he pressure tested it and it was not leaking from there anymore so i figured it was fixed. I noticed today that there is spot on the driveway where my wife parks. I thought it was just water so I touched and smelt it and it was coolant. So I popped the hood and the coolant tank is almost empty. Here is a picture of what i am talking about. Sorry for how big it is i resized it on photobucket but doesnt seem to get smaller

I do not know what is wrong now. I started it up and watched under and didnt see anything leaking and shut it off and watched and nothing. Im not sure if it leaks when it is up to temp or just randomly. Im going to end up taking it back to the dealership and see if they can find the issue and fix it. I would greatly appreciate any help from anyone on here.

yeah_Jeep is offline  
Sponsored Links
post #2 of 4 Old 11-16-2013, 07:53 AM Thread Starter
Registered User
2005 WK 
Join Date: Nov 2013
Location: Burgbernheim
Posts: 5
So after looking around a bit more i noticed the other lower hose clamp wasnt seated right so I pushed on it and this happened.

yeah_Jeep is offline  
post #3 of 4 Old 11-16-2013, 08:25 AM
Registered User
2009 WK 
Join Date: Aug 2006
Location: Columbia SC
Posts: 134
New clamp?

2009 GC Limited. 265 70 18 is the only change to date. Bought some Rubicon 17" wheels and put BFG M/T's on for hunting season OME HD Front, OME MD rear, winch to come, basket and lights bars first
ducktail is offline  
post #4 of 4 Old 11-16-2013, 10:40 AM Thread Starter
Registered User
2005 WK 
Join Date: Nov 2013
Location: Burgbernheim
Posts: 5
Originally Posted by ducktail View Post
New clamp?
I put 2 hose clamps on for a temporary fix since nothing is open tomorrow in germany. Going to set up a time to drop it off at the dealer next week. going to take it for a drive tomorrow and see if once i get it heated up if and where it will leak from. More to follow
yeah_Jeep is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome