(Advice) Power steering issue after high speed turn. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > (Advice) Power steering issue after high speed turn.

Artec Holiday Sale!Bead Lock Wheels! Raceline, Trail Ready, & Trail-GearROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail

Reply
Unread 09-23-2012, 04:16 PM   #1
Sinxb
Registered User
2014 JK Wrangler 
 
Join Date: Feb 2012
Location: LA, California
Posts: 76
(Advice) Power steering issue after high speed turn.

I was rolling right around 100MPH and had a turn coming up (Which I knew about) It was no problem to handle but I think my 06 Hemi grand felt otherwise. I was actually doing a 1/4 test run late at night.
So long story short I hit the brakes pretty hard and steered to the right to make the turn and when I went to turn around the jeep was whining with a bad power steering pump sound. It was hard to turn and it did not change. When the jeep is cold it steers ok with some power steering but it does whine and changes when I press the gas down (better power steering with higher pitch noise). Once the jeep gets warmed up the power steering is basically gone.
Do you guys think the pump just happened to go out or do you think the Jeep felt I was in trouble and tried to correct it and blew a seal or had a electrical failure at that point. I am really hating the level of safety features in this WK because I have had nothing but problems with sensor and safety related crap on this thing.
Any advice or help with this issue? I ordered a new pump but I feel it is not going to fix the problem so I am asking you guys what you think.

Sinxb is offline   Reply With Quote Quick reply to this message
Unread 09-24-2012, 12:51 AM   #2
trax95008
Registered User
2006 XK Commander 
 
Join Date: Dec 2005
Location: , California
Posts: 1,210
Just want to get a stupid question out of the way. Did you check the PS fluid level? My neighbor had a whiney PS pump. I actually only whined when cold. I got fed up of hearing it so I asked her if I could take a look at it for her. The fluid level was so low, that it was sucking air. I topped it off and the noise went away. I'd say squeeling when you hit the gas is a sign of the pump not wanting to turn, and causing the belt to slip
trax95008 is offline   Reply With Quote Quick reply to this message
Unread 09-24-2012, 01:52 AM   #3
Sinxb
Registered User
2014 JK Wrangler 
 
Join Date: Feb 2012
Location: LA, California
Posts: 76
Fluid level is good. And I took the belt off and turned the pump with my hand and it is free with no dragging of any kind smooth as silk by hand.
Sinxb is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.