(Advice) Power steering issue after high speed turn. - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 09-23-2012, 03:16 PM Thread Starter
Sinxb
Registered User
2014 JK Wrangler 
 
Join Date: Feb 2012
Location: LA
Posts: 76
(Advice) Power steering issue after high speed turn.

I was rolling right around 100MPH and had a turn coming up (Which I knew about) It was no problem to handle but I think my 06 Hemi grand felt otherwise. I was actually doing a 1/4 test run late at night.
So long story short I hit the brakes pretty hard and steered to the right to make the turn and when I went to turn around the jeep was whining with a bad power steering pump sound. It was hard to turn and it did not change. When the jeep is cold it steers ok with some power steering but it does whine and changes when I press the gas down (better power steering with higher pitch noise). Once the jeep gets warmed up the power steering is basically gone.
Do you guys think the pump just happened to go out or do you think the Jeep felt I was in trouble and tried to correct it and blew a seal or had a electrical failure at that point. I am really hating the level of safety features in this WK because I have had nothing but problems with sensor and safety related crap on this thing.
Any advice or help with this issue? I ordered a new pump but I feel it is not going to fix the problem so I am asking you guys what you think.

Sinxb is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-23-2012, 11:51 PM
trax95008
Registered User
2006 XK Commander 
 
Join Date: Dec 2005
Posts: 1,255
Just want to get a stupid question out of the way. Did you check the PS fluid level? My neighbor had a whiney PS pump. I actually only whined when cold. I got fed up of hearing it so I asked her if I could take a look at it for her. The fluid level was so low, that it was sucking air. I topped it off and the noise went away. I'd say squeeling when you hit the gas is a sign of the pump not wanting to turn, and causing the belt to slip
trax95008 is offline  
post #3 of 3 Old 09-24-2012, 12:52 AM Thread Starter
Sinxb
Registered User
2014 JK Wrangler 
 
Join Date: Feb 2012
Location: LA
Posts: 76
Fluid level is good. And I took the belt off and turned the pump with my hand and it is free with no dragging of any kind smooth as silk by hand.
Sinxb is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Power Steering 4.0 speed proportional? How do I tell? melk ZJ Grand Cherokee Forum 10 01-14-2012 09:01 PM
Blower Fan runs at high speed and won't turn off Brosepe ZJ Grand Cherokee Forum 4 03-09-2011 05:36 PM
How do you know if your power steering pump is speed portional steering? sweetie ZJ Grand Cherokee Forum 9 06-27-2009 10:04 PM
Power Steering hard to turn WJChris ZJ Grand Cherokee Forum 12 10-04-2008 06:09 PM
surges at high speed /load --power loss gpJeep ZJ Grand Cherokee Forum 0 12-18-2007 11:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome