Adding Factory Tow wiring harness to 2wd v6 Commander -

LinkBack Thread Tools
post #1 of 3 Old 09-04-2007, 10:23 AM Thread Starter
Registered User
2007 XK Commander 
Join Date: Sep 2007
Location: Mooresville, NC
Posts: 17
Adding Factory Tow wiring harness to 2wd v6 Commander

I'm getting the run around on the correct tow 7-way wiring harness fro a 2007 v6 2wd Commander. Originally sold p/n 82211150 which splices into Foward Control Module but does not use the tow relays for turn/stop but instead uses the Rear Left/Right trun signal control lines for turn/stop. Everything works except the problem is the turn signals on the commander do not light up during braking, even though they are behind the red tail light lens. I've noticed newer Grand cherokees whose tail lights work this way too. How can this tow harness be correct??? The other part number 82209766 use the tailight wiring to connect and uses the tow relays for turn/stop. I've been told that this is also only for 4wd and v8 Commanders. So I'm very confused and frustrated right now. Anyone know more about this?

rstrickl is offline  
Sponsored Links
post #2 of 3 Old 09-04-2007, 06:35 PM
Registered User
Radiac's Avatar
Join Date: Aug 2004
Location: Enka, North Carolina
Posts: 172
Did you have the dealer activate the trailer lights? They need to do that before they will work, at least I had to on my '06.

His: 2006 Bright Silver Commander
Pictures Here

Hers: 2004 Bright Silver Grand Cherokee Laredo
Pictures Here
Radiac is offline  
post #3 of 3 Old 09-04-2007, 08:15 PM Thread Starter
Registered User
2007 XK Commander 
Join Date: Sep 2007
Location: Mooresville, NC
Posts: 17
Yep that would work if I could use the 2nd p/n 82209766 that uses the tow relays, then the dealer enables the relays via the star scan tool and life is good. I just looked tonite and the wires are missing to the rear left tail light that would allow connecting the tow relays via the supplied connector to the tow plug, so I can't use that p/n..darn it. I think on 2006 this was the only p/n but on 2007 they left off some wires on the 2wd v6 and you have to use the splice p/n 82211150. That still leaves me with this harness not working because of the rear turn lamps not coming on during braking.......

Last edited by rstrickl; 09-07-2007 at 09:33 AM.
rstrickl is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
(ZJ) Adding factory fog lights - how to ZJunk ZJ Grand Cherokee Forum 102 01-20-2015 10:33 PM
Adding a window antenna to the Commander DocUwe WK Grand Cherokee & XK Commander Forum 0 07-20-2009 11:45 PM
wiring harness / factory amp not2high ZJ Grand Cherokee Forum 4 07-14-2008 11:20 AM
Non Factory Tow Harness 4 My JEEP PresTx82 ZJ Grand Cherokee Forum 5 06-13-2007 01:50 PM
Wiring harness question ... 98 harness in 93?? mjessop23 ZJ Grand Cherokee Forum 1 05-24-2007 08:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome