5.7 hemi stalling - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 5.7 hemi stalling

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineYear End Clearance Sale! Save 20%Warn, Smitybilt, Engo, Rugged Ridge Winches at CCOR

Reply
Unread 11-30-2014, 09:24 AM   #1
kris06
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 77
5.7 hemi stalling

Hello i need help with my jeep its 06 gc and its stalling at stops changed egr plugs from dealer o2 sensors changed throttle body and also torqe coverter camshaft sensor and crankshaft sensor and still stalling when shifting to drive from park when cold , when warmed up its just jerking with rpms 84k miles on the clock any ideas?

kris06 is offline   Reply With Quote Quick reply to this message
Unread 11-30-2014, 10:51 AM   #2
rsurran
Senior Member
2003 TJ Wrangler 
 
Join Date: Jun 2011
Location: Eastern Shore, Virginia
Posts: 693
Codes?
__________________
2005 WK, 5.7L, Gold, Leather
2003 TJ 4.0L Freedom Edition, Flame Red, 5 spd., CAI, Warn, stinger, Hella/KC trail lights.

Dick Surran

"When you stop contributing you are just taking up space."
rsurran is offline   Reply With Quote Quick reply to this message
Unread 11-30-2014, 11:01 AM   #3
kris06
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 77
No codes
kris06 is offline   Reply With Quote Quick reply to this message
Unread 11-30-2014, 12:55 PM   #4
CavallinoRed
Member
2006 WK 
 
Join Date: Oct 2013
Location: Arvada, CO
Posts: 332
Have you replaced the spark plugs recently?
CavallinoRed is online now   Reply With Quote Quick reply to this message
Unread 11-30-2014, 02:31 PM   #5
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland, MI
Posts: 1,535
Quote:
Originally Posted by kris06 View Post
Hello i need help with my jeep its 06 gc and its stalling at stops. changed egr, plugs from dealer, o2 sensors, changed throttle body, and also torque converter, camshaft sensor, and crankshaft sensor... and still stalling when shifting to drive from park when cold , when warmed up its just jerking with rpms. 84k miles on the clock any ideas?
1. Check that the spark plugs have the dark center upper electrodes (where the coil connects). They should be MOPAR OEM or Champion 570, but definitely with the dark top. There is a STAR Case on this. Change them every 30K miles. Gap is 0.043" and torque at 12-15 lb-ft. 90grandoneer uses NGK's and they seem to work for him. I've used only Champion or MOPAR on my 5.7L HEMI.
2. Verify that xmission fluid is full when hot. ATF+4. Some members have reported that low fluid level has caused stalling problems.
3. PCV valve was due at 60K miles. Do you know if it was done?

You said there were no codes set (DTC). Were there any DTC's pending? A small exhaust leak at the Y-pipe connection to the manifolds will give you performance fits if not corrected. Mine need to be done annually or it sets a pending DTC and MDS does not function. Try torqueing yours also.

CAUTION: This advice may be worth what you paid to get it.
__________________
HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline   Reply With Quote Quick reply to this message
Unread 11-30-2014, 04:40 PM   #6
kris06
Registered User
2006 WK 
 
Join Date: Mar 2013
Posts: 77
No pending codes but i will check y pipe and spark plugs
kris06 is offline   Reply With Quote Quick reply to this message
Unread 11-30-2014, 06:53 PM   #7
alberto68888
Registered User
2008 WK 
 
Join Date: Aug 2014
Location: Venezuela, Caracas
Posts: 7
Same problem with my 2008 GC 4.7 changed crankshaft, sparkplugs, cats, pcv, cleaned TB and fuel injectors. It's stall even while driving but all started when i cleaned the injectors and no DTC. Fuel pump pressure checked and was fine.
alberto68888 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.