5.7 engine knocking - JeepForum.com
 
LinkBack Thread Tools
post #1 of 9 Old 11-04-2012, 07:38 AM Thread Starter
ddemoss1
Registered User
2006 WK 
 
Join Date: Nov 2012
Location: Edgewater
Posts: 4
5.7 engine knocking

anyone experience a pretty hefty engine knocking in the cold weather with the 5.7 hemi? Ive noticed it a few time since its started to get cold in the mornings here. It threw the check engine light last time it did it so took it to a place with a code reader and nothing came up. suggestions?

ddemoss1 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-05-2012, 08:54 AM
mak90
Registered User
2010 WK 
 
Join Date: Jul 2012
Location: St. Mary's
Posts: 16
Bad gas maybe? I haven't had any problems but I have heard that they knock sometimes. Try filling up at a different gas station and see if the problem continues.
mak90 is offline  
post #3 of 9 Old 11-06-2012, 06:42 PM Thread Starter
ddemoss1
Registered User
2006 WK 
 
Join Date: Nov 2012
Location: Edgewater
Posts: 4
It only happens when i first start it up in the mornings to warm up and by the time im back out to my car (no more than 5 minutes later) it has stopped. it almost sounds like it could be misfiring
ddemoss1 is offline  
post #4 of 9 Old 11-08-2012, 01:04 AM
Ryan101505
Registered User
 
Join Date: Apr 2011
Location: G
Posts: 162
Could be lifters?
Ryan101505 is offline  
post #5 of 9 Old 11-08-2012, 06:48 PM Thread Starter
ddemoss1
Registered User
2006 WK 
 
Join Date: Nov 2012
Location: Edgewater
Posts: 4
well the code that tripped the check engine light was a misfire on cylinder 1, so i replaced all 16 plugs with hopes that they were the root of the knocking. to my dismay the knocking still happened this morning. I think if it were the lifters it would be more of a constant tick rather than an irregular knocking that occurs for only a few minutes while its warming up.
ddemoss1 is offline  
post #6 of 9 Old 11-09-2012, 07:49 AM
06JeepXKHEMI
Senior Member
 
06JeepXKHEMI's Avatar
2005 LJ Wrangler 
 
Join Date: Sep 2012
Location: Charlotte
Posts: 745
Garage
May seem like a dumb question but you checked the oil right?!?

05 LJRubi Currie 4" Springs, Savvy Fox shocks, MC trackbars, MC CA's single adj lower double uppers, 37x13.50 Cooper STT Pros on 17x9 ATX Ravine, MC Overlines front, Genright rear, Revolution 5.38s, Carolina Driveline driveshafts, MCAI
06JeepXKHEMI is offline  
post #7 of 9 Old 11-09-2012, 08:03 AM Thread Starter
ddemoss1
Registered User
2006 WK 
 
Join Date: Nov 2012
Location: Edgewater
Posts: 4
06JeepXKHEMI not a dumb question. yes, oil was the first thing i checked. it was within the operating range but i added a bit just to make sure it had plenty.
ddemoss1 is offline  
post #8 of 9 Old 11-09-2012, 08:10 AM
w1pf
Who, me?
 
w1pf's Avatar
2007 WK 
 
Join Date: Aug 2008
Location: Amherst
Posts: 754
kinda sounds like a collapsing lifter..

2014 WK2 Overland 5.9L
2007 WK Limited 5.7L
And some past Durangos
Red WK #19, Hemi #68.. I think..
Durango Owners Club DOTY 2011
-------
"Must have been that yesterday was the day that I was born"
w1pf is offline  
post #9 of 9 Old 11-09-2012, 01:29 PM
90grandoneer
Registered User
2006 WK 
 
Join Date: Apr 2008
Location: City of Trees
Posts: 2,648
I see you checked the oil, but is it the correct weight....5W-20? Have you cleared the DTC? Has it returned? Do you regularly change your oil, or do you let it slide way past the change intervals?

The No. 1 cylinder is an MDS cylinder, and there have been reports of the MDS lifter actuating pin(s) failing and causing an engage/disengage problem. This usually causes an initial intermittant problem that progresses into a continuous problem. There have been some writeups, with pictures, on at least one of these forums. If you can't come up with anything conclusive, you may want to do a search and see if you can come up with one of them. IIRC, one that had the problem was going ~10,000K between oil changes. Did that cause it???? Who knows? Guess it could keep the pin(s) from moving as freely as the should, especially if running dino. oil that long.

06 GCO, Dk Khaki, QDII, Flshing Hi 3rd Bk Lt, MDS "ON" Lt, Airtab Vortex Gens, Debadged, Fumoto Drain Valve, BT Catch Can, Chopped EGR Tube, SRT8 CAI, K&N Filter, Sonnax Trans Line Press Booster, SC Tuner W/Adv Trans Tune App, DS Tuner, Cust tubular hdrs w/3 in Magnaflow/Xlerator AP Exh Sys, Bilsteins, SRT Springs/Sways, Cust Eng Cvr, SRT8 frt/rear bumpers, FRI Sidewinder Cam/6.1 valvetrain, SLP 25% UD Pulley, BBK true 90mm T-Body, SOS Ign Coils w/.060 spark plug gaps, SRT Reps with 265/45&295/40X20's.
90grandoneer is offline  
Reply

Tags
5.7 liter , cold start , grand cherokee , knocking

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome