3.7 Rough Idle - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 3.7 Rough Idle

Black Friday Sale - Deep Discounts from ExtremeTerrain.com6th Annual, Beat Your Wife to the Credit Card Sale!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Reply
Unread 12-21-2012, 10:42 AM   #1
Beardacus
Registered User
2013 JK Wrangler 
 
Join Date: Nov 2012
Location: , NY
Posts: 67
3.7 Rough Idle

Hey gents.

So I recently started noticing a rough idle when stopped at a traffic light. It doesn't happen every single time but it is happening more often than not.

I first noticed it after gassing up at a mom & pop gas station about 2 months ago so I thought it might be some bad gas, but I have gone through a lot of tanks of 93 since then and it is still happening.

Any idea what it can be? Dirty TB? Something else?



Beardacus is offline   Reply With Quote Quick reply to this message
Unread 12-21-2012, 12:30 PM   #2
bull_blaster
Registered User
2005 WK 
 
Join Date: Apr 2007
Location: Hillsboro, Oregon, USA
Posts: 287
Check your air filter...if Thats good then check your air flow sensor...i clean mine every oil change. If all fails throw in a bottle of fuel treatment.
bull_blaster is offline   Reply With Quote Quick reply to this message
Unread 12-21-2012, 12:33 PM   #3
Beardacus
Registered User
2013 JK Wrangler 
 
Join Date: Nov 2012
Location: , NY
Posts: 67
Thanks Bull. I forgot to mention I used a bottle of fuel treatment the first time I filled up with a new tank of 93 after the rough idle began. That did not help.

Where is the air flow sensor located? What should I be looking for?
Beardacus is offline   Reply With Quote Quick reply to this message
Unread 12-27-2012, 11:52 AM   #4
Theogriff15
Registered User
2006 WK 
 
Join Date: Jun 2012
Location: Weston, MA
Posts: 838
I have the same thing happening to me. Have no idea whats wrong but it'd be awesome if we could figure out what it is.
__________________
2006 - 3.7L, Superlift, 265 Guard Dogs, 30" LED Bar, Bilsteins, Spidertraxx, Solid, Hypertech, Rola, Rear Led, Led Tails, S4xC Skids
Theogriff15 is offline   Reply With Quote Quick reply to this message
Unread 03-03-2013, 02:12 PM   #5
Benzie002
Registered User
2011 WK 
 
Join Date: Jul 2011
Location: EAST BRUNSWICK, NJ
Posts: 12
Mine is doing the same 2005 v6 runs fine- just a rough idle.
Benzie002 is offline   Reply With Quote Quick reply to this message
Unread 03-03-2013, 03:14 PM   #6
caulk04
Registered User
2008 WK 
 
Join Date: Jan 2013
Location: Greenville, Pennsylvania
Posts: 956
First thing I do with a rough idle, clean the TB. Next, seafoam through the intake. Follow that with new plugs if youre close to time for them.

Be sure to clean the iac motor and its ports very well while youre at it.

As far as the air flow sensor goes, chrysler engines don't have a mass air flow sensor, it's a speed density system that operates with a manifold absolute pressure sensor (map sensor).
caulk04 is offline   Reply With Quote Quick reply to this message
Unread 03-03-2013, 03:40 PM   #7
Butterjeep
Registered User
2012 JK Wrangler 
 
Join Date: May 2012
Location: Edgewater, NJ
Posts: 500
The 3.7 needs fresh plugs every 30k, maybe that could be it?
__________________
2012 JK
2014 WK2
Butterjeep is offline   Reply With Quote Quick reply to this message
Unread 03-03-2013, 05:35 PM   #8
Jaashua
Registered User
2005 WK 
 
Join Date: Feb 2013
Posts: 1,101
Try this stuff.

http://www.k100fueltreatment.com/mm5...tore_Code=KFTO

I swear, its expensive but it works right away. I put it in my gas tank and by the time I got down the road my car was running like new. It works and actually will make your car run like crap sometimes, because of all the stuff it cleans out. If that makes sense? Like the stuff is being locked loose. I just restart my car and runs perfect. It is the only fuel treatment I'll be using.
Jaashua is offline   Reply With Quote Quick reply to this message
Unread 03-03-2013, 06:17 PM   #9
flexyxj
Registered User
2009 XK Commander 
 
Join Date: May 2005
Location: Sioux Falls,SD
Posts: 491
Quote:
Originally Posted by Beardacus View Post
Hey gents.

So I recently started noticing a rough idle when stopped at a traffic light. It doesn't happen every single time but it is happening more often than not.

I first noticed it after gassing up at a mom & pop gas station about 2 months ago so I thought it might be some bad gas, but I have gone through a lot of tanks of 93 since then and it is still happening.

Any idea what it can be? Dirty TB? Something else?

Why are you running 93 Octane? It's designed for 87 Octane...
flexyxj is offline   Reply With Quote Quick reply to this message
Unread 03-03-2013, 07:04 PM   #10
Jaashua
Registered User
2005 WK 
 
Join Date: Feb 2013
Posts: 1,101
Mine is designed for 89 and I still use 87.

Sent from my Samsung S2 using JeepForum
Jaashua is offline   Reply With Quote Quick reply to this message
Unread 03-03-2013, 10:26 PM   #11
DeChache
Registered User
2003 WJ 
 
Join Date: Oct 2012
Location: Iowa City, IA
Posts: 272
Need to figure this out on my 08. Just started doing it. Runs fine but sitting at stoplights sometimes it will stumble rev up and then be fine.

Last edited by DeChache; 03-03-2013 at 11:00 PM..
DeChache is offline   Reply With Quote Quick reply to this message
Unread 03-31-2013, 10:57 AM   #12
Benzie002
Registered User
2011 WK 
 
Join Date: Jul 2011
Location: EAST BRUNSWICK, NJ
Posts: 12
Another post suggested a bad throttle position sensor. Any comments about that?
Benzie002 is offline   Reply With Quote Quick reply to this message
Unread 03-31-2013, 03:05 PM   #13
Piepenbrok420
Registered User
2013 JK Wrangler 
 
Join Date: Aug 2011
Location: Dallas, TX
Posts: 513
Quote:
Originally Posted by DeChache View Post
Need to figure this out on my 08. Just started doing it. Runs fine but sitting at stoplights sometimes it will stumble rev up and then be fine.
Mine does the same, will starr investigating tomorrow
__________________
Built Not Bought. 2013 JK trailrig. Instagram: @chrispiepenbrok
Piepenbrok420 is offline   Reply With Quote Quick reply to this message
Unread 03-31-2013, 08:53 PM   #14
DeChache
Registered User
2003 WJ 
 
Join Date: Oct 2012
Location: Iowa City, IA
Posts: 272
I have a lead on the IAC motor that seems promising. Prob will try cleaning mine first and if that helps I'll replace it.
DeChache is offline   Reply With Quote Quick reply to this message
Unread 04-01-2013, 03:47 PM   #15
dgiessel
Registered User
2006 WK 
 
Join Date: Feb 2013
Location: , Kansas
Posts: 14
I have a 3.7. It idled pretty rough when I bought it, but replacing spark plugs fixed it- mostly. Check engine light comes on occasionally for a mis-fire. It idles rough upon start-up, but smooths out once the engine warms up. I took it to my mechanic, who said a definite diagnosis would require tearing down the engine. He said it is most likely dirty injectors or carbon on the valves. He said it isn't hurting anything, and recommended running injector cleaner though it a couple of times. However, I haven't had a chance to do so yet, because no one will sell me any (I am a month shy of eighteen), so I cannot tell you whether or not he was correct.
__________________
metallic grey '05 GC Laredo, 3.7L V-6 (Totaled)
black '06 GC Limited, 5.7L HEMI

Last edited by dgiessel; 04-01-2013 at 10:21 PM..
dgiessel is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.