3.0 CRD Stalling - Key issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 12-24-2013, 04:08 AM Thread Starter
ZF1FR
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Savigny-sur-Orge
Posts: 107
3.0 CRD Stalling - Key issue

Hello everyone!

Thanks it happened to me in my alley, but the Jeep won't lock/unlock but start and stall each time after 3s.
MIL is indicating me "replace pressure sensor transmitter".
Scanner is giving me gray codes (I assume fujitive ones) :
P0513: incorrect immobilizer key
P0674/P0673: those are related to my glowplugs -> OK
U0103/U0404: those are related to the TCM/shifter (I'll have to check the connections).

Battery voltage is fine. Key fob #1 had its battery changed with the Jeep's battery (first symptoms I thought of a dead battery were hard time opening closing the doors). I don't recall changing the key fob #2 battery. Key fob #2 cannot open/close the doors, but starts the jeep (before stalling)

I have to figure out which module is generating error is it really the TPMS receiver or the security module?

Could it be the ignition switch?

Thanks in advance,

PS: I have now to find a way to tow my jeep into the garage, alley is all mud no way of pushing!

ZF1FR is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 12-24-2013, 05:42 AM
hawgripper
Registered User
2008 WK 
 
Join Date: Oct 2013
Location: Hastings
Posts: 30
I know that mine would start and stall if using the key fob for starting which turned out to be my glowplug module, not sure about the lock unlock issues.
hawgripper is offline  
post #3 of 7 Old 12-24-2013, 05:47 AM Thread Starter
ZF1FR
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Savigny-sur-Orge
Posts: 107
It could be related to this TSB:
http://www.wkjeeps.com/tsb/tsb_wh_0806105.pdf

This bulletin involves selectively erasing and reprogramming the Wireless Control Module
(WCM), also called the Sentry Key REmote Entry Module (SKREEM)

One or more of the following
specific conditions may occur: no engine crank, engine will crank but not start, engine will
crank and start but will immediately stop (within two seconds of start up).

I have a 2005 WH but left hand drive...
ZF1FR is offline  
post #4 of 7 Old 12-24-2013, 05:48 AM Thread Starter
ZF1FR
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Savigny-sur-Orge
Posts: 107
Quote:
Originally Posted by hawgripper View Post
I know that mine would start and stall if using the key fob for starting which turned out to be my glowplug module, not sure about the lock unlock issues.
Did you have any code thrown for the glowplug module?
ZF1FR is offline  
post #5 of 7 Old 12-24-2013, 06:24 AM
Radcrd
Registered User
2007 WK 
 
Join Date: Oct 2012
Location: Montreal
Posts: 371
How old is the battery? Even if the voltage shows fine it may be weak. These jeeps have all kinds of electrical issues when battery is weak. If over 5 years old replace it.

2007 WK CRD QDII, GDE HOT tune. 275/55/18'' on Sahara's, SRT8 suspension.
2000 Jetta TDI (hers)
2006 Liberty CRD (sold)
3 VW TDI's (sold)
Radcrd is offline  
post #6 of 7 Old 12-24-2013, 06:49 AM Thread Starter
ZF1FR
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Savigny-sur-Orge
Posts: 107
You're right when the first battery died (5 years old), it showed wierd signs: remote opening/closing very hard, I had to be close and clic more the once (that's the case today)
Then when it died I had service 4WD and check rear park assist, but it would not start at all.
The battery was dropping below 10V when cranking.

The actual battery is two years old (12.56V). But they can die quite rapidly. I did not use a lot the Jeep this year, some time staying for 3 month in a raw in the parking lot. When cranking it was running on 2-3 cylinders. May be the battery has suffered from this? And unfortunately I'm using it now for very small runs.
ZF1FR is offline  
post #7 of 7 Old 12-28-2013, 01:57 AM Thread Starter
ZF1FR
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Savigny-sur-Orge
Posts: 107
Thanks guys,

That was another weird sign when battery voltage is low. I bought a nice Ctek charger so I could restore the battery. It also has a quick coupling so I can plug it in my garage.
The jeep started after unplugging and charging the battery overnight.
Next battery, optima red top!
ZF1FR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome