2008 CRD Check Engine Light P0670 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 2008 CRD Check Engine Light P0670

Labor Day Sale!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 01-02-2012, 02:22 PM   #1
johnniebravo
Registered User
2008 WK 
 
Join Date: Sep 2002
Location: Bristow, VA
Posts: 837
2008 CRD Check Engine Light P0670

Happy New Year everyone!

Great way to start the new year, hit the remote start button on the Jeep last night and it wouldn't start. It started fine when I used the key. Shortly after starting I got a CEL, got the code checked today and it was P0670. The code says the Glow Plug Control Module is bad. I've seen several people post about the glow plugs specifically by codes but never the GPCM by CEL. Thing is, the CEL went off today when I went out to get the code scanned and pick up parts. I am trying to figure out why the CEL came on and then went off. My guesses are a bad ground at the module on the fuel/water filter, bad/low battery (tested fine today with VM with good fluid level), or the actual module is bad.

As I understand it, there is a glow plug relay and a glow plug control module. If I am wrong someone please correct me. I THINK the GPCM is located at the front passenger side of the engine (USDM cars).

Is this part the glow plug control module? The part number I pulled from mine is A6421532079 /000
http://store.europarts-sd.com/glowplugcontrolunit2007-2009.aspx

Can anyone who has had the GPCM with a CEL P0670 confirm that the part in the link above is the actual module?

Also, part prices are much much cheaper at my local Benz dealer versus the Jeep dealer. I've seen the Jeep part number as 05175759-AB from HERE (or 08-035-027, MB number, but doesn't make sense). What I need is the whole MB part number. Does anyone have the box from the GPCM they got from the dealer?

Thanks for the help and for reference this on a 2008 CRD purchased Sept 2007, 64k ish miles, no other CELs ever.

__________________
2008 CRD GC
johnniebravo is offline   Reply With Quote
Unread 01-02-2012, 02:49 PM   #2
lunaslide
Junior Member
2008 WK 
 
Join Date: Mar 2011
Location: Kirkland, Washington
Posts: 45
I had this go out on me awhile back. When I get home, I'll check the paperwork from the dealership to see what part number it was.

I have an extended service contract that covers the module but not the glow plugs themselves (they are considered consumable the same as spark plugs). They changed out the glow plug, that didn't solve it, changed the module, but still tried to charge me for the glow plug. Had to put the kibosh on that and just ended up paying the $150 deductible for the service contract work.
__________________

[ 2008 Grand Cherokee Laredo CRD ]
[ GDE ECOtune ][ Airflow Snorkel ][ MBRP T304 Diesel Exhaust ]
[ Superlift 4" ][ Jeep Commander front coils ]
[ AEV Pintler Argent Wheels ][ 285/70R17 BFG Mud-Terrain T/A KM2 ][ 4XGuard FG, BG, RR, Antennae mount ]
lunaslide is offline   Reply With Quote
Unread 01-03-2012, 05:48 PM   #3
johnniebravo
Registered User
2008 WK 
 
Join Date: Sep 2002
Location: Bristow, VA
Posts: 837
Quick update, the CEL came up again this morning after sitting cold all night. Pulled the code and was the same P0670.

I ordered a new Glow Plug Control Module from local Merc dealer for 189. Just to test the water, I checked in with the Jeep dealer next door to the Merc dealer and Jeep wanted $1,000 for the same part!

The original part included with the Jeep has been replaced by a newer part.

The new part number from both Merc and Jeep's parts systems is A6429002800. I will install the new unit tomorrow afternoon and report back.
__________________
2008 CRD GC
johnniebravo is offline   Reply With Quote
Unread 01-03-2012, 07:12 PM   #4
tdoster
Registered User
2007 WK 
 
Join Date: Nov 2011
Location: Dallas, TX
Posts: 98
You know it's bad when Jeep has a 500% markup over Merc retail.
tdoster is offline   Reply With Quote
Unread 01-04-2012, 03:04 PM   #5
johnniebravo
Registered User
2008 WK 
 
Join Date: Sep 2002
Location: Bristow, VA
Posts: 837
Got the new module installed this afternoon, the new part is about 40% smaller than the old one with a different shape. After two starts, the CEL turned off. The drive to work tomorrow will be the true test.
__________________
2008 CRD GC
johnniebravo is offline   Reply With Quote
Unread 01-12-2012, 09:26 PM   #6
ktmkris
Registered User
2008 WK 
 
Join Date: Dec 2011
Location: monroe, nc
Posts: 74
i had the exact same issue with my 08. i had three glowplugs burnt out. stealership told me they guaranteed my module was not bad change the plugs. they said they had changed 4 gp modules to have the problems come back. mine would only set s cel if it was under 50 degrees and a cold start.

you can check the glow plugs without removing them from the vehicle very easily. run a tiny wire from your positive source on your battery, just tap it or scrape it very fast across the top of the glow plug. if there is a spark it good, no spark then replace it. just a simple circuit.

all in all i had 3 plug bad. but you might as well replace all 6. by the way i paid 20 a glow plug, they can still make money at that price. dont think twice about telling the jeep parts department there prices are to high.
ktmkris is offline   Reply With Quote
Unread 01-13-2012, 04:41 PM   #7
johnniebravo
Registered User
2008 WK 
 
Join Date: Sep 2002
Location: Bristow, VA
Posts: 837
I forgot to follow up, the new module fixed the problem. So far all the plugs are fine, I do have a spare on hand.
__________________
2008 CRD GC
johnniebravo is offline   Reply With Quote
Unread 06-19-2012, 12:55 PM   #8
marcram
Registered User
2008 WK 
 
Join Date: Nov 2011
Location: Missouri City, TX
Posts: 81
Glow Plu

Quote:
Originally Posted by johnniebravo View Post
I forgot to follow up, the new module fixed the problem. So far all the plugs are fine, I do have a spare on hand.
Great news that you solved the problem. I have the same code a few weeks after swapping 3 of the 6 glow plugs. Do you by chance have a link to the installation of the module? Also, anywhere to buy it online?

Thanks,
Marc
marcram is offline   Reply With Quote
Unread 06-19-2012, 03:51 PM   #9
marcram
Registered User
2008 WK 
 
Join Date: Nov 2011
Location: Missouri City, TX
Posts: 81
Ok, so pretty sure I located the glow plug module located near the front center of the engine. I was able to pry the power connector from the module, but not the connector that leads to the glowplugs. Any suggestions here? Can this be done with the module in the standard location or do you need to remove it from the rest of the assembly. Anyone have instructions for this?

I'm hoping that the this error may be the result of mangled glow plug connectors (especially from trying to grasp the very hard to reach one in the engine rear near driver's seat). All resistance values seem to be correct for the glowplugs, but voltages have not been tested.

Any tips or insight are appreciated.
marcram is offline   Reply With Quote
Unread 06-25-2012, 08:06 PM   #10
marcram
Registered User
2008 WK 
 
Join Date: Nov 2011
Location: Missouri City, TX
Posts: 81
Anyone?

Quote:
Originally Posted by marcram View Post
Ok, so pretty sure I located the glow plug module located near the front center of the engine. I was able to pry the power connector from the module, but not the connector that leads to the glowplugs. Any suggestions here? Can this be done with the module in the standard location or do you need to remove it from the rest of the assembly. Anyone have instructions for this?

I'm hoping that the this error may be the result of mangled glow plug connectors (especially from trying to grasp the very hard to reach one in the engine rear near driver's seat). All resistance values seem to be correct for the glowplugs, but voltages have not been tested.

Any tips or insight are appreciated.
I can't get the light to turn off. Would you all recommend taking this in to the Mercedes or Jeep dealer? I figure the Mercedes techs have seen this engine a lot more than the Jeep techs.
marcram is offline   Reply With Quote
Unread 06-25-2012, 09:12 PM   #11
johnniebravo
Registered User
2008 WK 
 
Join Date: Sep 2002
Location: Bristow, VA
Posts: 837
I would recommend replacing the module, its VERY easy to swap out. Get the part from benz not jeep. Once I changed it out, light went off.

I do recall one plug being tougher than the other. I think I used a small screw driver to depress a tab or something, can't remember exactly...its been a while.

if that doesnt do it then you can try the dealer.
__________________
2008 CRD GC
johnniebravo is offline   Reply With Quote
Unread 06-27-2012, 01:16 PM   #12
marcram
Registered User
2008 WK 
 
Join Date: Nov 2011
Location: Missouri City, TX
Posts: 81
Quote:
Originally Posted by johnniebravo View Post
I would recommend replacing the module, its VERY easy to swap out. Get the part from benz not jeep. Once I changed it out, light went off.

I do recall one plug being tougher than the other. I think I used a small screw driver to depress a tab or something, can't remember exactly...its been a while.

if that doesnt do it then you can try the dealer.

Ok, then that is what I'll do. Will post the outcome.
marcram is offline   Reply With Quote
Unread 06-27-2012, 03:46 PM   #13
marcram
Registered User
2008 WK 
 
Join Date: Nov 2011
Location: Missouri City, TX
Posts: 81
Ok, glow plug control module is removed and put back, so replacing it should be easy. Local Benz dealer will charge $210 for the module. Not too bad.

Before I order the part, I test the resistance of the harness wiring to the glow plugs. Here is a picture.


On the harness, pins 9, 10, and 11 are removed.

For future reference, the glow plug wiring harness connector is numbered like this
12 NC NC NC 8 7
GND 5 4 3 2 1

Considering looking at the engine from the front with drivers side on the right, and cylindars labeled
F C
E B
D A

Connections are:
? NC NC NC C B
GND ? A F E D.

If anyone can fill in the ?s, it would be appreciated. I bet one of them is the positive battery supply.
marcram is offline   Reply With Quote
Unread 06-27-2012, 06:41 PM   #14
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,809
maybe this is of use, its the glow plug wiring by color, the pictures are from the 2007 sprinter service CD, should be the same wiring for the jeep.
glow-plug-wiring.jpg   glow-plug-module.jpg  
__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline   Reply With Quote
Unread 06-28-2012, 05:27 PM   #15
marcram
Registered User
2008 WK 
 
Join Date: Nov 2011
Location: Missouri City, TX
Posts: 81
Thanks for the diagram.

Has anyone ordered parts from sprinterparts.com? I see the 3.0L control module for $137. Seems like a great deal.

http://www.sprinterparts.com/item.ww...NUINE&sup=OEC&

Marc
marcram is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.