2008 Commander clunks and won't go over 40MPH - JeepForum.com

LinkBack Thread Tools
post #1 of 2 Old 10-20-2013, 07:58 PM Thread Starter
Registered User
Join Date: Oct 2013
Location: EHT
Posts: 1
2008 Commander clunks and won't go over 40MPH

Every now and then when I start out I'll hear a "clunk" and then my commander will not go over 40 MPH. I have to stop and shut the engine off and when I restart it goes back to normal. And idea what it is?

VoodooMP is offline  
Sponsored Links
post #2 of 2 Old 10-21-2013, 10:38 AM
Registered User
2006 WK 
Join Date: Apr 2013
Location: Joliet
Posts: 213
Could be your (esm) electronic shift module.

06 ROR lifted wk (mine)
07 RC lifted xk (wife's)
Youtube channel
overland-wk is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome