2007 JGK 3.0 CRD dead A/C - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 2007 JGK 3.0 CRD dead A/C

Eliminate Hood Flutter!!!WJ Shackle Tabs: Tow-Hook Replacements2014 Spartan Locker Special - While Supplies Last! Dana 3

Reply
Unread 06-24-2013, 12:45 PM   #1
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 43
2007 JGK 3.0 CRD dead A/C

The A/c just quit, dead, nothing. There is plenty of R134A in the system. I can't seem to get the compressor to kick in regardless if I use manual or auto settings. It will respond to heat settings but any A/c requests just brings in outside air.

I have checked the fuses and relays. One of the relays does get warm but that is about all.

Suggestions?

b52rule is offline   Reply With Quote Quick reply to this message
Unread 06-24-2013, 02:06 PM   #2
JRLT
Registered User
2010 WK 
 
Join Date: Aug 2011
Location: Lower Brule, South Dakota
Posts: 1,371
Maybe it's overfilled.
__________________
2010 3.7L, 4XGuard Matrix, Fastman TB, TB Ground Mod, Injen CAI, 255/60/18 Nitto Terra Grapplers, Bilstein Shocks & Struts, Cruiser Alloy Wheels - Switchblade, Stillen Brakes, Cargo Light Strip Mod, Electric Ashtray Mod, Jet-powered, Monkey Navigated...
JRLT is offline   Reply With Quote Quick reply to this message
Unread 06-24-2013, 02:22 PM   #3
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 43
Thanks for the reply. Dead center in the blue right where is should be.
b52rule is offline   Reply With Quote Quick reply to this message
Unread 06-24-2013, 11:47 PM   #4
terrasmak
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: South Korea, Osan AB
Posts: 505
Looks like I know what I'll be fixing when I'm home over the 4th. At least we will have a full selection of parts to swap off mine for troubleshooting.
__________________
"Racing makes Heroin addiction look like a vague wish for something salty." -- Peter Egan
terrasmak is offline   Reply With Quote Quick reply to this message
Unread 06-25-2013, 01:19 AM   #5
jamie1131
Registered User
2006 WK 
 
Join Date: Oct 2008
Location: Leicester, UK
Posts: 93
I had the same issue with my CRD. The shop told me i needed a new compressor.

I took the AC clutch relay out and checked it by putting it into the front fog lamp circuit. It worked just fine. I was lazy so i left it in that circuit and put the fog lamp relay back into the AC circuit and the compressor kicked straight into life.

I'm wondering if the relay was sticking and there wasn't enough power in the AC control circuit to drive it open.
jamie1131 is offline   Reply With Quote Quick reply to this message
Unread 06-25-2013, 06:37 PM   #6
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 43
I'll give it a try and report back.


Thanks!
b52rule is offline   Reply With Quote Quick reply to this message
Unread 06-25-2013, 10:41 PM   #7
Drewd
Registered User
 
Join Date: Jan 2006
Location: Colorado
Posts: 225
Would have never had this problem if you had a gasser
Drewd is offline   Reply With Quote Quick reply to this message
Unread 06-25-2013, 11:07 PM   #8
terrasmak
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: South Korea, Osan AB
Posts: 505
Quote:
Originally Posted by Drewd View Post
Would have never had this problem if you had a gasser
LoL , something else would have just broke.
__________________
"Racing makes Heroin addiction look like a vague wish for something salty." -- Peter Egan
terrasmak is offline   Reply With Quote Quick reply to this message
Unread 06-27-2013, 11:17 AM   #9
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 43
Quote:
Originally Posted by jamie1131 View Post
I had the same issue with my CRD. The shop told me i needed a new compressor.

I took the AC clutch relay out and checked it by putting it into the front fog lamp circuit. It worked just fine. I was lazy so i left it in that circuit and put the fog lamp relay back into the AC circuit and the compressor kicked straight into life.

I'm wondering if the relay was sticking and there wasn't enough power in the AC control circuit to drive it open.

I tried that last night, no go............and no A/C

I'm open for more suggestions.

I have to take it into the dealer for a Safety Recall N23/NHTSA 13V-175. That is the last place I'd like to get it fixed however.
b52rule is offline   Reply With Quote Quick reply to this message
Unread 06-30-2013, 04:58 PM   #10
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 43
Pulled and reset the high pressure connector below the receiver/dryer.............no go.
b52rule is offline   Reply With Quote Quick reply to this message
Unread 07-02-2013, 11:55 AM   #11
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal, Qc
Posts: 431
... any codes ? Check engine ... ??
__________________
2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is offline   Reply With Quote Quick reply to this message
Unread 07-02-2013, 11:56 AM   #12
jamie1131
Registered User
2006 WK 
 
Join Date: Oct 2008
Location: Leicester, UK
Posts: 93
Is there power going to the relay? If yes, is there power going to the compressor clutch?
jamie1131 is offline   Reply With Quote Quick reply to this message
Unread 07-02-2013, 11:32 PM   #13
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 43
Quote:
Originally Posted by jediknight View Post
... any codes ? Check engine ... ??
No check engine lights, no codes. Our son will be here tomorrow, has the same vehicle so we will troubleshoot it together.
b52rule is offline   Reply With Quote Quick reply to this message
Unread 07-02-2013, 11:33 PM   #14
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 43
Quote:
Originally Posted by jamie1131 View Post
Is there power going to the relay? If yes, is there power going to the compressor clutch?

I'll check power in both locations tomorrow. Our son will be here tomorrow, has the same vehicle so we will troubleshoot it together.
b52rule is offline   Reply With Quote Quick reply to this message
Unread 07-03-2013, 08:10 AM   #15
WieSeL
Registered User
 
Join Date: Mar 2013
Posts: 472
Check power to the compressor while commanded on. If you have power and clutch does not engage you need a compressor as there is an open in the clutch circuit at the comp.
WieSeL is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.