2007 JGK 3.0 CRD dead A/C - JeepForum.com
Reply
 
LinkBack Thread Tools
post #1 of 23 Old 06-24-2013, 12:45 PM Thread Starter
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 44
2007 JGK 3.0 CRD dead A/C

The A/c just quit, dead, nothing. There is plenty of R134A in the system. I can't seem to get the compressor to kick in regardless if I use manual or auto settings. It will respond to heat settings but any A/c requests just brings in outside air.

I have checked the fuses and relays. One of the relays does get warm but that is about all.

Suggestions?

b52rule is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 06-24-2013, 02:06 PM
JRLT
Registered User
2010 WK 
 
Join Date: Aug 2011
Location: Mitchell
Posts: 1,615
Maybe it's overfilled.

2010 3.7L, 4XGuard Matrix, Fastman TB, TB Ground Mod, Injen CAI, 255/60/18 Nitto Terra Grapplers, Bilstein Shocks & Struts, Cruiser Alloy Wheels - Switchblade, Stillen Brakes, Cargo Light Strip Mod, Electric Ashtray Mod, Jet-powered, Monkey Navigated...
JRLT is offline  
post #3 of 23 Old 06-24-2013, 02:22 PM Thread Starter
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 44
Thanks for the reply. Dead center in the blue right where is should be.
b52rule is offline  
post #4 of 23 Old 06-24-2013, 11:47 PM
terrasmak
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Sin City
Posts: 591
Looks like I know what I'll be fixing when I'm home over the 4th. At least we will have a full selection of parts to swap off mine for troubleshooting.

"Racing makes Heroin addiction look like a vague wish for something salty." -- Peter Egan
terrasmak is offline  
post #5 of 23 Old 06-25-2013, 01:19 AM
jamie1131
Registered User
2003 WJ 
 
Join Date: Oct 2008
Location: Southampton, UK
Posts: 94
I had the same issue with my CRD. The shop told me i needed a new compressor.

I took the AC clutch relay out and checked it by putting it into the front fog lamp circuit. It worked just fine. I was lazy so i left it in that circuit and put the fog lamp relay back into the AC circuit and the compressor kicked straight into life.

I'm wondering if the relay was sticking and there wasn't enough power in the AC control circuit to drive it open.
jamie1131 is offline  
post #6 of 23 Old 06-25-2013, 06:37 PM Thread Starter
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 44
I'll give it a try and report back.


Thanks!
b52rule is offline  
post #7 of 23 Old 06-25-2013, 10:41 PM
Drewd
Registered User
 
Join Date: Jan 2006
Location: Colorado
Posts: 225
Would have never had this problem if you had a gasser
Drewd is offline  
post #8 of 23 Old 06-25-2013, 11:07 PM
terrasmak
Registered User
2007 WK 
 
Join Date: Jan 2012
Location: Sin City
Posts: 591
Quote:
Originally Posted by Drewd View Post
Would have never had this problem if you had a gasser
LoL , something else would have just broke.

"Racing makes Heroin addiction look like a vague wish for something salty." -- Peter Egan
terrasmak is offline  
post #9 of 23 Old 06-27-2013, 11:17 AM Thread Starter
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 44
Quote:
Originally Posted by jamie1131 View Post
I had the same issue with my CRD. The shop told me i needed a new compressor.

I took the AC clutch relay out and checked it by putting it into the front fog lamp circuit. It worked just fine. I was lazy so i left it in that circuit and put the fog lamp relay back into the AC circuit and the compressor kicked straight into life.

I'm wondering if the relay was sticking and there wasn't enough power in the AC control circuit to drive it open.

I tried that last night, no go............and no A/C

I'm open for more suggestions.

I have to take it into the dealer for a Safety Recall N23/NHTSA 13V-175. That is the last place I'd like to get it fixed however.
b52rule is offline  
post #10 of 23 Old 06-30-2013, 04:58 PM Thread Starter
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 44
Pulled and reset the high pressure connector below the receiver/dryer.............no go.
b52rule is offline  
post #11 of 23 Old 07-02-2013, 11:55 AM
jediknight
Registered User
2008 WK 
 
Join Date: Oct 2011
Location: Montreal
Posts: 647
... any codes ? Check engine ... ??

2008 WK CRD Blue, QD II, Startech SD6 mod.
jediknight is offline  
post #12 of 23 Old 07-02-2013, 11:56 AM
jamie1131
Registered User
2003 WJ 
 
Join Date: Oct 2008
Location: Southampton, UK
Posts: 94
Is there power going to the relay? If yes, is there power going to the compressor clutch?
jamie1131 is offline  
post #13 of 23 Old 07-02-2013, 11:32 PM Thread Starter
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 44
Quote:
Originally Posted by jediknight View Post
... any codes ? Check engine ... ??
No check engine lights, no codes. Our son will be here tomorrow, has the same vehicle so we will troubleshoot it together.
b52rule is offline  
post #14 of 23 Old 07-02-2013, 11:33 PM Thread Starter
b52rule
Registered User
2007 WK 
 
Join Date: Feb 2007
Location: SoCal
Posts: 44
Quote:
Originally Posted by jamie1131 View Post
Is there power going to the relay? If yes, is there power going to the compressor clutch?

I'll check power in both locations tomorrow. Our son will be here tomorrow, has the same vehicle so we will troubleshoot it together.
b52rule is offline  
post #15 of 23 Old 07-03-2013, 08:10 AM
WieSeL
Registered User
 
Join Date: Mar 2013
Posts: 472
Check power to the compressor while commanded on. If you have power and clutch does not engage you need a compressor as there is an open in the clutch circuit at the comp.
WieSeL is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome