2007 Jeep Grand Cherokee Ltd. Diesel - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 2007 Jeep Grand Cherokee Ltd. Diesel

Rough Country Lift Kits and Parts!RIGID LED Light Blowout Sale - All Sizes, All Series, all Hey Guys - Extreme Terrain Jeep Outfitters - ExtremeTerrai

Reply
Unread 04-10-2010, 11:07 AM   #1
director002
Registered User
2007 WK 
 
Join Date: Mar 2010
Location: Edmonton
Posts: 3
2007 Jeep Grand Cherokee Ltd. Diesel

OK, its time to throw this out to a you guys and see what people think might be the issue here.

The dealership has had my jeep in the shop for 3 weeks of the last 5. What is happening is as follows:

When driving down the road just after the vehicle has been started it will say "Service Park Assist Disabled" and the the "P, R, N, D" light up with boxes around them and the vehicle will no longer drive...often it will rev up a bit...then you have to pull over...turn the vehicle off and on a few times for it to go away so you can continue to drive it.

Now of course the dealer says they have to have it happen there to do something about it....it didn't, but while it was there last time a check engine light came on and then they checked out all the wiring to look for broken/pinched wires....and, not finding any, they replaced the TCM.

The Jeep shifts better from reverse to drive now (there used to be a hesitation when taking off in drive).

We got the Jeep back yesterday after they replaced the TCM...and it lasted one day before the "Service Park assist...." issue happened again....and its going back to the shop on Monday...probably for another week...

To date the dealer has:
1. Checked over all wiring for broken wires/bad connections
2. Replaced the TCM

What next? HELP!

director002 is offline   Reply With Quote Quick reply to this message
Unread 04-10-2010, 11:29 AM   #2
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Shifter Module is most likely. Ask what codes they are getting.
Regards,
Merlin
__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote Quick reply to this message
Unread 04-10-2010, 12:47 PM   #3
director002
Registered User
2007 WK 
 
Join Date: Mar 2010
Location: Edmonton
Posts: 3
Will do Merlin, thanks!

I take it in Monday morning again....will update then.
director002 is offline   Reply With Quote Quick reply to this message
Unread 04-10-2010, 01:11 PM   #4
cmassey_2006
Registered User
2006 WK 
 
Join Date: Apr 2006
Location: Georgia
Posts: 515
Quote:
Originally Posted by merlinTec View Post
Shifter Module is most likely. Ask what codes they are getting.
Regards,
Merlin
That's what mine ended up being. My previous '07 WK 3.7L began displaying a box around each "P R N D" letter (whereas normally just the current position of the shifter was boxed). The Jeep wouldn't accelerate when that happened and I would have to pull off the road and turn the key on, off, on, off, etc. until the "P R N D" display looked normal again. Then the Jeep would behave just fine for a while after that. When it happened again, I scanned for codes using an OBDII scanner, and it found one. I forget which one it was, but after searching online, the code seemed to be pointing at a faulty Shifter Module, as Merlin has suggested. I took it to Jeep (still under factory warranty), I gave them the code I found (I'm assuming they scanned it too with their scanner to be certain), and they ended up replacing the Shifter Module. It never happened again after that 'till the day I traded it in.

Good luck!
__________________
2006 White Jeep WK Limited 4x4: (current) 67K miles, 5.7L HEMI, auto, Quadra-drive II, factory tow hooks, hitch, skids, and many "bells and whistles"...

2007 Silver Jeep WK Laredo 4x4: (Sold) 10K miles, 3.7L V6, auto...

1998 Blue Jeep XJ 4x4: (Sold) @ 156K miles, I6, AW4 tranny, several mods...
cmassey_2006 is offline   Reply With Quote Quick reply to this message
Unread 04-11-2010, 08:59 AM   #5
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,811
a good read here about the problem and solution.

Code:
http://www.cherokeesrt8.com/forums/showthread.php?t=32822
__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)

Last edited by suzieque; 04-11-2010 at 12:12 PM..
suzieque is offline   Reply With Quote Quick reply to this message
Unread 04-12-2010, 12:42 AM   #6
menoche
Member
 
menoche's Avatar
2007 WK 
 
Join Date: Oct 2007
Location: Near Montreal
Posts: 165
had a similar problem and they changed the shifter
menoche is offline   Reply With Quote Quick reply to this message
Unread 04-16-2010, 08:18 PM   #7
director002
Registered User
2007 WK 
 
Join Date: Mar 2010
Location: Edmonton
Posts: 3
So, I showed the dealer this forum and they agreed to change the shifter module....hopefully that solves it....I'd rather drive my jeep than have it sit in the shop!
director002 is offline   Reply With Quote Quick reply to this message
Unread 03-30-2011, 06:19 PM   #8
wrangler91blue
Registered User
1991 YJ Wrangler 
 
Join Date: Jul 2010
Location: PA
Posts: 24
Ok well i am having the same problem now. I just replaced the shifter and all, $530 for the part. Now about 2 weeks later the same issue is coming up, The boxes are lit up and is making a thud noise. They just changed out the trans fluid and filter that day i changed out the shift part. They should just sell you the damn board.

What is the next step with this, so far the check engine light has not come back on, but the person that drives the car is a bit pissed that i replaced that part and the issue is there again.

Thanks
wrangler91blue is offline   Reply With Quote Quick reply to this message
Unread 03-31-2011, 08:31 AM   #9
Larz12345
Registered User
2007 WK 
 
Join Date: Dec 2010
Location: Indianapolis, IN
Posts: 39
I have an 07 Limited CRD 4x4. Had the exact same issue. It was the shifter command module. Merlin's input actually helped becuase the dealer didn't think it was it.
Larz12345 is offline   Reply With Quote Quick reply to this message
Unread 03-31-2011, 05:23 PM   #10
wrangler91blue
Registered User
1991 YJ Wrangler 
 
Join Date: Jul 2010
Location: PA
Posts: 24
how much is that, and does it need to be programmed, Im pissed the the shifter is in it now. That was $530
wrangler91blue is offline   Reply With Quote Quick reply to this message
Unread 07-02-2011, 09:39 AM   #11
wojomoto
Registered User
2007 WK 
 
Join Date: Jul 2011
Location: Traverse City, michigan
Posts: 29
New service bulletin for diesel

I have a 07 GC with the 3.0 CRD and it has always has issues shifting. the dealer couldn't figure it out and now the check engine light came on. He said it needed a new shift sensor module which costs $1000. I did some research on line and there is a new service bulletin from April 2011 stating that the Transmission Control Module needs to be replaced. Has anyone else had this problem or replaced this module? The service report number is 21-002-11.
wojomoto is offline   Reply With Quote Quick reply to this message
Unread 07-02-2011, 04:24 PM   #12
SSF556
Web Wheeler
 
SSF556's Avatar
2008 WK 
 
Join Date: Jan 2008
Location: SC
Posts: 2,856
Quote:
Originally Posted by wojomoto View Post
I have a 07 GC with the 3.0 CRD and it has always has issues shifting. the dealer couldn't figure it out and now the check engine light came on. He said it needed a new shift sensor module which costs $1000. I did some research on line and there is a new service bulletin from April 2011 stating that the Transmission Control Module needs to be replaced. Has anyone else had this problem or replaced this module? The service report number is 21-002-11.
The module in the TSB you mentioned is about $180 and I believe you can replace it yourself. Take the TSB to the dealer and tell them that you will buy the module and ask them to install it. There may be some reprogramming involved.

Merlin do you need to reprogram the new module?
__________________
Silver WK Club Member #1
2008 CRD QT2
SSF556 is offline   Reply With Quote Quick reply to this message
Unread 07-03-2011, 08:14 AM   #13
wojomoto
Registered User
2007 WK 
 
Join Date: Jul 2011
Location: Traverse City, michigan
Posts: 29
WK CRD Transmission

Does anyone know if the transmission used in the 2007 WK CRD is the same as the other engines? The two error codes I received were U0404 and P0607. The dealer said this is quite common in Jeeps and the price to repair is $1035. I wonder if I repair the module in the TSB it wil take care of these error codes? Thanks for any info!
wojomoto is offline   Reply With Quote Quick reply to this message
Unread 07-03-2011, 09:04 AM   #14
suzieque
Registered User
2008 WK 
 
Join Date: Mar 2009
Location: Canada
Posts: 1,811
well, this information suggests that Chrylser only has 2 transmissions available in the WK.
http://www.wkjeeps.com/wk_transm.htm

either a W5A580 used in the v6 gas engines or the W5A580 used in the v8 gas engines.

my build sheet says I have a W5J400, and if I google that part number, I find articles saying that is the transmission used in the 3.0L v6 diesel and the 6.1L v8 gas engine.

this thread gives common error codes for the W5J400 http://www.trnw.net/z-search/W5J400.php
but I do not see your error codes.

u0404 is the shifter control bezel, fairly common part to fail in all WKs http://www.jeepforum.com/forum/f67/0...-u0404-637569/

I suspect that once you replace the shifter control bezel, both codes will clear, but that is just my opinion.


Old Part Number still available at http://factorymoparparts.com/68004143ae.html
GEAR SELECTOR PRNDL BEZ
Item# 68004143AE
Regular price: $139.00
Sale price: $87.10


New part number at the same website
GEAR SELECTOR PRNDL BEZ
Item# 68004143AF
Regular price: $747.00
Sale price: $470.40

Keep in mind your dealer is charging you full retail
__________________
2008 WK "S" Limited bright metallic silver exterior, light graystone interior, 5 speed W5J400 transmission, June 18/2008 build, C213RE rear differential with 3.73 axle ratio, C200FE front differential with 3.73 axle ratio, 245/60R18 Goodyear Fortera tires (stock summer tires), NV245 transfer case, GT2056V turbo, 3.0L CRD (OM642.980)
suzieque is offline   Reply With Quote Quick reply to this message
Unread 07-03-2011, 10:13 AM   #15
SSF556
Web Wheeler
 
SSF556's Avatar
2008 WK 
 
Join Date: Jan 2008
Location: SC
Posts: 2,856
Quote:
Originally Posted by suzieque View Post
well, this information suggests that Chrylser only has 2 transmissions available in the WK.
http://www.wkjeeps.com/wk_transm.htm

either a W5A580 used in the v6 gas engines or the W5A580 used in the v8 gas engines.

my build sheet says I have a W5J400, and if I google that part number, I find articles saying that is the transmission used in the 3.0L v6 diesel and the 6.1L v8 gas engine.

this thread gives common error codes for the W5J400 http://www.trnw.net/z-search/W5J400.php
but I do not see your error codes.

u0404 is the shifter control bezel, fairly common part to fail in all WKs http://www.jeepforum.com/forum/f67/0...-u0404-637569/

I suspect that once you replace the shifter control bezel, both codes will clear, but that is just my opinion.


Old Part Number still available at http://factorymoparparts.com/68004143ae.html
GEAR SELECTOR PRNDL BEZ
Item# 68004143AE
Regular price: $139.00
Sale price: $87.10


New part number at the same website
GEAR SELECTOR PRNDL BEZ
Item# 68004143AF
Regular price: $747.00
Sale price: $470.40

Keep in mind your dealer is charging you full retail
So please explain the difference in the new and old parts...why the $400 difference?
__________________
Silver WK Club Member #1
2008 CRD QT2
SSF556 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.