2007 - Grand Cherokee - Hesitation - already spent $3900.00 trying to fix - HELP - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 2007 - Grand Cherokee - Hesitation - already spent $3900.00 trying to fix - HELP

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe ULTIMATE "Selectable" Locker System! BroughFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 07-19-2012, 11:58 AM   #1
Thielhart
Registered User
2007  
 
Join Date: Jul 2012
Location: New POrt Richey, FL
Posts: 4
2007 - Grand Cherokee - Hesitation - already spent $3900.00 trying to fix - HELP

2007 Grand Cherokee - Started out with felt like transmission was slipping - $2900.00 later the vehicle now has a hesitation in exceleration. Replaced two coils one injector / spark plugs / fuel filter. Just picked back up and started doing it again. It is not throwing a code that points to a specific problem. Any suggestions any ideas. I luv my Jeep but this is about to brake me.

Thielhart is offline   Reply With Quote
Unread 07-19-2012, 12:33 PM   #2
w1pf
Who, me?
 
w1pf's Avatar
2007 WK 
 
Join Date: Aug 2008
Location: Amherst, MA
Posts: 754
Which engine?

What did you do for $2900?
__________________
2014 WK2 Overland 5.9L
2007 WK Limited 5.7L
And some past Durangos
Red WK #19, Hemi #68.. I think..
Durango Owners Club DOTY 2011
-------
"Must have been that yesterday was the day that I was born"
w1pf is offline   Reply With Quote
Unread 07-19-2012, 12:47 PM   #3
Thielhart
Registered User
2007  
 
Join Date: Jul 2012
Location: New POrt Richey, FL
Posts: 4
4.7l v8

2900.00 rebuilt transmission
1000.00 tune up / fuel filter / 2 coils / 1 injector

Last edited by Thielhart; 07-19-2012 at 01:10 PM..
Thielhart is offline   Reply With Quote
Unread 07-20-2012, 07:48 AM   #4
Justcurious617
Registered User
 
Join Date: Jul 2012
Location: boston
Posts: 5
I am going thru the same issue. I bought it to the dealer told them it buckles, transmission slips. I had no warning light but just a "Service 4 Wheel Drive System" They wanted me to by a whole new transfer case and saw nothing else wrong. I took the car back and wanted a second opinion. So was going to bring it in for maintence today and bingo - light popped on, so now waiting for the call to see what exactly is the problem. Will keep you posted but going thru the same thing - hundreds trying to figure this thing out!!
Justcurious617 is offline   Reply With Quote
Unread 07-20-2012, 01:20 PM   #5
IndyBlueWK
Registered User
2005 WK 
 
Join Date: Feb 2012
Location: Carmel, indiana
Posts: 1,110
J-ust
E-mpty
E-very
P-ocket
IndyBlueWK is offline   Reply With Quote
Unread 07-20-2012, 01:38 PM   #6
modernblueWK
Registered User
 
Join Date: Jan 2010
Location: Gunnison, CO
Posts: 1,665
Fuel filter??? Isnt that built in to the pump?
__________________
2008 wk 4.7 v8 Laredo X QTII - 245/70-17 at2 - Magnflow 13742
Blue WK club #4
2013 HEMI Durango Awd Crew. All stock
modernblueWK is offline   Reply With Quote
Unread 07-20-2012, 08:16 PM   #7
Thielhart
Registered User
2007  
 
Join Date: Jul 2012
Location: New POrt Richey, FL
Posts: 4
Apparently not fuel filter is seperate - also replaced a vent hose ... Code came back up that Injector 2 is bad and that is the one that was just replaced. It's siting at the shop now. I was also told it set alot of ghost codes. Have no idea what that means.
Thielhart is offline   Reply With Quote
Unread 07-21-2012, 01:42 PM   #8
twingler
Registered User
2005 WK 
 
Join Date: Jul 2012
Location: Scottsdale, AZ
Posts: 24
Question - Do you have a k&N filter? or aftermarket filter that requires oil?
Reason I ask... Sounds like you may simply have a dirty MAF sensor. ( Mass airflow sensor ) It's located in the air intake tube. If the wire sensor has oil residue or dirt on it - then you will result in erratic air/fuel messages to the computer. The sensor is easily cleaned with MAF cleaner ( spray can like throttle body cleaner) DONT USE THROTTLEBODY CLEANER. You can get it at most parts stores. $6-8 a can. remove the air intake tube, remove the sensor and spray the wire clean.
twingler is offline   Reply With Quote
Unread 07-25-2012, 05:13 PM   #9
Thielhart
Registered User
2007  
 
Join Date: Jul 2012
Location: New POrt Richey, FL
Posts: 4
Yes I have a K&N Filter ...........I will try that. Thank you! Thank you! Anything is wortha try. Will update if it works.
Thielhart is offline   Reply With Quote
Unread 07-25-2012, 10:06 PM   #10
mmorlan
Registered User
2005 WK 
 
Join Date: Jul 2012
Location: Boone, Iowa
Posts: 12
I also have the same issue. It only happens every once in awhile and only when i start it. Its like the car doesn't want to accelerate for a couple of seconds and almost bogs down when you push on gas. Then after the few seconds it runs like a champ. Any suggestions?
mmorlan is offline   Reply With Quote
Unread 07-26-2012, 06:19 AM   #11
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,422
If one injector is clogged, then it is entirely possible that other received similar crap too. You may want to consider replacing all injectors. On my WJ the #4 injector stopped working properly. I had that one done at the dealer, and then #8 started causing issues. I did that one and another one in my garage, and all has been good since then. If anything else happens, I am just going to replace all of them.

Injectors all get their input from the same dirty tank. If one is clogged, odds are that others will have issues.
__________________
Kent

'06 XK Limited, 5.7L Hemi, Quadra-Drive II, Black, 118K Miles
'02 WJ Overland, 4.7L HO, Quadra-Drive, Inferno Red, 98K Miles
kentman is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.