2007 Grand Cherokee Courtesy lights & Radio won't turn off when key off, door opened. - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 18 Old 07-01-2014, 09:06 AM Thread Starter
maverickma
Registered User
 
Join Date: Jan 2005
Posts: 36
2007 Grand Cherokee Courtesy lights & Radio won't turn off when key off, door opened.

Long time lurker here. Thanks for all the great info, but this latest issue has me stumped. My interior lights will not go out when I turn the key off and lock the doors via the key fob. And now my radio will only turn off after about 10 minutes when I take the key out and open the door. Typically the radio and the time display turn off immediately after closing the door. I replaced the rear liftgate latch with a new Mopar one, checked/lubed all the door latches, checked the wires between driver door and body (none broken), and load tested the battery. Everything appears fine.

Guys I'm stumped. There are no relays for dimming the lights from what I can tell. Goes to the dealer on Thursday and they're talking about a new dash. Really? Any thoughts? Am I missing something?

maverickma is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 07-01-2014, 11:54 AM
ZWilson07
Registered User
2008 WK 
 
Join Date: Aug 2010
Location: Louisville
Posts: 159
So is it only turning off once you turn the wk off and open the door?

Or is it staying on for 10 minutes even after you turn the wk off, pull the key, and open the door and get out?

2008 WK Overland 5.7 Hemi 4x4 QD2

Everything I need, plus a lot more I don't.

Black WK Club Member #154 || Hemi Club Member #89
ZWilson07 is offline  
post #3 of 18 Old 07-01-2014, 12:24 PM Thread Starter
maverickma
Registered User
 
Join Date: Jan 2005
Posts: 36
The courtesy lights I can't get to turn off at all....Jeep started, not started, locked, not locked so I had to pull the fuse for the interior lights. The radio and clock readout will eventually turn off after I take key out open and close door and lock up. For now I just turn off the radio manually and the clock stays on for like 10 minutes and then turns off. That must be a power saving feature. Too bad the courtesy lights don't do that.
maverickma is offline  
post #4 of 18 Old 07-02-2014, 12:59 AM
masterofallbass
Registered User
2007 WK 
 
Join Date: Sep 2010
Location: Saint Cloud
Posts: 112
im having the same problem with my 07. my driver door doesn't register when open or closed on the dash. the windown switch for the front windows and power lock switch doesn't work on the driver side ever since the door doesn't register with the dash. #12 fuse is good and theres power to the door and I can roll down the windows to the rear windows with the driver switch. but with that being said if the door doesn't register its open all the courtesy lights & Radio won't turn off
masterofallbass is offline  
post #5 of 18 Old 07-02-2014, 06:45 AM Thread Starter
maverickma
Registered User
 
Join Date: Jan 2005
Posts: 36
If I had to guess, I would guess that both of our issues have something to do with that wire bundle running from the driver door to the chassis even though a visual inspection showed nothing. I didn't check inside the door and inside the chassis wherever they connect to.
maverickma is offline  
post #6 of 18 Old 07-03-2014, 12:12 AM
masterofallbass
Registered User
2007 WK 
 
Join Date: Sep 2010
Location: Saint Cloud
Posts: 112
if u find something let me know and ill do the same
masterofallbass is offline  
post #7 of 18 Old 07-03-2014, 03:45 AM
chrali
Registered User
2006 XK Commander 
 
Join Date: Jul 2012
Location: Great Yarmouth
Posts: 302
You sure you haven't turned the light stalk to have the courtesy light on?

Sent from my C6833 using JeepForum

Encourage alternative fuels - use all the petrol!
GDE HOT Tune
chrali is offline  
post #8 of 18 Old 07-03-2014, 05:06 AM Thread Starter
maverickma
Registered User
 
Join Date: Jan 2005
Posts: 36
Light stalk is not turned on.

Mbass yep, it goes to the dealer today so I'll keep you posted. I'm leaving in 30 minutes. Doug
maverickma is offline  
post #9 of 18 Old 07-03-2014, 09:22 AM Thread Starter
maverickma
Registered User
 
Join Date: Jan 2005
Posts: 36
Ok just back from the dealer. All the wiring and connections checked out from the door to the body. They are pretty sure its the driver side door latch so we had to order the part since it was not in stock. Just in case, I'm going to let the Jeep dealer install that part, but I'm not going back there until the 14th. I'll post a status on the 14th. Doug
maverickma is offline  
post #10 of 18 Old 07-17-2014, 12:41 AM
masterofallbass
Registered User
2007 WK 
 
Join Date: Sep 2010
Location: Saint Cloud
Posts: 112
so was it the door latch? thats my guess. if so how much did it cost?
masterofallbass is offline  
post #11 of 18 Old 07-17-2014, 06:34 AM Thread Starter
maverickma
Registered User
 
Join Date: Jan 2005
Posts: 36
Was not the door latch. Goes in again to the dealer on Monday. With labor the part was $225, yes I'm pissed and I will make sure that amount is credited to my bill. I bet the rear latch is bad, the one I just bought, but I have no patience to figure it out. Jeep service has been disappointing, at least from the two dealers I've been to.
maverickma is offline  
post #12 of 18 Old 07-17-2014, 07:06 AM
murderedoutGC
Registered User
2015 WK 
 
Join Date: Jun 2013
Posts: 431
Quote:
Originally Posted by maverickma View Post
Was not the door latch. Goes in again to the dealer on Monday. With labor the part was $225, yes I'm pissed and I will make sure that amount is credited to my bill. I bet the rear latch is bad, the one I just bought, but I have no patience to figure it out. Jeep service has been disappointing, at least from the two dealers I've been to.
if the latch was bad it should pop up in the notifications center notifying you that the rear latch is open wouldn't it?!

2015 GC Altitude White on black
murderedoutGC is offline  
post #13 of 18 Old 07-17-2014, 02:27 PM Thread Starter
maverickma
Registered User
 
Join Date: Jan 2005
Posts: 36
Not sure. It didn't last year when I had the issue. The only thing that would happen is the courtesy lights would stay on, no door ajar light on the dash etc. I lubed up that rear latch and it solved the issue for a year.
maverickma is offline  
post #14 of 18 Old 08-25-2014, 10:36 AM Thread Starter
maverickma
Registered User
 
Join Date: Jan 2005
Posts: 36
Issue resolved.

Sorry for the late update, but the issue has been resolved. It ended up being the console (where the odometer is contained). I'm told the dimming is controlled by the console, not by relays in the 2007 GC. The part alone was $525 and then add the labor. It was expensive, but it's now fixed. They said it's not common. Lucky me.
maverickma is offline  
post #15 of 18 Old 09-01-2014, 07:54 PM
masterofallbass
Registered User
2007 WK 
 
Join Date: Sep 2010
Location: Saint Cloud
Posts: 112
Nice im sure thats my problem too. What is the part number or name? Is it like a module?
masterofallbass is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome