2006 jeep commander - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 2006 jeep commander

NEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WDWe have Engo 10k Synthetic IN STOCK!!! Hurry while supplieSpartan Locker Promo Running now @ ROCKRIDGE 4WD plus FREE

Reply
Unread 01-07-2015, 06:41 PM   #1
The1manclan
Registered User
 
Join Date: Jan 2015
Posts: 2
2006 jeep commander

my jeep just started to mess up when i drive it all the gauges go dead to zero and all the warning lights come on. when this happens i have no turn signals or windshield wipers but it seems to run fine. if anyone knows what this could be please comment thanx

The1manclan is offline   Reply With Quote Quick reply to this message
Unread 01-08-2015, 07:43 AM   #2
JeepCACares
Registered User
 
Join Date: Oct 2014
Location: Windsor, Ontario
Posts: 72
Quote:
Originally Posted by The1manclan View Post
my jeep just started to mess up when i drive it all the gauges go dead to zero and all the warning lights come on. when this happens i have no turn signals or windshield wipers but it seems to run fine. if anyone knows what this could be please comment thanx
The1manclan,

I'm sorry to hear about your concerns. How often does this happen? Is it frequent or intermittent? Are there any error codes set?

The root cause can be a number of things. In some cases the symptoms can be related to the ignition switch. A diagnosis would be of benefit in order to determine the root cause.

Dave P.
Top Care Specialist
Chrysler Canada
JeepCACares is offline   Reply With Quote Quick reply to this message
Unread 01-08-2015, 05:01 PM   #3
imthehink
Registered User
2005 WK 
 
Join Date: Feb 2006
Location: Broken Arrow, OK
Posts: 1,033
Id put money on your ignition switch. Cheap and easy fix.
imthehink is online now   Reply With Quote Quick reply to this message
Unread 01-08-2015, 06:03 PM   #4
tom19511
Registered User
2006 WK 
 
Join Date: Mar 2009
Location: Sheffield Lake, OH
Posts: 544
X2, on your ignition switch. Same thing happened to me... There is a recall for the ignition switch.. I would wait to fix it if possible.
__________________
Tom19511
tchristopher1@wowway.com
2006 Grand Cherokee Laredo 3.7
2007 Liberty Sport 3.7
tom19511 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.