2005 WK electrical issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 11-26-2013, 04:00 PM Thread Starter
jbrem
Registered User
 
jbrem's Avatar
2005 WK 
 
Join Date: Aug 2005
Location: Lake Mills
Posts: 732
2005 WK electrical issue

Hey guys. Electrical issues are my least favorite so I petition the brain trust.

Driving back from work today my dash lights (everything) and cabin fan would flicker off very briefly, then come back on. When everything came back on it was as if the key had just been inserted and turned.

Headlights did not flicker off and no noticeable engine power changes during flickers.

This happened several times. Finally, the 'SERVICE ELEC BRAKE SYSTEM' messaged showed with the warning light staying lit as well. Lights continued to flicker on and off until I got home.

Any ideas? I slammed on the brakes on some snow/ice and ABS did NOT kick on so that would be the obvious place to start, but want to make sure there isn't something simpler that might be the cause.

Thanks!

jbrem is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-26-2013, 04:02 PM
Jeepforthewin
Registered User
2010 JK Wrangler 
 
Join Date: Jan 2013
Location: Jacksonville
Posts: 2,134
Do the "key dance" and post the codes.

2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline  
post #3 of 5 Old 11-26-2013, 04:32 PM Thread Starter
jbrem
Registered User
 
jbrem's Avatar
2005 WK 
 
Join Date: Aug 2005
Location: Lake Mills
Posts: 732
U0114

Please don't tell me it's the TCM...lol

EDIT: I wonder if this is related to the safety recall I received recently...let me dig it up.
jbrem is offline  
 
post #4 of 5 Old 11-26-2013, 04:49 PM
Jeepforthewin
Registered User
2010 JK Wrangler 
 
Join Date: Jan 2013
Location: Jacksonville
Posts: 2,134
That code is for: Lost communication with Final Drive Control Module

2010 JKU - Stock for now
2005 WK - 6" lift, 35" BFG's, a lot more (SOLD)
Jeepforthewin is offline  
post #5 of 5 Old 11-26-2013, 04:51 PM Thread Starter
jbrem
Registered User
 
jbrem's Avatar
2005 WK 
 
Join Date: Aug 2005
Location: Lake Mills
Posts: 732
Quote:
Originally Posted by Jeepforthewin View Post
That code is for: Lost communication with Final Drive Control Module
Bingo...exactly what the recall letter states.

Thanks for your help.
jbrem is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome