2005 Grand Cherokee Laredo Idle Problems - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 07-19-2009, 07:58 PM Thread Starter
johliatay
Registered User
 
Join Date: Jul 2009
Location: South Jersey
Posts: 5
2005 Grand Cherokee Laredo Idle Problems

Hello Everyone, After doing a lot of searching I am looking for feedback and clarification.
When I am sitting at a light my engine will rev high and then go way down. On a few occasions it has stalled because it idles too low. It will start right back up but the idle problem continues to persist.
After doing numerous searches it seems like it could be the Idle Control Valve.
So I have a few questions.
Could this actully be the issue? (I am not sure if the 2005 has one)
If this could be the issue, can anyone please let me know where I can find it on my Jeep? (on other threads I have seen where to find it, but those are on differnt model Jeeps and the pictures or diagrams do not match mine)
Also if this might be the problem, are they easy to clean?

Sorry for so many questions. I have taken it to the dealer twice and they can find no issues. Any help would really be appreciated.

johliatay is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-19-2009, 08:09 PM
bmuhlbach
Registered User
2005 WK 
 
Join Date: May 2008
Location: Hinckley,OH
Posts: 104
that is what my Daughters 01 Escape would do it never throw a code when it did it.
bmuhlbach is offline  
post #3 of 4 Old 07-20-2009, 11:45 AM
colinzj
Registered User
2006 WK 
 
Join Date: Mar 2005
Location: Chandler, AZ
Posts: 1,693
Which engine? 3.7 and 4.7 definitely have an IAC and the 5.7 probably does (but I don't know and don't have the FSM in front of me).

On the 4.7 (and I believe the 3.7), it's in basically the same place it's always been, too: On the throttle body right next to the TPS. It's easy to miss it if the resonator's still on, though, which may be why you're not seeing it.

2006 WK Laredo 4x4 4.7L
1993 ZJ Laredo 4x4 4.0L Dead, sold, and rolling again
colinzj is offline  
post #4 of 4 Old 07-20-2009, 02:18 PM
kiesha
Registered User
2006 WK 
 
Join Date: Jun 2008
Location: london
Posts: 302
hi, i had same problem on my 4.7, went to dealer they said there was no codes but they coud see the problem so they kept my car for 3 days and there was very easy solution as software update!!!
it solved the problem.
Merlin have tsb for this and he help me out.
Regards

WK 4.7 V8
kiesha is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
problems - 2005 Grand Cherokee 4.7 v8 (surging, idle jumping) thuhreb WK Grand Cherokee & XK Commander Forum 13 03-25-2016 11:07 AM
Tire inflation valve stem cracking 2005 Jeep Grand Cherokee Laredo JamieRE WK Grand Cherokee & XK Commander Forum 19 11-12-2012 08:12 AM
2005 Grand Cherokee Laredo Seat Covers ? lefty57 ZJ Grand Cherokee Forum 1 04-29-2006 07:13 PM
How to install tow hooks on 2005 Grand Cherokee Laredo? rambo-2000 ZJ Grand Cherokee Forum 2 04-05-2006 04:44 PM
1993 Grand Cherokee Laredo stalls on idle nelson76 ZJ Grand Cherokee Forum 8 01-15-2006 11:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome