2005 Grand Cherokee heat only works on max temp - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 34 Old 10-10-2013, 04:24 AM
Jasmin71
Registered User
2005  
 
Join Date: Feb 2013
Location: Lake
Posts: 11
I was told that heater itself needs to be re- calibrated....... whatever that means....was told its a dealer only fix

Jasmin71 is offline  
Sponsored Links
Advertisement
 
post #17 of 34 Old 12-12-2013, 09:10 PM
ChrisWK
Registered User
2005 WK 
 
Join Date: Mar 2011
Location: Atlanta
Posts: 169
Wow I have the same problem with my heater not working at different temps exact for max heat. This is on a 05 5.7 l with the auto a/c controls. Have any of you got a fix for this if so please let me know.

Thanks

Chriswk

Limited HEMI Dark Khaki Pearl SRT8 Full Body Kit, Roof Rails,SRT8 Engine Strut Bar, Lund Rear Spoiler, MYGIG INSTALLED with LOCKPICK, Kenwood Sub,AFE Intake, Taylor Spark Plug Wires,G2 Silver Painted Brake Calipers, Billet Tech Catch Can, Addco Sway Bars Front and Rear, Eibach Lowering Springs,Xenon Volt HID Lows 6k,Chrome SRT Reps
ChrisWK is offline  
post #18 of 34 Old 12-15-2013, 04:20 PM
ChrisWK
Registered User
2005 WK 
 
Join Date: Mar 2011
Location: Atlanta
Posts: 169
If you had your ac heater worked on my dealership what did they do to fix it.

Thanks

Limited HEMI Dark Khaki Pearl SRT8 Full Body Kit, Roof Rails,SRT8 Engine Strut Bar, Lund Rear Spoiler, MYGIG INSTALLED with LOCKPICK, Kenwood Sub,AFE Intake, Taylor Spark Plug Wires,G2 Silver Painted Brake Calipers, Billet Tech Catch Can, Addco Sway Bars Front and Rear, Eibach Lowering Springs,Xenon Volt HID Lows 6k,Chrome SRT Reps
ChrisWK is offline  
post #19 of 34 Old 12-15-2013, 05:58 PM
lowpsi
Registered User
2015 JK Wrangler 
 
Join Date: Nov 2013
Location: Baltimore
Posts: 68
my 05 WK has the same issue, I did not notice it until it started getting real cold, but it blows cold air unless at the max settings, which then blows very hot. WHile it is great that the heat blows so hot it gets a bit uncomfortable when running in the auto settings.

Is it me or are there a LOT of electrical problems related to the 05 WK's? It seems most all have the flashing dash lights, faulty heat controls, random window motor problems, and door locks malfunctioning. Not to mention the weird codes which seem to be thrown. If I did not already have one, I would think it is something to avoid purchasing.

2015 Wrangler Unlimited hydro blue Auto, 3:73 gears Power windows/door locks
lowpsi is offline  
post #20 of 34 Old 01-01-2014, 10:02 AM
94jeepman
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: rapid city
Posts: 778
Have you figured out how to fix this? It really Sucks going on road trips and having to turn on and off every few minutes haha
94jeepman is offline  
post #21 of 34 Old 01-05-2014, 07:48 PM
98jgc
Registered User
2005 WK 
 
Join Date: May 2006
Location: Oneonta, NY
Posts: 474
98jgc is offline  
post #22 of 34 Old 01-05-2014, 07:51 PM
98jgc
Registered User
2005 WK 
 
Join Date: May 2006
Location: Oneonta, NY
Posts: 474
Quote:
Originally Posted by Jasmin71 View Post
I was told that heater itself needs to be re- calibrated....... whatever that means....was told its a dealer only fix
That is like checking blinker fluid

The above post will solve your problem of MAX only function, takes 15 minutes and a torx screwdriver. Part is cheap.

http://www.amazon.com/Dorman-973-028.../dp/B003YLMPZA
98jgc is offline  
post #23 of 34 Old 01-05-2014, 08:50 PM
94jeepman
Registered User
2005 WK 
 
Join Date: Apr 2011
Location: rapid city
Posts: 778
Quote:
Originally Posted by 98jgc View Post
That is like checking blinker fluid

The above post will solve your problem of MAX only function, takes 15 minutes and a torx screwdriver. Part is cheap.

http://www.amazon.com/Dorman-973-028.../dp/B003YLMPZA
All I read on that was it fixing the blower problems and not the heat thing. Correct me dig I'm wrong
94jeepman is offline  
post #24 of 34 Old 02-01-2014, 02:36 PM
TRSonly1
Registered User
 
Join Date: Dec 2007
Location: GA
Posts: 30
Does anyone have a fix on this temperature issue? Same here, cold or hot only, nothing in between. Thanks
TRSonly1 is offline  
post #25 of 34 Old 02-01-2014, 04:16 PM
johnniebravo
Registered User
2008 WK 
 
Join Date: Sep 2002
Location: Bristow, VA
Posts: 898
I believe on the WK jeeps site there is a tsb on recalibrating/reflashing to fix this exact issue. Has something to do with temps not rising evenly when the knob is rotated.

And yes, there are a lit of issues with the 05 as it was the first year for the WK.

2008 CRD GC
johnniebravo is offline  
post #26 of 34 Old 02-02-2014, 09:44 PM
Joeyicu
Registered User
 
Joeyicu's Avatar
1998 ZJ 
 
Join Date: Jul 2006
Location: Columbia
Posts: 583
so, is this the fix or not. Mine has had this problem for the better part of 2 years.

{2005 WK Hemi }(1998 ZJ 5.2 - 3.5 IRO 31s) [1984 F250 6.9]
Joeyicu is offline  
post #27 of 34 Old 02-07-2014, 03:22 PM
chey308
Registered User
 
Join Date: Dec 2013
Location: Washington
Posts: 13
Have had the same thing going on. Recently found that if the dial is on a number not the red dot when I start the vehicle it seems to work ok and able to control the temp. Maybe something to try. Have also heard the blend doors can go bad and need to be replaced.
chey308 is offline  
post #28 of 34 Old 02-08-2014, 07:11 AM
twss22
Registered User
2005 WK 
 
Join Date: Nov 2013
Location: New Concord
Posts: 14
Had the same problem on a 2005 Cherokee, it was the blower motor resistor behind the glove box.
twss22 is offline  
post #29 of 34 Old 02-13-2014, 01:05 AM
Joeyicu
Registered User
 
Joeyicu's Avatar
1998 ZJ 
 
Join Date: Jul 2006
Location: Columbia
Posts: 583
the blower motor resistor? My blower motor will change speeds just fine, its just the temperature control/blend door related stuff. If I take her to work tomorrow in the truck I will try putting it on the middle and keeping it there and seeing how it goes, I am pretty sure mine will cycle to blowing cold like way to quickly. I need to take it to the dealer and have the new flash I think.

{2005 WK Hemi }(1998 ZJ 5.2 - 3.5 IRO 31s) [1984 F250 6.9]
Joeyicu is offline  
post #30 of 34 Old 04-29-2014, 04:03 AM
drupi
Registered User
2005 WK 
 
Join Date: Apr 2014
Location: Prague
Posts: 2
Anything new on this problem?? I have the same issue on my WK HEMI 05
drupi is offline  
Reply

Tags
2005 , grand cherokee , heater control , jeep , maximum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome