2005 4.7 Transmission Lag and hard shift - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 2005 4.7 Transmission Lag and hard shift

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueRIGID LED Light Blowout Sale - All Sizes, All Series, all End of Summer Sale, 20% OFF!

Reply
Unread 09-27-2013, 01:40 PM   #1
CT05WK
Registered User
 
Join Date: Sep 2013
Posts: 37
2005 4.7 Transmission Lag and hard shift

Occasionally when going from P to D I will get a minor lag and noticeable clunk when it engages.

Also from P to R it will engage but not move until I hit the accelerator at which point it feels like I'm in a low gear

In both circumstances I will go back to D and then shift to appropriate gear and it's fine.

To top it off I get a noticeable hard shift from 2-3 from time to time

Thoughts? I have 104,000 miles. Do not know maintenance history.

CT05WK is offline   Reply With Quote
Unread 09-27-2013, 05:08 PM   #2
JeepN4KC
Keep on Jeepin on........
 
JeepN4KC's Avatar
 
Join Date: Jul 2011
Location: Blue Springs, MO
Posts: 5,657
Quote:
Originally Posted by CT05WK View Post
Occasionally when going from P to D I will get a minor lag and noticeable clunk when it engages.

Also from P to R it will engage but not move until I hit the accelerator at which point it feels like I'm in a low gear

In both circumstances I will go back to D and then shift to appropriate gear and it's fine.

To top it off I get a noticeable hard shift from 2-3 from time to time

Thoughts? I have 104,000 miles. Do not know maintenance history.
I'd start with drain/refill of the tranny along with new tranny filters. See where that gets ya.
__________________
~Mike~

My Build Thread WK
My Other Build Thread XJ
'01 XJ with some stuff
Sept 2013 Cherokee of the Month
'07 WK with some other stuff
~RED WK CLUB #7~
'11 KK with mostly stock stuff
'06WK our first Jeep with stock stuff - totalled and gone
JeepN4KC is online now   Reply With Quote
Unread 09-27-2013, 08:43 PM   #3
CT05WK
Registered User
 
Join Date: Sep 2013
Posts: 37
Quote:
Originally Posted by JeepN4KC
I'd start with drain/refill of the tranny along with new tranny filters. See where that gets ya.
thanks.... Sometimes I feel like things can't just be that easy and assume the worst.
CT05WK is offline   Reply With Quote
Unread 10-06-2013, 09:09 PM   #4
CT05WK
Registered User
 
Join Date: Sep 2013
Posts: 37
UPDATE: DTC Codes P0869 and P0932... HELP!
CT05WK is offline   Reply With Quote
Unread 10-06-2013, 09:15 PM   #5
sickchilly
Registered User
2010 WK 
 
Join Date: Jan 2008
Location: Seattle, WA
Posts: 207
If you don't know the maintenance history, I would replace fluid and filters ASAP.

But I'm gonna bet your problem is the solenoid pack. It's about 2 bills and a pretty fast swap.
__________________
2010 Brilliant Black Crystal Pearl Coat Grand Cherokee S-Limited with various bits 'n pieces... broken in but not even finished!
sickchilly is offline   Reply With Quote
Unread 10-06-2013, 09:20 PM   #6
CT05WK
Registered User
 
Join Date: Sep 2013
Posts: 37
I don't know the history for sure... Fluid looks very clean, smells fine. I'd have to drop the pan..?
CT05WK is offline   Reply With Quote
Unread 10-06-2013, 09:55 PM   #7
sickchilly
Registered User
2010 WK 
 
Join Date: Jan 2008
Location: Seattle, WA
Posts: 207
Yes. Drain, drop pan, remove filter and valve body. Unplug solenoid pack, remove and replace. Then reassemble in reverse with new filter and ATF.
__________________
2010 Brilliant Black Crystal Pearl Coat Grand Cherokee S-Limited with various bits 'n pieces... broken in but not even finished!
sickchilly is offline   Reply With Quote
Unread 10-06-2013, 10:00 PM   #8
CT05WK
Registered User
 
Join Date: Sep 2013
Posts: 37
Sounds simple enough... Pretty common problem? Others have speculated speed sensors for the 3rd gear feeling when starting issue. Some have speculated TCM/PCM or even a new tranny!! How likely are those?
CT05WK is offline   Reply With Quote
Unread 10-06-2013, 10:42 PM   #9
sickchilly
Registered User
2010 WK 
 
Join Date: Jan 2008
Location: Seattle, WA
Posts: 207
Could be anything really. There's only so much keyboard/Google speculation I can do from here. But those two codes seem to point to a high pressure problem usually caused by a bad solenoid pack if you search around and read the threads on various forums.
__________________
2010 Brilliant Black Crystal Pearl Coat Grand Cherokee S-Limited with various bits 'n pieces... broken in but not even finished!
sickchilly is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.