'08 WK Transmission Temp Question - JeepForum.com

 
LinkBack Thread Tools
post #1 of 12 Old 06-25-2009, 06:01 PM Thread Starter
Grancher08
Registered User
2008 WK 
 
Join Date: Jun 2009
Location: Staten Island, NY
Posts: 15
'08 WK Transmission Temp Question

New here but I belong to other forums... the past couple of times I have driven the truck I receive a message saying Transmission Over Temp or something along those lines... any reason why I'm receiving this?

Grancher08 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 06-25-2009, 06:31 PM
Spider-One
Registered User
2008 WK 
 
Join Date: Jun 2008
Location: NT, Canada
Posts: 457
Because your transmission is over temp.... lol. Check the fluid, if it doesn't have a dip-stick have it checked at the dealer. It shouldn't give you a warning for nothing, either way you probably want it checked out.

2008 GC CRD, OME 2" lift kit, 265/70/R17 Cooper Discoverer S/T's, 1.5" Spidertrax spacers, gutted turbo resonator
Spider-One is offline  
post #3 of 12 Old 06-25-2009, 06:58 PM Thread Starter
Grancher08
Registered User
2008 WK 
 
Join Date: Jun 2009
Location: Staten Island, NY
Posts: 15
Ah damn. I got it in the beginning of December, should this be happening already? Jeez, I got a 2000 Mustang and my only problem is I need brakes right now lol... but not to strike anyone the wrong way, why should this happen? Not even 5 K on it yet...
Grancher08 is offline  
post #4 of 12 Old 06-26-2009, 04:59 PM Thread Starter
Grancher08
Registered User
2008 WK 
 
Join Date: Jun 2009
Location: Staten Island, NY
Posts: 15
Bumpbumpbump

2008 Jeep Grand Cherokee Laredo
-3.7L V6, Sun & Sound Package, nothing else too special
Grancher08 is offline  
post #5 of 12 Old 06-26-2009, 09:07 PM
no-blue-screen
Registered User
2008 WK 
 
Join Date: Aug 2006
Location: Laurel, MD
Posts: 662
Maybe low trans fluid from the factory. Check the trans fluid or have the dealer check it. Other thought would be parking brake out of adjustment or brakes dragging causing increased load on the trans. If the trans is overheating you are best not to drive it until you get it in to be looked at.
no-blue-screen is offline  
post #6 of 12 Old 06-27-2009, 01:55 AM Thread Starter
Grancher08
Registered User
2008 WK 
 
Join Date: Jun 2009
Location: Staten Island, NY
Posts: 15
There is no increased load at all, so I don't see that as the problem. I live in a borough of NYC and it's stop and go... plus I've been making deliveries in it recently, which forces me to go from Park to Drive and back to Park again frequently. Would that be giving the transmission some extra heat?

2008 Jeep Grand Cherokee Laredo
-3.7L V6, Sun & Sound Package, nothing else too special
Grancher08 is offline  
post #7 of 12 Old 06-27-2009, 02:09 AM
marlon_jbt
Registered User
2010 KK Liberty 
 
Join Date: Apr 2003
Location: Detroit, MI
Posts: 1,133
Question: Do you just see it flash really quick when you turn the key on?

Because if so, that's more of a software bug than anything. I believe there's a TSB to fix it.

Or does it come on and STAY on? That would definitely indicate a problem.

Red Jeep Club member # 264
marlon_jbt is offline  
post #8 of 12 Old 06-27-2009, 02:13 AM Thread Starter
Grancher08
Registered User
2008 WK 
 
Join Date: Jun 2009
Location: Staten Island, NY
Posts: 15
Well it happened twice to my knowledge. Once I came to a stop and put it in Park. I didn't open the door yet and I heard a chime and seen the message. I popped the hood but realized I couldn't see much. It kinda smelled like transmission fluid, but what would it mean if I smelled it?

2008 Jeep Grand Cherokee Laredo
-3.7L V6, Sun & Sound Package, nothing else too special
Grancher08 is offline  
post #9 of 12 Old 06-27-2009, 02:14 AM
marlon_jbt
Registered User
2010 KK Liberty 
 
Join Date: Apr 2003
Location: Detroit, MI
Posts: 1,133
Odd. But you certainly have an issue there. Are you still under warranty? (Although you should be, there are some of us (me) who will be out of warranty after 1 year, not 3 )

If so, time for a dealer visit.

Red Jeep Club member # 264
marlon_jbt is offline  
post #10 of 12 Old 06-27-2009, 08:52 AM
no-blue-screen
Registered User
2008 WK 
 
Join Date: Aug 2006
Location: Laurel, MD
Posts: 662
If you can smell trans fluid that sounds like you have a leak. If you look under the vehicle do you see any puddles or does the transmission pan look wet? I would take it in and get it checked out ASAP....if you have a trans leak and/or your trans is overheating this is likely to get worse before it gets better for you.
no-blue-screen is offline  
post #11 of 12 Old 06-27-2009, 02:53 PM Thread Starter
Grancher08
Registered User
2008 WK 
 
Join Date: Jun 2009
Location: Staten Island, NY
Posts: 15
Thanks for the help guys. I'll have it checked out and let you know.

2008 Jeep Grand Cherokee Laredo
-3.7L V6, Sun & Sound Package, nothing else too special
Grancher08 is offline  
post #12 of 12 Old 04-22-2014, 02:57 PM
CommanderKP07
Registered User
 
Join Date: Apr 2014
Location: Oklahoma City
Posts: 2
Same issue, plus some.

Similar problem. Had the warning flash briefly, but I needed to replace the water pump. Replaced it, then the starter went out. Replaced that, then it ran like crap. Low RPM's, no acceleration, took forever to putter around and start. Took to a shop, said it has a blown head gasket but I see no smoke and I hear no rattling. Shop diagnosed it, but is there a chance they missed something?
CommanderKP07 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
42RE Transmission Temp Sensor CP-Mike ZJ Grand Cherokee Forum 11 10-06-2010 05:13 PM
Transmission Over Temp bigdunz WK Grand Cherokee & XK Commander Forum 0 09-03-2009 07:15 AM
TRANSMISSION OVER TEMP message after trailer wiring install grandebob WK Grand Cherokee & XK Commander Forum 5 04-06-2009 02:42 PM
Transmission Temp Gauge - 94 GC - Power Source kdavis ZJ Grand Cherokee Forum 6 04-19-2005 11:47 AM
Question about engine temp/temp guage HighOnH2O ZJ Grand Cherokee Forum 8 07-25-2004 02:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome