08 WK Laredo, passenger side window won't go up with driver's door controller - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 08 WK Laredo, passenger side window won't go up with driver's door controller

ORS4x4: New Product!Aluminum Quick Release Fire Extinguisher Mounts from ORS4xKinetic Recovery Rope from ORS4x4

Reply
Unread 08-27-2015, 07:47 PM   #1
Schoch
Member
 
Schoch's Avatar
 
Join Date: Aug 2008
Location: Wake Forest, NC
Posts: 207
08 WK Laredo, passenger side window won't go up with driver's door controller

Of course, this is going to happen to me.

Just bought my wife an 08 WK Laredo. Really love it, slate blue with a black and charcoal interior. When we looked at it and test drove it, the windows all worked with no problem. Of course, when we get it home the passenger side window won't roll up. It is definitely a controller issue, but not sure if it is the driver's or passengers. The window rolls down fine with both controllers, but only will roll back up with the passenger side one. Rolls up perfectly, no problem with pass side switch. Nothing at all trying with the driver's side.

When I have XJs with a similar problem, it is usually the passenger side controller. I just want to be sure that is what it probably is before I start popping door panels on our 71k mile WK.

Schoch is offline   Reply With Quote Quick reply to this message
Unread 08-28-2015, 12:30 AM   #2
Red_liner740
Registered User
 
Join Date: Sep 2013
Location: Tottenham, On
Posts: 352
I had the same issue. Dirt in the drivers switches. Took it apart, contact cleaner and q-tips. Good to go.
Red_liner740 is offline   Reply With Quote Quick reply to this message
Unread 08-28-2015, 01:23 AM   #3
AFguy247
Registered User
2005 WK 
 
Join Date: Feb 2015
Location: Las Vegas, Nevada
Posts: 123
I've got the same problem. Except it's on all windows. So I guess i'll try to clean them tommorrow...
__________________
2005 Limited 5.7L Hemi QDII OME HD
AFguy247 is offline   Reply With Quote Quick reply to this message
Unread 08-28-2015, 07:11 AM   #4
Schoch
Member
 
Schoch's Avatar
 
Join Date: Aug 2008
Location: Wake Forest, NC
Posts: 207
Awesome, I'll try that first.
Schoch is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.