07 Jeep Commander; all warning lights - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 07 Jeep Commander; all warning lights

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectThanksgiving holiday sale in effect @ oconeeoffroad.comRugged Ridge 8500lb Winch w/ Steel Cable $294.99 Shipped O

Reply
Unread 07-28-2010, 02:45 PM   #1
jefkawst
Registered User
2007 XK Commander 
 
Join Date: Jul 2007
Location: West Melbourne, FL
Posts: 8
07 Jeep Commander; all warning lights

Hello all,

I need help with my 2007 Jeep Commander. Lately what's been going on is, all my warning lights would just come on. About last month, while driving through a residential area, all the warning indicator lights just came on and the Jeep stopped. On the dash it was reading transmission over heat and check gauges. I then had it towed to the Jeep Dealer. They found nothing wrong with it. The computer just gave out some codes and they tested all of them and everything turned out okay.They turned the car back over to me. Now, present time, this happened again just yesterday. Back to the dealer routine; the codes and computers and no failure found. Just turning the car back over to us. The dealers attitude towards it is nothing is broke, so nothing to fix.

This is going through the extended warranty that was purchased with the vehicle. Maybe that's why the dealers are being lazy and just relying on a computer to do the diagnostics instead of some good old fashioned real troubleshoothing skills. Whatever..

Anyone have any ideas or experience with intermittent warning lights/gauges on their Commanders. I would highly appreciatte it for some tips or options to help me with my Jeep.

Thank you all in advance,

Jeff

jefkawst is offline   Reply With Quote Quick reply to this message
Unread 07-28-2010, 03:13 PM   #2
meep
Registered User
2008 WK 
 
Join Date: Sep 2008
Posts: 1,008
i would start checking grounds, every one i can find. would also start the car, and wiggle harnesses, to see if that causes it. i'm thinking power loss, or power spike.

i have discovered if you off-restart engine while rolling, the computers go nuts, trans stays out of gear, skinny pedal goes inop and tach sits at 2k until you STOP. the electronics in these are PICKY.
meep is offline   Reply With Quote Quick reply to this message
Unread 07-28-2010, 03:21 PM   #3
merlinTec
Registered User
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Any chance they gave you the list of codes that it set?
__________________
UK Chrysler Jeep Master Tec.
merlinTec is offline   Reply With Quote Quick reply to this message
Unread 07-29-2010, 12:38 AM   #4
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,432
Battery.

I had a similar issue on startup in the XK about a year ago. I was about to send it to the dealer for diagnosis when my brother did some battery testing with the volt meter. He is an electrical engineer, and I am the mechanical engineer in the family. It shows. I had a dead cell, and it would not jump or hold a charge, but it would power up the electrical only to give lots of codes and dash lights.

Sure enough, I bought a new battery, and it fired right up with all codes gone. I bet that your battery is on the way out.
__________________
'06 XK Limited, 5.7L, QD II, Black, 127K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 103K
kentman is offline   Reply With Quote Quick reply to this message
Unread 08-10-2010, 06:02 AM   #5
jefkawst
Registered User
2007 XK Commander 
 
Join Date: Jul 2007
Location: West Melbourne, FL
Posts: 8
thanks for the replies all, but it's still happening.

Battery is good; measured 14V when in idle.

after the dealer, the 2nd time around. No failure found again. Can't do nothing.

I crawled all over and inside the jeep myself trying to find some frayed wires possibly shorting to the chassis. Everything is neatly kept and tucked away.

this happened again this morning just really quickly. the lights went on for about 2 seconds and then when back to normal. this was about a minute after starting it driving away from my house on the way to work. It didn't stall or anything, all panel lights just briefly went on then went off. And I was still off to work and made it.

What is up with Jeep, i'm seeing new post of problems with other jeep owners?

Anybody else have anything similiar with their Jeep Commander?

thanks again in advance,

Jeff
jefkawst is offline   Reply With Quote Quick reply to this message
Unread 08-10-2010, 06:34 AM   #6
kentman
Registered User
2006 XK Commander 
 
Join Date: Jan 2004
Location: Wilmington, NC
Posts: 1,432
Any aftermarket hardware (alarm, audio, remote starter, etc.)? Sometimes, this stuff can wreak havoc on the electrical system.

Also, are the battery terminals tight and do the terminal wires look good?

Beyond that, I do not know what to tell you. You are probably just going to have to wait until it dies and stays dead. At that point, you can have them troubleshoot the real reason for death. I would guess maybe a bad wire in the harness, a bad PCM, or a wire connector that is corroded.

You sure this vehicle has never been in the ocean water? If you are not the original owner, then I would be a little worried about its history. Have you noticed any excessive corrosion anywhere? It would suck if it was a Katrina vehicle or something similar. Ocean water is very rough on electrical.
__________________
'06 XK Limited, 5.7L, QD II, Black, 127K
'02 WJ Overland, 4.7L HO, QD, Inferno Red, 103K
kentman is offline   Reply With Quote Quick reply to this message
Unread 08-17-2010, 11:09 AM   #7
wookiee
Bought, not built.
 
wookiee's Avatar
2007 WK 
 
Join Date: Feb 2006
Location: Springfield, SD
Posts: 658
Same thing happened to my GC Overland.
It won't even start.
Same warnings. The dashhawk won't connect at all.
Bought new battery, no change.
Checked grounds, seem ok
I'm still looking for something, but tomorrow, I'll call the extended warranty people and let the dealer see what he can do.

Is there a way to reset the entire system?
__________________
07 Steel Blue Overland CRD QDII | Bilsteins | 4xguard Matrix | Rear SRT8 SwayBar | DashHawk w/egt | Provent MBRP XP Exhaust | New Intake Tube & Seal + EHM | Alternator Splash Guard | Crank Sensor | GPS AL InMotion Hack | Swirl motor bypass | Blue WK Club Member #13 | 100,000 Mile Club | Dogpiled Club | pre-N23 FDCM |
wookiee is offline   Reply With Quote Quick reply to this message
Unread 08-19-2010, 10:34 AM   #8
sal-XK
Senior Member
2007 XK Commander 
 
Join Date: Jun 2010
Location: raeford, NC
Posts: 722
How to get your DTC code Getting Diagnostic Trouble Codes (DTC) without DTC reader - Jeep Commander Forums: Jeep Commander Forum

List of the DTC codes DTC Table
sal-XK is offline   Reply With Quote Quick reply to this message
Unread 08-19-2010, 10:43 AM   #9
wookiee
Bought, not built.
 
wookiee's Avatar
2007 WK 
 
Join Date: Feb 2006
Location: Springfield, SD
Posts: 658
Quote:
Originally Posted by wookiee View Post
Same thing happened to my GC Overland.
It won't even start.
Same warnings. The dashhawk won't connect at all.
Was just a blown ignition 20A fuse #19.
All those warnings, but not one saying to check fuse.
__________________
07 Steel Blue Overland CRD QDII | Bilsteins | 4xguard Matrix | Rear SRT8 SwayBar | DashHawk w/egt | Provent MBRP XP Exhaust | New Intake Tube & Seal + EHM | Alternator Splash Guard | Crank Sensor | GPS AL InMotion Hack | Swirl motor bypass | Blue WK Club Member #13 | 100,000 Mile Club | Dogpiled Club | pre-N23 FDCM |
wookiee is offline   Reply With Quote Quick reply to this message
Unread 08-19-2010, 05:36 PM   #10
Walt
Registered User
2008 WK 
 
Join Date: Oct 2009
Location: Midland, MI
Posts: 1,530
Quote:
Originally Posted by jefkawst View Post
......Battery is good; measured 14V when in idle....
this happened again this morning just really quickly. the lights went on for about 2 seconds and then when back to normal. this was about a minute after starting it driving away from my house on the way to work. It didn't stall or anything, all panel lights just briefly went on then went off. And I was still off to work and made it.....
Jeff
Battery voltage may appear normal, but it's the battery capacity you should test. This would be especially true at idle when the alternator is charging the system to operating voltage under static conditions.

Sears, AutoZone, etc. can do this battery capacity test for you, usually at no charge. Seems we frequently see 05-07 WK's with batteries on the way out that cause erratic electronics behavior. kentman correctly suggested this.

Once a cell starts to go or sulfates up, it will intermittently work/short out. Once battery voltage dips below, say 11.5v or so, you are likely to see these symptoms. You may get good voltage in the driveway, but as the battery moves around the marginal cell may intermittently short below acceptable operating voltage.

Do you know the age of the battery? Intermittent symptoms are a b@tch on these new vehicles. Hang in there...do the easy stuff first.
__________________
HEMI CLUB MEMBER #45; SILVER WK CLUB MEMBER #13
'08 WK GC Limited. 5.7L HEMI. Quadra-Trac II. Bright Silver Metallic. Class IV hitch.
Michelin LTX M/S tires. Fumoto oil drain valve. Billet Technology oil catch can.
Walt is offline   Reply With Quote Quick reply to this message
Unread 11-30-2010, 02:11 AM   #11
Papayo
Registered User
2006 XK Commander 
 
Join Date: Nov 2010
Location: El Monte, California
Posts: 2
I had the same problem with my 06 commander about 2 years ago. The first two times it happened i took the jeep to the dealer with the check engine light on, but they coul not find anything wrong. The third time it happened to me i drove the jeep all the way to the dealer with all the dash lights flashing, stalling at every turn, the steering wheel very hard to turn and a clicking sound coming from the front tires. They replaced the ignition switch, related wiring and they reprogram the computer. After that i never had that problem again.
Papayo is offline   Reply With Quote Quick reply to this message
Unread 11-30-2010, 11:03 AM   #12
JKM
Registered User
2005 WK 
 
Join Date: Dec 2008
Location: Toronto, Ontario
Posts: 420
ignition switch a common problem on WKs. Part is about $50 (electrical switch and not the key tumbler).

Batteries are also problematic. Considering it's an 06 it's nearing the end of its life. To rule it out 100% I would spend the $100 on a new one. Worst case you bought a battery a year early.

Next I would replace the ignition switch. Common problem so do a search for this. Again for $50, it's worth changing it to rule it out
JKM is offline   Reply With Quote Quick reply to this message
Unread 11-30-2010, 11:48 AM   #13
NYTrailrider
Registered User
1988 MJ Comanche 
 
Join Date: Jan 2010
Location: St. Petersburg, FL
Posts: 331
Quote:
Originally Posted by jefkawst View Post
Hello all,

I need help with my 2007 Jeep Commander. Lately what's been going on is, all my warning lights would just come on. About last month, while driving through a residential area, all the warning indicator lights just came on and the Jeep stopped. On the dash it was reading transmission over heat and check gauges. I then had it towed to the Jeep Dealer. They found nothing wrong with it. The computer just gave out some codes and they tested all of them and everything turned out okay.They turned the car back over to me. Now, present time, this happened again just yesterday. Back to the dealer routine; the codes and computers and no failure found. Just turning the car back over to us. The dealers attitude towards it is nothing is broke, so nothing to fix.

This is going through the extended warranty that was purchased with the vehicle. Maybe that's why the dealers are being lazy and just relying on a computer to do the diagnostics instead of some good old fashioned real troubleshoothing skills. Whatever..

Anyone have any ideas or experience with intermittent warning lights/gauges on their Commanders. I would highly appreciatte it for some tips or options to help me with my Jeep.

Thank you all in advance,

Jeff
Destruction is imminent.
NYTrailrider is offline   Reply With Quote Quick reply to this message
Unread 04-15-2011, 06:17 AM   #14
skylery
Registered User
 
Join Date: Apr 2011
Location: orlando, FL
Posts: 1
I have an ‘07 Grand Cherokee, bought it new. 4.7 Flex Fuel. About two months ago all the indicator lights would come on. Back out of the driveway and some of them would go off and some would stay on the entire drive. Took it to the dealer and they couldn’t find anything wrong with it and told me to come pick it up. As they were driving it up to me from the back and all the indicator lights came. The issue was duplicated so then they thought it was the instrument cluster. Cluster was replaced after they kept it for 4 days because the mileage has to be reset. Here we are two months later and it just started again. I replaced the battery about 18 months ago with an optima so I don’t think that’s the issue. I do have a jet performance chip but have had that in it since ‘08. I don’t want to take this back to the dealer without having some back up because even thought I have a warranty it still $100 a pop.
skylery is offline   Reply With Quote Quick reply to this message
Unread 12-10-2012, 08:34 PM   #15
4theluvOcheese
Registered User
2007 XK Commander 
 
Join Date: Dec 2012
Location: Jesup, IA
Posts: 1
Same here

I just bought an 07 Jeep commander in September and have had similar issue. Mine is intermittent...all dash lights go on, heat shuts off, etc. I can still drive as normal but worried this will get worse. I have also had the water under driver seat. Will try batter first...saw another note on the water...what a pain in tha ace.
4theluvOcheese is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.