07' GC Diesel New Alternator Issue - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 07-27-2013, 10:51 PM Thread Starter
Registered User
Join Date: Jul 2012
Location: Midhurst
Posts: 13
07' GC Diesel New Alternator Issue

Just installed new Bosch alternator as per the write up in this forum.

Fired jeep up and the alternator won't spin. Removed the belt and I can't turn the alternator by hand.

Disconnected the + and signal wire off the alternator and now it is freed up. Spins fine.

The #1 lead on the signal wire matches up with the #1 prong on the alternator.

Could this be a bad alternator?

I hooked the + and signal wire back up with the alternator sitting on the frame rail where the air box would be. Ran the ignition through a cycle without firing up the jeep. Spins fine.

I'm thinking on getting my supplier to swap it out for another new unit.


Grimm18 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome