05 WK warning indicators came on - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 05 WK warning indicators came on

TeraFlex Now at Rockridge 4WD! BEST DEALS around!Alloy usa heavy duty ball joint kitsENGO QUADLUX 6" to 54" LED AMBER AND WHITE MULTI

Reply
Unread 08-11-2013, 10:07 AM   #1
JPK
Registered User
2005 WK 
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 210
05 WK warning indicators came on

Just got two warnings on my dash. First, service 4wd system. That's been happening for a couple of years when I'm in cruise control. Today I got a second one while in cruise control, service electric brake system. They only come on when in cruise control. Also, my ABS light came on and the anti skid off indicator came on as well. Any thoughts as to the issues? Thanks.

JPK is offline   Reply With Quote Quick reply to this message
Unread 08-11-2013, 12:26 PM   #2
kllshadow
Registered User
2006 WK 
 
Join Date: May 2011
Location: Altoona, PA
Posts: 366
Go to autozone or advanced and have them pull the codes causing the lights. Its free and more effective than guessing what could be the cause.
__________________
Black WK Club Member #61
kllshadow is offline   Reply With Quote Quick reply to this message
Unread 08-11-2013, 12:39 PM   #3
JPK
Registered User
2005 WK 
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 210
In searching the net....

...I believe I have a faulty wheel speed sensor. Don't know which wheel but I will check it out.
JPK is offline   Reply With Quote Quick reply to this message
Unread 08-11-2013, 03:04 PM   #4
JPK
Registered User
2005 WK 
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 210
Ran a check....

Three codes came up.

C1027 Left rear wheel speed sensor erratic
C1043 Left rear tone wheel
P1684 Battery loss in 50 starts

I know what the first one is, what do the second and third ones mean? Thanks.
JPK is offline   Reply With Quote Quick reply to this message
Unread 08-11-2013, 03:34 PM   #5
JPK
Registered User
2005 WK 
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 210
Looks like the tone wheel may be dirty as well. Will get it looked at. How much will the dealer charge, Any experience with this?
The last code indicates the battery has been disconnected within the last 50 starts....which it has been.
JPK is offline   Reply With Quote Quick reply to this message
Unread 08-11-2013, 03:38 PM   #6
JPK
Registered User
2005 WK 
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 210
How ironic.....Jeep is having dirty sensor issues when it is supposed to be "trail rated". Isn't that what Jeep's are supposed to do best.....get dirty?
JPK is offline   Reply With Quote Quick reply to this message
Unread 08-11-2013, 08:47 PM   #7
WieSeL
Registered User
 
Join Date: Mar 2013
Posts: 472
Check the wheel speed sensor and clean the tone ring . the sensors catch metal debris also due to it being magnetized
WieSeL is offline   Reply With Quote Quick reply to this message
Unread 08-12-2013, 03:10 AM   #8
Ditchd
Registered User
2009 WK 
 
Join Date: Jul 2013
Location: Billingham, Cleveland
Posts: 81
I have just been told that in the UK at least there is a recall for a software upgrade for the " final drive system " means very little to me at the moment but probably worth checking if there's similar your neck of the woods.
Ditchd is offline   Reply With Quote Quick reply to this message
Unread 08-15-2013, 04:57 PM   #9
JPK
Registered User
2005 WK 
 
Join Date: Jul 2006
Location: Jacksonville, FL
Posts: 210
Fixed....
JPK is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.