05 WK "Service Electric Brake System" Light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 05 WK "Service Electric Brake System" Light

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201FS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 11-22-2009, 03:59 PM   #1
wktim
Registered User
2005 WK 
 
Join Date: Oct 2008
Location: burlington, wi
Posts: 6
05 WK "Service Electric Brake System" Light

I know there has been alot of discussion of this issue, but i think i bring a new one to the table. About two weeks ago i was just driving down a flat road and all of my electrical shut off. No headlight, dash lights, radio, heater, faults, anything. It was off for 1-2 seconds then back on, when it came back on the Service Electric Brake System light was on. It continues to do this at completely random times and the light does not always come on. Any input?
Thanks, Tim

wktim is offline   Reply With Quote
Unread 11-24-2009, 05:43 PM   #2
wktim
Registered User
2005 WK 
 
Join Date: Oct 2008
Location: burlington, wi
Posts: 6
Update, they think it is the ignition switch , i will update to tell you if this works.
Tim
wktim is offline   Reply With Quote
Unread 11-25-2009, 04:48 PM   #3
xa310165
Registered User
2005 WK 
 
Join Date: Mar 2009
Location: Baltimore
Posts: 47
I have the same problem. Happened about 3 times since April, except I have the heater and radio still working. Only got the brake message once. I found that a few people have had the same issue and it seems to be the ignition switch. My dealership has never heard of the issue so I said screw them and have been riding on the problem. I might or might not get it fixed lol
xa310165 is offline   Reply With Quote
Unread 11-28-2009, 08:25 AM   #4
wktim
Registered User
2005 WK 
 
Join Date: Oct 2008
Location: burlington, wi
Posts: 6
OK so, as of now the ignition switch is the problem, and it did fix it. No more problem!!
wktim is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.