'05 WK Battery/electrical issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > '05 WK Battery/electrical issue

Introducing MONSTALINERô UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 11-06-2006, 10:56 AM   #1
ewarnecke002
Registered User
 
Join Date: Jun 2005
Location: Boulder, CO
Posts: 3
'05 WK Battery/electrical issue

I have a 2005 WK that tends to have a completely drained battery if the vehicle has not been driven for 2-3 weeks. I have checked every time to make sure no door was left open or light left on and this does not appear to be the issue. Has anyone else had this issue or know anything about this? I would tend to think there might be a short in the electrical system but with such a new, low mileage vehicle (15k), I would be suprised if this is it. Perhaps a bunk battery?

ewarnecke002 is offline   Reply With Quote
Unread 11-06-2006, 12:16 PM   #2
KingPrat
Registered User
2001 WJ 
 
Join Date: Jan 2006
Location: Saugerties, NY
Posts: 1,305
Quote:
Originally Posted by ewarnecke002
I have a 2005 WK that tends to have a completely drained battery if the vehicle has not been driven for 2-3 weeks. I have checked every time to make sure no door was left open or light left on and this does not appear to be the issue. Has anyone else had this issue or know anything about this? I would tend to think there might be a short in the electrical system but with such a new, low mileage vehicle (15k), I would be suprised if this is it. Perhaps a bunk battery?
With 15k, I doubt the battery, but it's a possibility. Bring it to the dealer or AutoZone or somewhere and have the battery tested. It's still under warranty, so the dealer should fix it.
__________________
New: Steel Blue 2001 Laredo 4.7, QD, Exhaust

Nokian Vatiiva tires: 235/65-17

Previous:1997 ZJ TSi 4.0. Some stuff added


Western New England College '08
Golden Bear Lacrosse #13
Week 11 USILA Rank: #15
2008: 16-5
NCAA Elite 8
TCCC Champions



Please read and share!!
KingPrat is offline   Reply With Quote
Unread 11-08-2006, 05:47 AM   #3
jim2527
Registered User
 
Join Date: Oct 2004
Posts: 57
There is a TSB pertaining to batteries. Mine wouldn't start a few ago. I had excessive corrosion on my positive terminal. After thoroughly cleanig it it started right up. If your battery part # ends with 719AD it may be a bad battery.

http://wkjeeps.com/tsb/wk_rapid_response_05-035.pdf
jim2527 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.