05 occasional hard starting - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 05 occasional hard starting

BDS 4-1/2" Suspension Lift Kit - Jeep Wrangler YJRough Country Lift Kits and Parts!FREE, FREE, FREE EVENT!! Save big on Lockers now till Apri

Reply
Unread 12-24-2015, 04:43 PM   #1
LA2
Registered User
 
Join Date: Dec 2015
Location: Orange City, fl
Posts: 6
05 occasional hard starting

my 05 WK recently became hard to start occasionally. new battery and diagnostics show no problem. it will start fine for days then wont. cranks and acts like a fuel problem. after 3-4 tries it starts. changed the fuel relay with no difference. once started it runs perfectly. of course when in the shop it starts fine. I am new to the form but desperate to find a solution. I will check back but if you know of this problem please email me lad@ladart.com

LA2 is offline   Reply With Quote Quick reply to this message
Unread 12-25-2015, 07:59 AM   #2
RCS1300
Registered User
2005 WK 
 
Join Date: May 2014
Location: Stamford, Connecticut
Posts: 645
Connect an oscilloscope to the crank and cam sensors and check to make sure that they are operating correctly. Also, connect a fuel pressure gauge to the fuel rail and see if the fuel pressure is within specification.
RCS1300 is offline   Reply With Quote Quick reply to this message
Unread 12-25-2015, 09:50 AM   #3
LA2
Registered User
 
Join Date: Dec 2015
Location: Orange City, fl
Posts: 6
I know the fuel pressure was checked but thanks for the tip on the crank and cam sensors - will try that
LA2 is offline   Reply With Quote Quick reply to this message
Unread 12-25-2015, 08:44 PM   #4
92JEEPWRANGLERY
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2009
Location: Chattanooga, Tennessee
Posts: 111
Sounds exactly like the symptoms on our 05 5.7. I put a fuel pump in it and all is well!
92JEEPWRANGLERY is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.