05 JGC 4.7 won't start, electrical issues?? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK Grand Cherokee & XK Commander Forum > 05 JGC 4.7 won't start, electrical issues??

TeraFlex Now at Rockridge 4WD! BEST DEALS around!Alloy usa heavy duty ball joint kitsENGO QUADLUX 6" to 54" LED AMBER AND WHITE MULTI

Reply
Unread 08-24-2012, 06:18 AM   #1
hwk305
Registered User
2005 TJ Wrangler 
 
Join Date: Aug 2012
Location: Mechanic Falls, Maine
Posts: 1
05 JGC 4.7 won't start, electrical issues??

Dash lights started occasionally flickering about a year ago. Then over the course of the next 5 or 6 months it stalled/cut-out while driving (lost all power) around 4 times. engine light would come on for awhile and go out for awhile, code for EGR valve. about 2 months ago a new problem started to emerge, on occasion it wouldn't start, it would just click. A jump start would get it going every time, sometimes a few key turns and it would start right up like nothing was wrong. A couple weeks ago, leaving work, the engine was running rough, it was difficult to go 45mph, got home, shut it off and it hasn't started since (turns over just doesn't fire). it has thrown the P0522(oil pressure) code... reset removed neg term....then U1417, U1418. exhaust has a little steam coming out (smells gassy, like a flooded engine) I haven't done anything to it since it all started.

hwk305 is offline   Reply With Quote Quick reply to this message
Unread 10-16-2012, 01:28 PM   #2
mjjopling
Registered User
2005 WK 
 
Join Date: Nov 2010
Location: Austin, TX
Posts: 120
Sounds like a computer, ever find out what was wrong?
__________________
2005 WK Limited 4.7L QTII (Black WK Club Member #4)
1970 Mustang Mach 1 / 1970 Mustang Coupe - 5spd 302 / 1979 Bronco XLT / 1978 Bronco - 38s, 4.10s - R.I.P. / 1993 F150 XLT Supercab - 5.8L / 1948 F1 - Flathead 6
mjjopling is offline   Reply With Quote Quick reply to this message
Reply

Tags
battery issue , electrical issue , jeep , stall issue , won't start

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.