New xj owner...problem areas? -

LinkBack Thread Tools
post #1 of 2 Old 11-17-2013, 10:53 AM Thread Starter
Registered User
Join Date: Nov 2013
Posts: 3
New xj owner...problem areas?

I'm looking at a 1999 cherokee 4.0 4x4 auto with 170k miles for $1500.*
The seller says it uses coolant but its not going into the oil or leaking out.
Also, at an idle the oil pressure drops to 0 on the gauge and the "check gauges" light comes on but doesn't make any noise. Above idle it builds ~40 psi.
Are these common issues? Is this worth the price for me to fix?

Thanks in advance!

tvanlant is offline  
Sponsored Links
post #2 of 2 Old 11-19-2013, 11:16 AM
1ATony's Avatar
1989 YJ Wrangler 
Join Date: Apr 2009
Location: mass
Posts: 5,812
Make sure it's not going into the tranny. Pull the radiator cap and see if there's oil in the radiator fluid. Hope this helps you out.

1ATony is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome