No turn signals or hazards - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 01-15-2014, 11:52 AM Thread Starter
crsalvarado
Registered User
 
Join Date: Jan 2014
Location: denver
Posts: 1
No turn signals or hazards

NO TURN SIGNAL OR HAZARDS pleeeeeeease HELP !!!


the other day started car put in drive and BAM!!! car went dead no lights stereo nothing heard a clicking sound what I figured was coming from fuse panel after puling courtesy lamp fuse clicking stopped still no power so I figured maybe it was alt but after jumpstart car started right up drove a few blocks and BAM AGAIN car stopped no power ...has to be altenator right well 30 seconds a buzzing sound lasted a few seconds wouldn't you know power have not had an issue since then but now I have NO TURN SIGNALS OR HAZARDS no clicking no light absolutely NOTHING any ideas would be helpful already purchased new flasher relay but was told may not be issue since Im not even getting light from bulb all fuses good ....

crsalvarado is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome