post #1 of Old 04-18-2011, 11:26 AM Thread Starter
muddy_tires
Registered User
 
Join Date: Apr 2011
Location: lockport
Posts: 3
sooo aggravating!!!!!

ok i just got a used 1991 jeep cherokee laredo and granted some things were wrong but that was to be expected, but one of the things was the hazard and turn signals wont work. ive checked the fuses and they are all good but in thinkin its the flasher fuses but i cant find them i even got a repair manual from o'reilys but it dont tell me squat! ive torn the dash apart as well but i also cheacked the fuse box under the hood as well, please give me some insight im goin crazy!!!!

muddy_tires is offline  
post #2 of Old 04-18-2011, 11:39 AM
pleontks
Registered User
1976 J-Series Truck 
 
Join Date: Apr 2010
Location: Whetstone, Az
Posts: 1,130
flasher runs off of a relay. It's a little box (1"x1 1/2")? usually under dash.
you could also have all dead bulbs. Check the bulbs.

Beauty is in the eye of the jeepowner.
pleontks is offline  
post #3 of Old 04-18-2011, 11:57 AM
BJ's Off-Road
Registered User
1979 FSJ Cherokee 
 
Join Date: Oct 2004
Location: Gig Harbor, WA
Posts: 1,379
You may get more answers in the Jeep Cherokee XJ forum. This section is for the full-size Cherokees that were built from 1974-1983. Here is a link:

http://www.jeepforum.com/forum/f114/

www.bjsoffroad.com
BJ's Off-Road is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome