post #1 of Old 10-15-2013, 10:11 PM Thread Starter
cookingguy
Registered User
1979 FSJ Cherokee 
 
Join Date: Nov 2010
Location: Port Hueneme
Posts: 559
loose locking hub

So about 1 or 2 months ago I changed my locking hub out due to a failed something or another. All was going well till today I went to the bank and noticed splatering of some fluid on my wheel. Well I got home look into it more and my locking hub is a litte loose. I tried to tight the Allen head bolts that hold it in place and they won't tight up any more. I need some ideas on what may be going on this is my daily driver and need it in top running shape. I installed mile marker hubs and its a Dana 44 front end thanks for any ideas

cookingguy is offline  
post #2 of Old 10-16-2013, 03:55 PM
pleontks
Registered User
1976 J-Series Truck 
 
Join Date: Apr 2010
Location: Whetstone, Az
Posts: 1,130
I had rattling warn hubs on my 76. I replaced them with milemarkers. Still rattled. My warn's had rattled for years with no problem.

Mine has the quadra-trac, and I think the hub may be machined just a little differently, since it's supposed to take slugs and not selectables.

What I ended up doing to get rid of the wiggle/rattle is I only installed 1 of the retainer clips. I think I installed the inner, and left the outer ring out. This totally fixed my problem, and everything seems to be working right. I do not, however, know if this was a good idea or not, only that it worked.

Beauty is in the eye of the jeepowner.
pleontks is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome