Instrument lights not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Full Size Jeep Forum > Instrument lights not working

Gear Installs at CCOR SpecialSavvy FOX IFP 4" Lift Shocks in StockSavvy/Currie Aluminum Control Arms

Reply
Unread 05-22-2013, 07:56 PM   #1
Chrisv102581
Registered User
1979 J-Series Truck 
 
Join Date: Sep 2012
Location: Dover, DE
Posts: 6
Instrument lights not working

My instrument lights (all except turn signal indicators) aren't working. I switched out all the bulbs and nothing. Where should I start?

Chrisv102581 is offline   Reply With Quote Quick reply to this message
Unread 05-24-2013, 10:32 AM   #2
Dale1966
Registered User
1980 FSJ Wagoneer 
 
Join Date: May 2013
Location: Jacksonville, Fl
Posts: 8
Chris, have you checked all fuses ?
Dale1966 is offline   Reply With Quote Quick reply to this message
Unread 05-24-2013, 02:12 PM   #3
Dngrs1
Registered User
1979 CJ7 
 
Join Date: May 2009
Location: Mohave Valley,AZ
Posts: 821
Make sure there is a good ground to the instrument cluster board.
__________________
I would rather have a tool I don't need, than need a tool I don't have.
Dngrs1 is offline   Reply With Quote Quick reply to this message
Unread 05-24-2013, 09:03 PM   #4
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 988
Mine too, i tried to clean contacts, i think it could be headlight switch on mine. Not sure,
Sub'ed
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
79chiefs is offline   Reply With Quote Quick reply to this message
Unread 05-25-2013, 02:28 PM   #5
bcrawler
Registered User
1981 FSJ Cherokee 
 
Join Date: Feb 2008
Location: Duncan,B.C.
Posts: 7
Mine did the same thing.Try running a wire from the speedo screws on the back to ground and test the lights. Mine lost ground and this is the repair I did to fix.
bcrawler is offline   Reply With Quote Quick reply to this message
Unread 05-25-2013, 04:58 PM   #6
revelc
Registered User
1985 FSJ Wagoneer 
 
Join Date: Nov 2011
Location: Tyler, Texas
Posts: 663
Mine worked after I rotated my headlight switch back and forth a few times.
__________________
Wag Rebuilt 360, 260H, 727, Locked 44, AMC 20, 208, 31" M/T's, 4" Rustys, 2.5" Duals. SOON:SOA SF, 496, T400, Doubler, D60's, 37" M/T's <-TOY
Cherokee Rebuilt 360, 2" Duals, mostly stock. SOON: Hot Street 401, 4'' Rustys, 33" BFG A/T's maybe a T-case to get rid of Q-Track <-TOW RIG
revelc is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.