Instrument lights not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Full Size Jeep Forum > Instrument lights not working

End of Summer Sale, 20% OFF!2007 - 2011 Jeep JK Long Arm Lift KitsIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 05-22-2013, 06:56 PM   #1
Chrisv102581
Registered User
1979 J-Series Truck 
 
Join Date: Sep 2012
Location: Dover, DE
Posts: 6
Instrument lights not working

My instrument lights (all except turn signal indicators) aren't working. I switched out all the bulbs and nothing. Where should I start?

Chrisv102581 is offline   Reply With Quote
Unread 05-24-2013, 09:32 AM   #2
Dale1966
Registered User
1980 FSJ Wagoneer 
 
Join Date: May 2013
Location: Jacksonville, Fl
Posts: 8
Chris, have you checked all fuses ?
Dale1966 is offline   Reply With Quote
Unread 05-24-2013, 01:12 PM   #3
Dngrs1
Registered User
1979 CJ7 
 
Join Date: May 2009
Location: Mohave Valley,AZ
Posts: 796
Make sure there is a good ground to the instrument cluster board.
__________________
I would rather have a tool I don't need, than need a tool I don't have.
Dngrs1 is offline   Reply With Quote
Unread 05-24-2013, 08:03 PM   #4
79chiefs
Registered User
1988 XJ Cherokee 
 
Join Date: Dec 2012
Location: Lillington, NC
Posts: 964
Mine too, i tried to clean contacts, i think it could be headlight switch on mine. Not sure,
Sub'ed
__________________
99WJ Laredo I6-A 2wd
88XJ-Building on a budget.
95 E34 540i-DD
Had/have 6Jeeps/5Cherokees/4XJ's
79chiefs is offline   Reply With Quote
Unread 05-25-2013, 01:28 PM   #5
bcrawler
Registered User
1981 FSJ Cherokee 
 
Join Date: Feb 2008
Location: Duncan,B.C.
Posts: 7
Mine did the same thing.Try running a wire from the speedo screws on the back to ground and test the lights. Mine lost ground and this is the repair I did to fix.
bcrawler is offline   Reply With Quote
Unread 05-25-2013, 03:58 PM   #6
revelc
Registered User
1985 FSJ Wagoneer 
 
Join Date: Nov 2011
Location: Tyler, Texas
Posts: 663
Mine worked after I rotated my headlight switch back and forth a few times.
__________________
Wag Rebuilt 360, 260H, 727, Locked 44, AMC 20, 208, 31" M/T's, 4" Rustys, 2.5" Duals. SOON:SOA SF, 496, T400, Doubler, D60's, 37" M/T's <-TOY
Cherokee Rebuilt 360, 2" Duals, mostly stock. SOON: Hot Street 401, 4'' Rustys, 33" BFG A/T's maybe a T-case to get rid of Q-Track <-TOW RIG
revelc is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.