got my cherokee running, but it will not go forward! - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 10-07-2008, 07:52 PM Thread Starter
ifurlong
Registered User
 
Join Date: Oct 2008
Location: 92371
Posts: 8
got my cherokee running, but it will not go forward!

it will move in reverse, any suggestions?
it kind on moves in foreword but barely

ifurlong is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-07-2008, 08:18 PM
bgabrielse
Registered User
1998  
 
Join Date: Oct 2008
Location: Sheboygan
Posts: 4
you might have the same problem as i just had with my wrangler. could be the Clutch Pack in the transmission, or a clogged transmission filter.
bgabrielse is offline  
post #3 of 5 Old 10-07-2008, 08:26 PM Thread Starter
ifurlong
Registered User
 
Join Date: Oct 2008
Location: 92371
Posts: 8
is it is the tranny I assume a standard rebuild will fix the problem.
I was just reading about the QT T-case, there is a vacuum switch in the glove box...well, mine has no glove box, there is a door, bot nothing behind it, and there is a part which looks suspiciously like a vacuum switch dangling from the dash right under where the glove box would be, I wonder if something is missing?
ifurlong is offline  
 
post #4 of 5 Old 10-07-2008, 08:53 PM
BJ's Off-Road
Registered User
1979 FSJ Cherokee 
 
Join Date: Oct 2004
Location: Gig Harbor, WA
Posts: 1,379
Is your front driveline in it?

www.bjsoffroad.com
BJ's Off-Road is offline  
post #5 of 5 Old 10-08-2008, 09:32 AM Thread Starter
ifurlong
Registered User
 
Join Date: Oct 2008
Location: 92371
Posts: 8
do you mean the front drive shaft? yes, its in
ifurlong is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
anybody running lights on the A-pillar? coyote1911 Full Size Jeep Forum 0 08-19-2009 12:27 PM
1957 Forward Control OnTheRocks Full Size Jeep Forum 1 01-21-2009 05:30 PM
Any One Running 70's era. Cherokee's? poppatello Full Size Jeep Forum 10 04-11-2008 01:58 PM
1988 GW Engine Keeps Running... jnc123ny Full Size Jeep Forum 2 12-25-2007 09:36 AM
Forward Cab site... paulthejeeper Full Size Jeep Forum 0 12-24-2007 01:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome