post #1 of Old 03-27-2013, 04:37 PM Thread Starter
JTRUCKSD
Registered User
 
Join Date: Mar 2013
Location: Piedmont
Posts: 1
82 J20 new to the forum

Hey guys just got my new 1982 J20. Love the truck but this is going to be a long haul (needs quite a bit of work). Things that I notice are wiring is a nightmare. fuel gage and temp gauge don't work (just put in aftermarket temp gauge). and needs a new t-stat just to name a few. I want to restore it as money is available. not show truck quality but a decent frame up. any ideas let me know, and what do yea think? paid $1500

Attached Thumbnails
j20-1.jpg   j20-2.jpg  
JTRUCKSD is offline  
post #2 of Old 03-27-2013, 05:23 PM
RockRollin
Registered User
1990 FSJ Wagoneer 
 
Join Date: Apr 2012
Location: Grand Haven Mi
Posts: 1,325
Welcome
Always liked that patina look, no rust through, then clear coat that puppy.
Search the forum for like issues, you'll probably find what ya need for info. Looks good from what I can tell , I belive there's a Wagoneer running around with a muscle grill though.

"I like fun" Edd
Clawed: 90GW, TFI, Streetfire, 3"lift all spring, 31"BFG ATs, working RKE, Edel2131, Holly 1850, mild cam,
05 Renegade OME 927, 947, top plate, JBA 4.5s
"Just Jeepin it real"
RockRollin is offline  
post #3 of Old 03-27-2013, 07:50 PM
Saul32
Registered User
1988 FSJ Wagoneer 
 
Join Date: Jun 2012
Location: Chicago
Posts: 657
Welcome and X2 on the patina look. Good luck with the new toy and post pics n updates when you can.

Nothing important...
Saul32 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome