At A Stump HELP - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 02-03-2014, 08:51 PM Thread Starter
bozzman080
Registered User
1987 MJ Comanche 
 
Join Date: Feb 2014
Location: castle rock
Posts: 4
my 4.0 will not run right HELP!!!

I just bought a 1987 jeep Comanche 2WD 4.0 with 5speed
I am at a loss since when I test drove it she ran like a gusty 4.0 should loads of torque, now it is acting up
it was stalling and dying and the tachometer was jumping all over the place
so I did this so far
new
cap, rotor, wires, bosch platinum plugs, CPS, IAC, Fuel filter, all vacuum lines inspected and replaced as needed, Coil ,Ignition control module,
after all this a few hundred dollar's later she idles and revs only to around 2800rpm then dies out and falls on her face
also running very rich
I cant figure this out new TPS is on order
any other suggestion's , I am about to Craig's list her and walk away


Last edited by bozzman080; 02-04-2014 at 12:02 PM.
bozzman080 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-04-2014, 05:48 PM
Caish
Registered User
1987 XJ Cherokee 
 
Join Date: Jul 2010
Location: Central
Posts: 631
unplug the Crank Position sensor and plug it back in and get one to replace it.
I would also suggest pulling it out and cleaning it off and might even try drilling
one of the holes out to a 3/8" so you can get it a little closer for better signal.

My 87 Renix occasionally won't start, when it happens, I just unplug mine and
plug it back in and its good for 2 to 4 months.

Join us on Jeeperz Creeperz on Google+
Facebook: Arkansas Jeeps
Caish is offline  
post #3 of 4 Old 02-04-2014, 06:57 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,033
Click on the link in my signature. Do posts 1 through 5. Platinum plugs suck BTW. NGK all the way.

If you own a Renix Jeep, you'll want to check this out.

An index to over 30 write-ups can be found in the link below

www.cruiser54.com

My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline  
post #4 of 4 Old 02-04-2014, 10:58 PM Thread Starter
bozzman080
Registered User
1987 MJ Comanche 
 
Join Date: Feb 2014
Location: castle rock
Posts: 4
Shes alive , i can not believe it was the cat it was beyond plugged up so if you have done all that i did check that
bozzman080 is offline  
Reply

Tags
hesitating , no power

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome