small trouble ..... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > MJ Comanche Technical Forum > small trouble .....

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineG2 Disc Brake Conversion Kit for Jeep Wrangler YJ TJ LJ Ch

Reply
Unread 12-09-2012, 12:08 AM   #1
gus7
Registered User
 
Join Date: Jan 2012
Location: willaimsburg, va
Posts: 27
small trouble .....

ok this just started a few days ago - hard starting ...lean outs ..loss of power and loss of fuel mileage ... any know specs of the TBI i look at all i know of like map temp senders crank all so far good ! fuel psi ? 12 psi ? thxs

gus7 is offline   Reply With Quote
Unread 12-09-2012, 05:37 AM   #2
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,059
From Joe Peters and well stated. Sounds harsh but just makes sense:

“Let’s play a game.

You pretend that you are the only one that knows what year/engine/model, etc that you are asking about.

We will all pretend you never asked a question until you provide at least the bare minimum of information about your vehicle”.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote
Unread 12-09-2012, 06:21 PM   #3
ftpiercecracker
Registered User
1990 MJ Comanche 
 
Join Date: Jul 2011
Location: woodbury, Tennessee
Posts: 348
Rough day Cruiser?
ftpiercecracker is offline   Reply With Quote
Unread 12-09-2012, 06:28 PM   #4
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,059
Quote:
Originally Posted by ftpiercecracker View Post
Rough day Cruiser?
Nah. Just stating the facts. Has the OP responded yet with more info?
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote
Unread 12-09-2012, 10:51 PM   #5
gus7
Registered User
 
Join Date: Jan 2012
Location: willaimsburg, va
Posts: 27
sorry a bit short .....

she is 1989 2.5 liter with TBI ...fuel psi is at 15 psi ,yes on the good spark ... map has 1.5 volts tps at base running

Last edited by gus7; 12-11-2012 at 08:06 PM..
gus7 is offline   Reply With Quote
Unread 12-17-2012, 08:15 PM   #6
Reptile
Web Wheeler
1991 XJ Cherokee 
 
Join Date: Feb 2011
Location: Bakersfield, CA
Posts: 1,297
I like that game Cruiser.

Well, the 2.5l engine would explain the lack of power...
Reptile is offline   Reply With Quote
Unread 12-18-2012, 10:06 PM   #7
Reptile
Web Wheeler
1991 XJ Cherokee 
 
Join Date: Feb 2011
Location: Bakersfield, CA
Posts: 1,297
...Start by checking the state of battery connections, distributor and refreshing your grounds (this is a big deal). After that there are so many possible causes and you might be shooting in the dark: O2 sensor, coolant temp sensor, plugs to name a few.
Reptile is offline   Reply With Quote
Unread 12-19-2012, 04:13 AM   #8
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 10,059
Quote:
Originally Posted by Reptile View Post
...Start by checking the state of battery connections, distributor and refreshing your grounds (this is a big deal). After that there are so many possible causes and you might be shooting in the dark: O2 sensor, coolant temp sensor, plugs to name a few.
Super big deal is the braided cable where it connects to the firewall. This must be removed, the paint scraped off the firewall, and the cable end polished up nicely, and then reattached securely. Check the cleanliness of the cable at the back of the head also.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
My Jeep Technical Photos

http://www.cherokeeforum.com/g/album/1725214
cruiser54 is offline   Reply With Quote
Unread 12-20-2012, 09:24 AM   #9
gus7
Registered User
 
Join Date: Jan 2012
Location: willaimsburg, va
Posts: 27
small troubles

i have two heavy ground cables one to the block and body - i used no-oxs [https://www.sourcetelsupply.com/cata...ucts_id=131]on the them too O2 is working right temp sensors are good too ..this hell started 3 weeks ago back firing and lean work mode next rich as hell ---out of the blue !
gus7 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.