JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   MJ Comanche Technical Forum (http://www.jeepforum.com/forum/f53/)
-   -   mj won't start (http://www.jeepforum.com/forum/f53/mj-wont-start-1531199/)

Bryce527 06-01-2013 10:55 PM

mj won't start
 
Okay so I have an 88 Comanche with the 2.5L engine. The thing will crank but just won't start. I'm having trouble figuring out what the issue is. And to be clear I am very unexperienced with working on cars.

Anyways. I have purchased a brand new battery for it. I have checked what is getting voltage. When it's trying to start there is electricity going from the ignition coil to the distributor but there isn't any coming from the distributor to the spark plugs. One would assume I guess that the distributor has gone bad, and that could be a possibility. As i dont know much about cars What else could be the culprit of this problem? Through research I've found maybe that the crankshaft position sensor has gone bad, or does this have nothing to do with it? What could cause the problem of power not coming from the distributor? If the distributor has not been properly installed would this problem happen? Or is the problem something that I have not mentioned?

1SICKMJ 06-03-2013 01:30 AM

The CPS(crankshaft position sensor) is pretty much in charge of timing of the spark, and fuel injectors. Could it be the culprit yes. But you said the Coil has power, and its going to the distributor. So Im assuming you mean the spark plug wire that goes from the coil to the center of the distributor has spark, did you pop open the distributor and see if the rotor or any of the points on the distributor cap are corroded/rusted?

Bryce527 06-04-2013 08:48 AM

Okay thanks

Well there's 12volts coming from the coil to the distributor, when the engine is cranked (shouldn't the 12volts be turned into a higher voltage in order to produce spark? if so,) there isn't spark though. I have look at the distributor, and the rotor. the rotor rotates when its cranked. I have purchased a new cap and rotor. planning to replace it this afternoon.

cruiser54 06-05-2013 06:05 AM

Renix CPS Testing and Adjusting



Renix CPSs have to put out a strong enough signal to the ECU so that it will provide spark.

Most tests for the CPS suggest checking it for an ohms value. This is unreliable and can cause some wasted time and aggravation in your diagnosis of a no-start issue as the CPS will test good when in fact it is bad.

The problem with the ohms test is you can have the correct amount of resistance through the CPS but it isn’t generating enough voltage to trigger the ECU to provide spark.

Unplug the harness connector from the CPS. Using your voltmeter set on AC volts and probing both wires in the connector going to the CPS, crank the engine over. It won’t start with the CPS disconnected.

You should get a reading of .5 AC volts.

If you are down in the .35 AC volts range or lower on your meter reading, you can have intermittent crank/no-start conditions from your Renix Jeep. Some NEW CPSs (from the big box parts stores) have registered only .2 AC volts while reading the proper resistance!! That’s a definite no-start condition. Best to buy your CPS from Napa or the dealer.

Sometimes on a manual transmission equipped Renix Jeep there is an accumulation of debris on the tip of the CPS. It’s worn off clutch material and since the CPS is a magnet, the metal sticks to the tip of the CPS causing a reduced voltage signal. You MAY get by with cleaning the tip of the CPS off.

A little trick for increasing the output of your CPS is to drill out the upper mounting hole to 3/8” from the stock 5/16”, or slot it so the CPS bracket rests on the bell housing when pushed down. Then, when mounting it, hold the CPS down as close to the flywheel as you can while tightening the bolts.




Revised 01-26-2013

Bryce527 06-05-2013 09:41 AM

I replace the cap and rotor. And also the ignition control module. Still no spark at the distributor center. What else could it be?
The cps? And what else?

cruiser54 06-05-2013 02:22 PM

1 Attachment(s)
See post #4.

Bryce527 06-06-2013 09:54 AM

Okay replaced the crankshaft position sensor. Still not starting. I'm guessing it is some electrical or computer problem? What else could it be?


The time now is 03:09 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.