JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   MJ Comanche Technical Forum (http://www.jeepforum.com/forum/f53/)
-   -   Internal Slave Replaced (http://www.jeepforum.com/forum/f53/internal-slave-replaced-1519033/)

HanksRide 05-05-2013 01:08 PM

Just replaced the internal slave and new clutch and pressure plate on a 91 MJ, clutch seems to engage and work perfectly but pedal feels really soft. No slack in it just easy to push down, more so than what I think it should be. Any ideas, we bled it pretty good. Did not replace master cylinder, think that would help? BTW it is an AX15 with 4.0 L engine.

ftpiercecracker 05-05-2013 09:55 PM

Your clutch works great and its easy to push down and your complaining about it???

HanksRide 05-05-2013 10:09 PM

Quote:

Originally Posted by ftpiercecracker
Your clutch works great and its easy to push down and your complaining about it???

Just so happens that I am complaining about it.. This is the vehicle that carries my daughter around quite often and it means something to me to have it in good working order. I am 45 years old and have driven a standard transmission for most of my life and I know when a clutch does not feel right. Am I a expert mechanic? No I am not but I have learned a tremendous amount from asking questions on this forum. It is responses like that, that keeps people from asking questions, especially noobs that are unsure of themselves and worried they are asking a dumb question. If you do not have anything constructive to say then please refrain from answering my questions.


The time now is 08:52 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.