I got a miss issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > MJ Comanche Technical Forum > I got a miss issue

Building a Bumper?Ruffstuff Axle Simple Swap Kit!~Artec JK 1 TON SWAP~

Reply
Unread 09-24-2013, 07:27 PM   #1
Crash7500
Registered User
1987 MJ Comanche 
 
Join Date: Sep 2013
Location: Rural valley, Pa
Posts: 4
I got a miss issue

I have a miss issue. It is only once in awhile. I have changed the plugs wires cap and button and still does it. It does it when you first start it and take off then it smooths out and then it will miss like one time just every once in awhile some days more than others. It is a 2.5L. Anyone have any ideas. Thanks. Some one took the cat converter off it and the O2 sensor is just hanging under the truck, would that do it?

Crash7500 is offline   Reply With Quote
Unread 09-28-2013, 06:30 AM   #2
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,789
Remove the braided ground strap from the firewall. Scrape the paint from under it and clean it's terminal. Reinstall tightly.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote
Unread 12-29-2013, 02:58 PM   #3
Crash7500
Registered User
1987 MJ Comanche 
 
Join Date: Sep 2013
Location: Rural valley, Pa
Posts: 4
I did the ground wire deal, all intake bolts seem to be tight. Would you think it could be the coil
Crash7500 is offline   Reply With Quote
Unread 12-29-2013, 03:00 PM   #4
Crash7500
Registered User
1987 MJ Comanche 
 
Join Date: Sep 2013
Location: Rural valley, Pa
Posts: 4
When it does it. It seems to be like under a load right befor it will down shift and if you floor board it it picks right up and goes
Crash7500 is offline   Reply With Quote
Unread 12-29-2013, 03:00 PM   #5
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,789
Quote:
Originally Posted by Crash7500 View Post
I did the ground wire deal, all intake bolts seem to be tight. Would you think it could be the coil
Click on my link below and do posts 1, 3, and 4.
__________________
Quote:
Originally Posted by chris87xj View Post
If you own a Renix Jeep, you'll want to check this out. >

An index to over 25 write-ups can be found in Post #1.

Cruiser's Mostly Renix Tips
Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.