Hard starting problem, need help - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 08-30-2012, 04:14 PM Thread Starter
87manche17
Registered User
1987 MJ Comanche 
 
Join Date: Jul 2012
Location: Harlan
Posts: 168
Hard starting problem, need help

Ok, Im having some wierd trouble out of my MJ. It takes it forever to start, it trys to start but to no avail. When it does start it runs perfect, and doesnt have any problems whatsoever. I have good fuel pressure, good spark, and air. But now when I unplugged my MAP sensor it tried to fire, and it fired up. I had to feather the gas pedal to keep it running, but it ran. So Im kinda wonderin if my MAP sensor is bad, or is thier something I havent though of.

87manche17 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 08-31-2012, 02:39 PM
newfieZJ
Registered User
1995 ZJ 
 
Join Date: May 2008
Posts: 6,557
I would think your fuel lines are draining back into your tank . Check valve Map sensor might have been plugged back in right after it was running ?

1995 Orvis build

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1988 MJ build

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1998 Slate 5.9 build

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1998 Platinum 5.9 build

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
newfieZJ is offline  
post #3 of 11 Old 08-31-2012, 04:50 PM Thread Starter
87manche17
Registered User
1987 MJ Comanche 
 
Join Date: Jul 2012
Location: Harlan
Posts: 168
I have changed the battery for a new one and it starts, but im still having trouble. Because I have to press the gas pedal to get it to start.But once started its fine. WTF?
87manche17 is offline  
post #4 of 11 Old 08-31-2012, 06:25 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,238
Gas pedal have to be pressed to the floor?
cruiser54 is offline  
post #5 of 11 Old 08-31-2012, 06:42 PM Thread Starter
87manche17
Registered User
1987 MJ Comanche 
 
Join Date: Jul 2012
Location: Harlan
Posts: 168
Yep, if I dont it will crank all day.
87manche17 is offline  
post #6 of 11 Old 08-31-2012, 07:19 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,238
Check the hose to the MAP sensor from the throttle body. Can't be crushed, crimped, cracked or split. Must fit tightly on both ends. Make sure the electrical plug to the MAP is seated tightly.
cruiser54 is offline  
post #7 of 11 Old 08-31-2012, 08:28 PM Thread Starter
87manche17
Registered User
1987 MJ Comanche 
 
Join Date: Jul 2012
Location: Harlan
Posts: 168
Ive checked it 3 or 4 times thier both connected fine. It woulndnt be faulty would it?
87manche17 is offline  
post #8 of 11 Old 08-31-2012, 08:36 PM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,238
The MAP? Sure could be. I just always check the simple stuff first.
cruiser54 is offline  
post #9 of 11 Old 09-01-2012, 07:09 AM Thread Starter
87manche17
Registered User
1987 MJ Comanche 
 
Join Date: Jul 2012
Location: Harlan
Posts: 168
Ok thanks, I'll get back to ya when I change the MAP sensor.
87manche17 is offline  
post #10 of 11 Old 09-01-2012, 07:16 AM
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott
Posts: 11,238
Got a meter and know how to use it?
cruiser54 is offline  
post #11 of 11 Old 09-01-2012, 10:01 AM Thread Starter
87manche17
Registered User
1987 MJ Comanche 
 
Join Date: Jul 2012
Location: Harlan
Posts: 168
Ok now it only starts if its warm outside. If i try to start it in the morning, it will just crank and catch.
87manche17 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Hard starting problem with my 87 MJ 87manche17 XJ Cherokee Technical Forum 0 08-26-2012 07:37 PM
Hard starting YJBully XJ Cherokee Technical Forum 5 09-21-2010 08:11 AM
Hard starting 1996 Problem? 4.0H.O.XJ XJ Cherokee Technical Forum 3 12-10-2008 03:47 PM
Hard starting? lilseth0014 XJ/MJ Cherokee Non-Technical Forum 1 07-01-2008 09:24 PM
85 2.5L Hard starting problem/ no power RedJeepXJ XJ Cherokee Technical Forum 4 12-26-2002 06:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome