good old 4.0 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > MJ Comanche Technical Forum > good old 4.0

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great valueIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 03-21-2008, 11:13 AM   #1
kinkydoints
Registered User
1991 FSJ Wagoneer 
 
Join Date: Feb 2008
Location: KY.
Posts: 10
good old 4.0

I have been working to get this 1991 4.0L wagoneer limited to run with out squeeling from the serpintine belt hitting on the timing chain cover. I can see it . I have changed waterpump , alltinater, ideler pully,and belt. this is the old style that has the adjuster under the powersteering pump. It seems like the belt is just too close to the timing chain cover at the engine were it comes off the cluchfan pully and to the engine main vibration damper pully? Im looking at the cluchfan pully now but that looks like a dealer part or junkyard. there seems to be no adjustment in the alltinators mount just the 2 bolts that hold it in place...Is there any way I missed something. I wondering if I file down the alt. mount on the alt and add a spacer washer to move the pully out about 2mm. Im just guessing!

kinkydoints is offline   Reply With Quote
Unread 03-21-2008, 08:05 PM   #2
B_Mabus
Registered User
1994 XJ Cherokee 
 
Join Date: Jun 2007
Location: Pa
Posts: 115
I had this happen on my Cherokee. The harmonic balancer is going bad. Look under it and see if the Harmonic Balancer is walking back and rubbing on the cover. I had to get a new one good luck with it. I didnt have a squeal of the belt just that the harmonic balancer was rubbing on the timing chain cover.
__________________
'89 XJ 183,xxx BLACK with olive drab....parts jeep
'90 XJ 177,xxx WHITE....sold
'90 XJ 153,xxx RED...wip
'94 XJ 145,xxx WHITE...current ride

Nothing runs like a Renix
B_Mabus is offline   Reply With Quote
Unread 03-22-2008, 09:02 AM   #3
kinkydoints
Registered User
1991 FSJ Wagoneer 
 
Join Date: Feb 2008
Location: KY.
Posts: 10
ya well this old engine has 165,000 miles but still goes good. Ill check this out thanks!
kinkydoints is offline   Reply With Quote
Unread 03-23-2008, 12:02 PM   #4
kinkydoints
Registered User
1991 FSJ Wagoneer 
 
Join Date: Feb 2008
Location: KY.
Posts: 10
Checked that walking balancer out that was the trouble gave it a little push for now worked for a quick fix.
were did you get your Vibration Damper pully at? dealer or parts store? junk yard?
kinkydoints is offline   Reply With Quote
Unread 03-24-2008, 09:55 AM   #5
carnuck
Registered User
1984 J-Series Truck 
 
Join Date: Nov 2004
Posts: 3,212
you can get them new from NAPA.
carnuck is offline   Reply With Quote
Unread 03-31-2008, 11:48 AM   #6
kinkydoints
Registered User
1991 FSJ Wagoneer 
 
Join Date: Feb 2008
Location: KY.
Posts: 10
Thats it ! the squeek! is gone.

any Idea about a head gasket change ? as far as parts needed, do I need to change the injecter seals, this motor has the mpi . Im guessing both intake and exhast gaskets, valve cover gasket
kinkydoints is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.