Fuel Pump Dead? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Cherokee & Comanche Forums > MJ Comanche Technical Forum > Fuel Pump Dead?

TJ 5.25" Speaker Adapters - NalinMFGTJ, YJ & LJ Drop Down Tail Gate Conversion KitLJ Suspension Systems from Clayton Off Road

Reply
Unread 07-30-2012, 06:15 PM   #1
DeejayZeejay
Registered User
1994 ZJ 
 
Join Date: Mar 2012
Location: Macomb, Michigan
Posts: 325
Fuel Pump Dead?

Well I picked up this 88 Jeep MJ with a 4.0 5 speed a couple weeks ago. Ran pretty good, horrible tires causing death wobble(right front tire was seperated). 123k miles. $1275 and it was mine. Changed most the fluids(eng oil, gear box and diff). Tune up and new tires. Seemed to crank a little longer than usual but always fired up.... Last week it wouldnt start. Had to use ether and mess with it to get it going. Always had a loud humming from the fuel pump. Now at work, went to go on a run and wont start up. Primed it, gave it ether and nothing. Hit the fuel rail valve and no gas came out. And I hear no humming from the pump. Fuel pump died? Probably original to.

__________________
Jeeps 4 Life!
DeejayZeejay is offline   Reply With Quote
Unread 07-31-2012, 07:02 AM   #2
Pete M
Registered User
1988 MJ Comanche 
 
Join Date: Sep 2005
Location: S/E Michigan
Posts: 1,834
clean the ground located behind the drivers side taillight. worth a shot at least.
__________________
-88 MJ; 4.0L, ex-2wd, TJ ax15/231, 78 Ford D44 w/spool, 9" w/posi, 33" trXus MTs, custom roll-bar/bumpers/etc.
Also an 86 MJ Metric ton and 2 '90 MJs
Projects/wheelin' pics: picturetrail.com/petermontie
My email: petermontie@hotmail.com
ComancheClub.com/forums
Pete M is offline   Reply With Quote
Unread 08-02-2012, 05:55 AM   #3
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,783
There's a rubber hose in the tank between the fuel pump and the external flange. They get pretty crapped out. Change fuel filter?
cruiser54 is offline   Reply With Quote
Unread 08-02-2012, 07:59 AM   #4
97_4popper
Registered User
1990 MJ Comanche 
 
Join Date: Jan 2005
Location: Guston, KY
Posts: 463
Check that ground as Pete said.
If you're not hearing the pump when you turn on the key, it's probably either the ground or the pump has given up the ghost.
__________________
90 MJ 4.0 4X4 5sp LB Pioneer Big Ton.
Truck contains parts from 3 MJs, 2 XJs, 1 TJ and a dishwasher.
http://img.photobucket.com/albums/v1...IMG_0101-2.jpg
Check out comancheclub.com...
My build thread: http://comancheclub.com/forums/viewt...hp?f=7&t=27756
Wifes: 97 TJ 2.5 4X4 5sp 31's stock. . . Slow but; reliable.
97_4popper is offline   Reply With Quote
Unread 08-02-2012, 06:36 PM   #5
DeejayZeejay
Registered User
1994 ZJ 
 
Join Date: Mar 2012
Location: Macomb, Michigan
Posts: 325
Couple questions. The ballast resistor, does that control the fuel pump? Also im not familiar with this starter solenoid by the battery... Would either of those kill power to the pump?
__________________
Jeeps 4 Life!
DeejayZeejay is offline   Reply With Quote
Unread 08-02-2012, 07:05 PM   #6
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,783
The fuel pump gets a full 12 volts on cranking and then switches power to one side of the ballast resistor so it can reduce the voltage coming out to about 10 volts so the pump is quieter.
cruiser54 is offline   Reply With Quote
Unread 08-02-2012, 07:23 PM   #7
Pete M
Registered User
1988 MJ Comanche 
 
Join Date: Sep 2005
Location: S/E Michigan
Posts: 1,834
Yup, power gets diverted to run through the resistor after the truck is running.

Have you checked for power at the pump? There are 3 wires at that connector: ground, power, and signal from the level sensor.
__________________
-88 MJ; 4.0L, ex-2wd, TJ ax15/231, 78 Ford D44 w/spool, 9" w/posi, 33" trXus MTs, custom roll-bar/bumpers/etc.
Also an 86 MJ Metric ton and 2 '90 MJs
Projects/wheelin' pics: picturetrail.com/petermontie
My email: petermontie@hotmail.com
ComancheClub.com/forums
Pete M is offline   Reply With Quote
Unread 08-03-2012, 09:05 AM   #8
DeejayZeejay
Registered User
1994 ZJ 
 
Join Date: Mar 2012
Location: Macomb, Michigan
Posts: 325
Im not getting power to the pump.... Which is brand new. My old pump was real loud when it did work.
__________________
Jeeps 4 Life!
DeejayZeejay is offline   Reply With Quote
Unread 08-03-2012, 01:08 PM   #9
97_4popper
Registered User
1990 MJ Comanche 
 
Join Date: Jan 2005
Location: Guston, KY
Posts: 463
You've checked it with a meter?

If you're not getting power to the pump, then check your wiring.
__________________
90 MJ 4.0 4X4 5sp LB Pioneer Big Ton.
Truck contains parts from 3 MJs, 2 XJs, 1 TJ and a dishwasher.
http://img.photobucket.com/albums/v1...IMG_0101-2.jpg
Check out comancheclub.com...
My build thread: http://comancheclub.com/forums/viewt...hp?f=7&t=27756
Wifes: 97 TJ 2.5 4X4 5sp 31's stock. . . Slow but; reliable.
97_4popper is offline   Reply With Quote
Unread 08-03-2012, 04:45 PM   #10
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,783
Fuel pump relay may be bad:
renix-relay-center.jpg  
cruiser54 is offline   Reply With Quote
Unread 08-06-2012, 10:50 AM   #11
DeejayZeejay
Registered User
1994 ZJ 
 
Join Date: Mar 2012
Location: Macomb, Michigan
Posts: 325
So I checked the wires and all is good. Put a new ground connector at the pump. I left the pump out just to make sure it was good before going in. Nothing. Does the pump need to be installed in the tank to complete the ground? New relay, ballast resistor and the solenoid by the battery. Little stumped here now...
__________________
Jeeps 4 Life!
DeejayZeejay is offline   Reply With Quote
Unread 08-06-2012, 12:49 PM   #12
DeejayZeejay
Registered User
1994 ZJ 
 
Join Date: Mar 2012
Location: Macomb, Michigan
Posts: 325
Also tried to jump the pump from the relay and it sparked....
__________________
Jeeps 4 Life!
DeejayZeejay is offline   Reply With Quote
Unread 08-06-2012, 02:29 PM   #13
DeejayZeejay
Registered User
1994 ZJ 
 
Join Date: Mar 2012
Location: Macomb, Michigan
Posts: 325
After messing with it all day today, I have come to realize its the power wire from the pump to the cab.... Now I just need to replace that wire....hopefully.
__________________
Jeeps 4 Life!
DeejayZeejay is offline   Reply With Quote
Unread 08-06-2012, 03:39 PM   #14
DeejayZeejay
Registered User
1994 ZJ 
 
Join Date: Mar 2012
Location: Macomb, Michigan
Posts: 325
Problem solved! It was the 2 wire connector that goes through the top of the pump bracket. So I straight wired it through the hole with a grommet and some gas resistant sealant. What a pita....
__________________
Jeeps 4 Life!
DeejayZeejay is offline   Reply With Quote
Unread 08-06-2012, 03:51 PM   #15
cruiser54
Web Wheeler
 
cruiser54's Avatar
1990 MJ Comanche 
 
Join Date: Oct 2009
Location: Prescott, Arizona
Posts: 9,783
Good job.
cruiser54 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.